Trigger instrument track from midi track means mute / solo disabled after freeze?

Hi Folks,

If i use a midi track to trigger an instrument track, is it correct that after i freeze that instrument, i can no longer activate mute or solo on that frozen track in the arrange window?

Or is this a bug?

The weird thing is, if i open up the mixer, i can solo / mute there.


I’m on:

Win 8.1


That’s correct. The source Instrument is frozen (so the “exported” audio file is played back in the background instead of playing it back in real time from the MIDI data), so it doesn’t make sense to Solo or Mute the individual Tracks of this instrument.

Hmmmm, that’s a bit strange, because if i freeze an instrument that doesn’t take its midi from an external midi track, then i CAN solo / mute in the arrange window.

Also, when you’re in the arrange window, even if a track is frozen or not, you still might want to solo or mute it.

It’s annoying that you need to go the mixer just to do this!

So basically what you’re saying is that in the arrange window, although an instrument track looks like an audio track in a way, it’s actually the midi that you’re muting or solo’ing. And because that track takes its midi from an external track, that’s why you no longer have the option to mute or solo.


That logic can be defeated by performing the following experiment: in a fresh project, set up a VSTi with a very short percussive sound, and insert a super long reverb in the FX rack. If you trigger the sound, then quickly mute the instr. track, you would expect the reverb tail to still be heard (if you were only muting a midi track). But that’s not what happens.

So to me it makes no sense that in the scenario described in my first post, the solo & mute buttons of the audio path also get disabled!

Unless I’m missing something the mute/solo states of frozen tracks are identical in the mixer and the arrange.
the midi is disabled but the instrument output is where you can solo or mute the frozen audio.

@Grim: i’m wondering if it’s a bug.

Could you do me a favour and try the following:

Create an instrument track. Set its midi input to “no input”

Now, create a midi track and set its output to the instrument that you created a moment ago.

Draw some midi notes on the midi track. Check it’s creating sound, then freeze the instrument track.

When i do all this, both the midi and instrument tracks become greyed out, INCLUDING the mute and solo buttons on the instr. track, and they’re no longer operational. But if i go to the mixer view they ARE operational there!

Ahh…I was previously doing it with a rack instrument which behaves as I described. Track instruments do behave as you describe.

The Instrument track is tricky. It’s different when you Solo/Mute it in the Arranger window or in the MixConsole.

In the Arranger (Project) window, you Solo/Mute the source MIDI data. So even if you Mute the Instrument track in the Arranger, the Instrument still can be used and produce a sounds of other MIDI tracks routed to this instrument.

In the MixConsole you Solo/Mute the Stereo Out Audio Return Channel of the Instrument. So if you Mute it, you cannot hear the signal from other MIDI tracks routed to the instrument anymore.

Regarding the freeze, if I freeze the Instrument (in the Rack), I cannot Solo/Mute any MIDI Track routed to this Instrument (in the Arranger window). These buttons are disabled. Is it the same in your side?

Hi Martin,

Thanks for looking in to this further.

That’s correct, but not if you have a standalone VSTi track. Because in that scenario, it acts like a midi AND audio track.

But, once you route more midi tracks to the same instrument, that (original VSTi) track just becomes a midi track.

But the annoying thing remains that in this scenario, you no longer have a way to mute or solo that instrument in the project window, unless you create an extra group for it.

Actually, this would all be less problematic if VSTi tracks had midi sends. Because the whole reason i’m routing a midi track to a VSTi track is that i want to trigger envelopes (Xfer LFO Tool, Cableguys ShaperBox, MXXX) that are in the VSTi’s FX rack.

If instrument tracks had midi sends, there would be no need for the external midi track.

Sorry, I’m lost now. Where is the Freeze function in your scenario?

On the track in the left, in the inspector, next to the “show lanes” button.

:slight_smile: Thanks, I know this.

But I don’t understand, when does the Freeze function comes to the place in your scenario. I will try to recap:

  • Instrument Track (HSSE), with some MIDI data.
  • MIDI track routed to the HSSE (instrument) with some other MIDI data.
  • Freeze the Instrument.

=> Now, you cannot Solo the Instrument track (or MIDI track) in the Project window. But you can Solo the Instrument (Audio Return) Channel in the MixConsole.

Am I right?

If you use Instrument track only (no other MIDI track routed to it), and freeze, you can use Solo of the Instrument Channel even in the Project window.

You would like to be able to do the same, even if other MIDI tracks are routed to the Instrument track, to be able to Solo the Instrument Channel even in this case. An I right?

Yes, all correct.

The point is: if the instrument is taking external midi, and you freeze it, you can do nothing more with it.

So why is the mute and solo option removed ON THE TRACK but not in the mixer?

I’m working most of the time in the project window, so as i work further on the song, i want to constantly mute some elements in the mix as introduce new sounds, so my frustration is having to go to the mixer to mute that frozen instument, while all other tracks / groups / whatever can be muted in the project window.

Can you see the logic in the solo / mute option being removed in the project window but not in the mixer?

Yes, I can see the logic. While you route multiple MIDI sources to the instrument, the Instrument Track becomes a MIDI track in the Project window. So it behaves the same way, as you mute any other of the MIDI tracks (routed to the instrument). So when the Instrument is frozen, it takes no effect.

At the other hand, I see your point.

As a workaround, you could add a Mute automation lane, and change the status of the Mute in the Automation track of the Instrument track from the Project window. This one is linked with the Channel, so you can Mute it from here. I know, its a workaround…

I’m running into a similar problem, and maybe my expectations are flawed. I freeze a rack instrument and am working largely in the Project window where I have several MIDI tracks controlling rack instruments. I solo another non-frozen MIDI track and expect to hear only that track/instrument, yet I hear all the frozen tracks as well. I expect NOT to hear any frozen tracks - I expect the frozen tracks to behave as if they weren’t frozen. Is that logic flawed? I do have solo defeats on all my rack instruments. When nothing is frozen and I solo a MIDI track, I only hear that track, so my expectation is it would behave the same way when frozen. Thanks for any insight.


Is the frozen Instrument track routed to the same Group or output as the Instrument of the non-frozen MIDI?

Do you freeze the Track (in the Project Window) or the Channel (in the MixConsole)?

The frozen instrument track is not routed to the same output of the instrument I’m soloing. I froze the track via the VST instruments dialog. That’s the only way I’m aware of to freeze a VST instrument. All my instrument and group channel outputs in the MixConsole are solo-defeated, so all I ever have to do to solo a MIDI instrument is to solo it in the Project window. When I freeze an instrument, I expect it to behave the same way as if it wasn’t frozen. Does that make sense?

I mean output of the instrument.

The output of the instrument is routed to a group channel.

And the other one?

It’s going to a different group channel.