UAD and Wavelab 10 latency

Hi, I’ve recently been Mastering an album in Wavelab Pro 10 using the audio montage system.
It’s a 10 song album, and on each clip was a plug-in chain. A typical 8 plug chain included Steinberg stock plugs, Waves, and UAD plugs.
It’s pretty much unusable with the UAD plugs inserted into each song’s clip chain. UAD Ampex tape had a whopping 239ms of latency, Massive Passive EQ 188ms, and Teletronix LA2 188ms also.
When I pressed play on the montage, I could literally go and make a cup of tea before I heard any sound.
When I removed all the UAD plugs, the problem immediately disappeared as the stock and Waves plugs only have a latency of 1 to 2 ms each.

I have a pretty powerful PC, lots of UAD external power, a Sattelite, and a PCI card, and these UAD plugs do not cause a delay in bigger sessions in Cubase 11, so I’m not sure what the issue is. Does anyone else have a similar issue or know of a solution? Thanks.

In all my years of doing mastering (26) I don’t think I have ever used more than 4 plugins for mastering a track…FWIW

That’s genuinely very interesting, but it’s not really relevant to my latency issue.
I could use 10 waves or stock plugs per tracks with next to no latency. 4 Uad plugs per track and things grind to a halt. It’s not the number of plugs that’s causing the problem in this instance, it’s the type of plug.


What are UA saying about WaveLab 11 and UAD ?

regards S-EH

Nothing, as far as I’m aware. It’s officially tested on Cubase 11, but Wavelab isn’t mentioned. (I’m using WL 10 for the record)
I know from forums, experience etc that lots of people use UAD in wavelab, some presumably without issues, so just wondering if anyone has any any similar problems.

I think Justin Perkins will answer this :slight_smile:

regards S-EH

Thanks! Hope so

Can you show us a screen shot of your UAD Control panel settings?

Also, yes there are definitely some UAD plugins that do not work well in WL Montages on some systems. (Windows).

I’ll see if I can find my list.


1 Like

I really only use the UAD ATR-102 now and then these days. If you post a screen shot if your plugin chain (not the specific settings, just the inserted plugins) and the UAD Control Panel settings I can test it out here but I’ve certainly never experienced that kind of latency.

What sample rate is your session at?

Does it happen with only UAD plugins inserted or is there perhaps another plugin in the chain that is exaggerating this?

1 Like

Thanks guys,

Heres a screenshot of that session. On this example, the UAD plugins are only on the first song (I’d removed from all the others) and I’m still getting crazy delay.
Session was 44k (CD client) , you can see the latency in ms on the plugin list . UAD panel is in the shot too, all looks normal there, plenty of headroom.

And yes, this seems to be a UAD issue…when I remove them from the session, everything runs smoothly, even when I replace them with more Waves plugins.

Interesting. I’ll see what I can test here with that chain. I should have most of those plugins.

I had never seen the FBW meter before but it seems indicate it’s a FireWire bandwidth meter.

Are you using a UAD audio device too? As a test, do you get different results if you use another audio device if you have one, or even the built-in output of your computer?

1 Like

Hi Justin, thanks for your time.

Yeah, I have a UAD firewire satellite Duo and an internal PCI card. My interface is a Steinberg UR816C, I took your advice and tested it with the generic PC audio driver and I still got the delay. I did discover something though…when I press play, the UAD meter ‘resets’ like it’s loading again. This could account for the delay. I have ‘Reset plug-ins when Starting Playback’ UNCHECKED in the preferences, yet that’s what it still seems to be doing.
Perhaps the Firewire Satellite is operating outside of the parameter and it’s resetting every time you start playback. Looks like a firewire issue. For now, I’m going to have to forget about my UAD plugs and Wavelab. (Which is a bit of a shame as they cost a fortune!)

Interesting. I don’t have much time to experiment today or tomorrow but I can say in over 10 years of using UAD and WaveLab I haven’t ever had this happen, and I’m often at 96k sample rate.

I have a PCIe Octo card no FireWire anything to test with.

One other option to check for now is in the Plugin Preferences area. There is a DYN option for each plugin.

This is designed so that UAD plugins are only taxing the UAD DSP when they are truly needed but since you’re having such. big issue, you may want to see what happens when you set it to the opposite of whatever your UAD plugins are set to now.

See attached:

Thanks for the suggestion. I just tried it out. I unchecked all the ‘DYN’ boxes on the relevant UAD plugs. Unfortunately, it didn’t change the delay.
I’m thinking it’s a firewire bug. If so, most of the UAD users are using USB or PCI so will never encounter it.
Although, as an experiment, I switched off my firewire satellite in the UAD panel and tried to load the plugs solely through my UAD PCI card. Surprisingly, this didn’t seem to make any difference.

To reiterate, this issue doesn’t happen using the UAD satellite in Cubase 11. It works perfectly well on playback there, no resets etc… but in Wavelab it resets on playback and you get the delay.

Ah, maybe @PG1 can weigh in on what’s going on but it does seem to be specific to FireWire and WaveLab.

Surprisingly, UAD hasn’t moved to VST3 format yet which could help since VST2 is such old technology at this point.

Sorry I can’t help more but I can’t reproduce the issue here with what I have.

I have used WL and UAD, and UAD only (except for a Voxengo Elephant as TP limiter gatekeeping) for many years, I should say before Stonehenge was built:-). Today I am on WL11
I have had no problems whatsoever and never thought about this, I am on Mac, sine many years back but I started on PC and cannot remember anything like this.
SO I did an experiment, 44/16 17 trax montage stereo as a CD master, I inserted 14 UAD plugins per clip including ShadowHill Comp, Pulktecs, P-EQ. P-Limiter, Studer and Ampex tape recorder and some more, then I set 6 UAD plugins on the Track, and yes there are a noticeable latency before play, You are right.
But when I run plugins as I usually do, about 1-3 per clip and 6-7 on the track, there are no problems, a slight short little gap perhaps but not in anyway bothering.
And comparing the audio quality I can cope with that very, very tiny lately at start play.
Yes Waves is faster there is no play gap with waves, but I have not found the same sonic quality really yet in Waves, very good but not as UAD, as I have sold all my analog gear and use UAD in the box only…
I have an Apollo QUAD and a Satellite on Thunderbolt 2.

I also did test the way You did, with different brands Steinberg, UAD and Waves, and there is a bit of Latency when UAD is inserted, but still not annoying.

I say as Justin, send us a screenshot of your setup and I will try if I have the plugs available.

Cheers Uffe

1 Like

Hi, Thanks for your reply. I shared my chain in the post above

I’m thinking it’s a firewire/wavelab/UAD issue, not necessarily UAD /Wavelab

No problem, thanks for your time

Using Wavelab 11 with an RME Fireface 800 here and reproduced your chain, except I used C4 instead of C6 and didn’t get the latency you’re seeing.
Have you checked the “Use Extra Buffering” setting in the UAD Control Panel? I have the DSP load limit set to 95% and DSP Loadlock unchecked.
I have left the DYN option checked for all my UAD plugins. Here is what my load looks like on the meter
I’m using a UAD2 PCIe Quad card.


Since my system is Firewire, let me know if I can provide any other info or try anything for you. I’m on Win 10 1909.

1 Like

Searched through the thread and still don’t see what I originally asked for. A screenshot of the control panel settings.

This was to check the Extra Buffering setting Etc.