Unable to installl cubse 8.5

I have been upgrading since sx3 with no issue.

How do I install 8.5? It keeps crashing and saying there is an error. Never any types of issue…

Man, I knew I should have left this one alone

Well it should be easy to pinpoint the problem with all the detailed info you have supplied :wink:

lol - it was early AND I WAS frustrated my bad.


I have 8 and all previous version ran very smooth. Quad core, 36. ghz, 16gb ram, win 10 64 bit os with Cubase 8.0.3 64 bit smooth as butter. No reason to update other than blow 50. I cannot get past it wanting to install then about 90% saying there is an error. I can launch installer and it starts to install then the error. A problem caused the program to stop working properly.

I have downloaded three times… I am now going to try a dif browser

In both google and explorer after numerous downloads from the email I received I am unable to install this update, please help.

I cannot for the life of me get this thing to install… It is killing me, lol

I wouldn’t bother re-downloading again…unlikely that all downloads are corrupt. Is the file 875mb?

In the first instance make sure you’re running the installer as admin. (right click)

If you get the error again please post the code or exactly what it says.

it doesnt have a code… just says error


I have tried all the browsers and this will not install… what else can i do?

It really says error…just that one word??

no, it says problem caused the program to stop working correctly. please close the program.


happens same spot everytime. I have tried diff browser, diff directory, and the sorts. lost! I have submitted a tickey, but maybe we can get it before hand? lol

Did you run the installer as admin?

Do you get as far as making any selections for versions and locations and starting the actual install or is the installer crashing before showing any options?

Guessing this install is on a PC?

You can press the PrtScn (Print Screen) button/key on your keyboard when the error is on-screen,
run the Microsoft “Paint” program. CTRL-V or Shift-Insert to paste the screen print into paint.
save the image as a png file
then upload / attach the image to a post in this topic so you can receive help in fixing this issue.

if the code only says what I say, what will posting a screen shot do?

if it takes a screen shot then I will do it, but im not seeing how that would help.

I did add the screen shot just so you dont think im crazy… I am going mad trying to figure out what the issue could be.
Capture.PNG.jpg

You are also not seeing how to fix it… so take a chance!

sure, i posted it.


I have a really good idea of what I am doing and have done numerous installs. I am baffled. Tried all directories… many downloads.

Reboot your computer. Check your hard drive space. Make sure all other programs are closed. Check to see if you have a virus protection running and stop that. Run the installer as administrator.

If that fails, run a chkdsk on your hard drive.

When you have done this report back.

It is not a download, so stop talking about browsers and downloads. (Edit- this is not to sound mean, it is just cutting to the chase. We really want you to get this thing installed!)

what do you mean its not a download? while I agree, many have had corrupted dls from steiny.

I rebooted and did a diskchk which passed. I have tons of space on my main os hdd. I did disable my panda security which was no success.

This is odd

If it were a corrupt download it LIKELY would not extract and then Run. Also you have downloaded a number of times. You are not getting a FILE MISSING report.

I really want it installed too my man, :slight_smile:

I wasnt going to buy it, but its my bday so i splurged! lol

I got you and you are correct. so far I am getting the same error over and over no matter where I try to extract. I always to run as admin when installing software and have done so with all my cubase installs and upgrades. I am not even able to get to the point to choose all users.

Is this the Cubase Upgrade or Full Install? What have you checked as wishing to update? Which version (I am guessing 64 but I have done weird things and had weird things happen)