Unacceptable perfornance on mac

I’m using Cubase 10 pro on OSX catalina and the performance is terrible. I’m distributing the load of vst’s throughout various channels so I don’t overload a single core, and while my osx cpu meter shows I’m using only around 25% of it’s power, Cubase is reaching it’s limit.

I’ve made a performance test on Logic and the difference is huge.

This is the second thread I create hoping someone from Steinberg can give some light about this.

Thanks for reading and hope steinberg engineers take this issue seriously.

Try disabling all virtual cores in BIOS. (hyperthreading) and try it again. There is a known, long term issue with multi-media multi-threading that involves both OS vendors, Intel, and steinberg(I can’t confirm AMD), and the issue is somewhat obfuscated and confusing especially when you bring it up on these forums.

Hi Milkman, thanks for your answer.

I’ve disabled the hyperthreading using xcode but the same problem still happens.

You might need to disable those cores in your BIOS. Does xcode have uEFI or direct r/w access to your BIOS? IVe installed xcode on macs as part of dev environments, but never played around with it much.

I’ve done it too, and still the same.

I’ve just opened a project with not too many plugins and only 40 tracks and the cubase meter is full again.

I find this totally unacceptable but even more unacceptable is the lack of support from staff from steinberg.

Think it is time to stop suporting steinberg and time to swith to another DAW.

Thanks for your answer one more time milkman

Today I tested Logic Pro X, Cubase performance is much worse, only two VST instruments, 15 audio tracks, no plugins and crazy fans noise, disaster…

Think it is time to stop suporting steinberg and time to swith to another DAW.

YES! :unamused:

Steinberg, fix it!


Here I attach a screenshot of the issue. This not only happens with one single project, it happens with all the projects I work on. I switch to Logic and load the same plugins and it works as it should. I can’t finish my projects because of this and I have no idea why there are no steinberg staff answering to this.

Same problem. This software is unusable after about 20 minutes.

The audio performance overloads with just a couple of tracks.

I invested in Logic Pro 10.5 a month ago. It’s inexpensive and on my Mac it outperforms Cubase cpu-wise. However, learning Logic to a degree that I can focus on music is going to take a while and I currently miss working in Cubase. Nevertheless, now I can at least have more than five tracks going without the cpu meter and the fan going wild.

I do cross my fingers that the next update of Cubase will deliver greatly improved performance om Mac but that has to be actual and considerable improvements, not just anecdotes without evidence.

I think I will buy logic when I buy a Macarm laptop. I have not tested logic for few years. It was anything but logic but I guess you need to spend time with it, as any other software. It so easy to jump back to Cubase…

I’ve been a strong defender of Cubase for years, convincing even top producers to switch from Protools to this daw, but I must say I’m really disappointed, not only with Cubase itself, but especially with the steinberg customer support. There seems to be a lot of professionals complaining about this problem and having serious problems with this and it seems this company don’t care at all.

I still keep on trying to finish projects and I’m unable to do it because Cubase is failing like crazy, it is totally unsuable.

Could PLEASE someone from Steinberg give some information about this issue? This is making me sending stuff out of time and I can’t allow myself this kind of things.

hoping someone sees this. also on catalina and the performance of cubase is ‘appallingly low’’…heartbreakingly poor. using vst connect it is crashing on closing down every time …and the mac screen of death appears with information that implies something is going to be done but nothing gets done.
cubase’s engine is not syncing and it’s creating horrific nightmares and endless hours of soul searching …finally on cubase 10.5 i cannot for love of money find any way of getting ‘snap to grid’ information in my menu bar…(this may not be mac related, but also to point out top right cog is also not offering a solution…)…is it that snap to grid settings no longer exists in 10.5?
if anyone has similar issues related the engine and crashing …especially with VST Connect i’d like to hear…

I’m having a lot of crashing, especially when opening projects, but although this is not a good thing, in the end I can deal with it.

However I would like this post to focus on the cpu problems.

I’m on a macbook pro 2015. Upgraded to Catalina a week ago. Cubase elements LE 10 was fine. Ran great. But I just recently upgraded to Cubase Pro 10.5 and it’s chugging hard. I have one audio track and my average load peaks just when playing an empty track after about 10 seconds.

I’ve gone through all the optimization docs I could find and it’s still the same. Is there some option in Cubase Pro 10.5 that could be causing problems for me that’s not in Elements? I’ve gone through all the options I can think of under Studio setup, but maybe there’s something else on in the bg on cubase pro 10.5 that I’m missing vs elements 10.0

sorry if this issue has been posted a million times. I’m new to the forum and did a quick search, but didn’t see a solid answer.

That’s what we’re all trying to get, a solid answer, but it seems nobody from Steinberg is able to take part in this threads. After 10 years using Cubase I’ve been forced to switch to Studio One since it has been imposible for me to finish any project properly.

Yup. I have tried (I think) everything based on my failed support calls with Steinberg. I’m downgrading this weekend from Catalina to either Mojave or High Sierra. Not sure which one at this point, but I have choice.

Hi there,

I’ll bring my personal case for summing up. In my case, I was running on a 2015MBP Cubase Elements 10, then Artist 10, and, finally, Pro 10.5. I also noticed a drop on performance; some project I was working on the artist, and It went fine, without performance peaks… and when i continued working on it with Pro, it started doing performance peaks, artifacts… the usual stuff. Also, the MBP coolers went full power, so there is considerable amount of fan noise.

Maybe the fact i switched to Pro at the start of summer is part of the equation (I live in Spain, and believe me, its HOT haha) but, I’m not sure.

Temporary I switched back 64 to 32bit processing, and I’m saving resources, and now I can work with all my projects, but, you know…

I’m spanish too :slight_smile:

Sad to see I’m not the only one having this problems.