Undo history Bug

Undo behaves differently in Cubase Pro 10.5.
Within the Key Editor Undo used to work exclusively on the part that was active inside the Key Editor. Now it Does not. :confused:

As you can see in the first video Cubase 10 Undoes edits made to the Flute part. Regardless of where in the history they were made.
In the second video you can see that Cubase 10.5 undoes edits made to the English Horn part. Even though the Flute part is currently active in the editor.
There is nothing in the manual about this behaviour.

https://youtu.be/Rg4jp0Jdk3c

https://youtu.be/mQn1dH1tFwI

Hi,

I have just tested this in Cubase 10.0.30, 10.0.50 and 10.5.0. It works the very same way in all versions.

What I tested:

  • Add 2 MIDI Tracks, 2 MIDI Parts.
  • Add a MIDI Note to MIDI Track/Part 1.
  • Add a MIDI Note to MIDI Track/Part 2.
  • Open Key Editor of MIDI Track/Part 1 back.
  • Undo.

=> The MIDI Note of MIDI Track/Part 2 is undone.

Am I doing something different from you?

Hi,

Thanks for the reply.

The results of your test indicate that the Cubase Undo function is behaving differently on your system than mine.

In this video of Cubase 10.0.40 you can see that after opening the Editor of MIDI Track/Part 1 and pressing Undo, the notes in MIDI Track/Part 2 have not been undone.

https://youtu.be/yIshdXEq-Ls

I had assumed that Steinberg had programmed Cubase to behave in this way. It has behaved like this on my system since I bought Cubase Pro 9.0 and it provides much much better work flow. If this is not how the Undo function behaves normally, why is 10.0.4 behaving like this on my system?.
It can’t be a bug because it has worked like this for two years, in every version since 9.0.
If this can’t be fixed in 10.5, I would like a refund of $89 AUD because Cubase 10.5 is unusable.

Hi,

From my point of view there is nothing to fix. It seems the correct behavior is the one you can see in C10.5.

I would be interested if you could try to start your Cubase 10.0 in Cubase Safe Start Mode. How does Undo behave then?

I am not going to try Safe Start Mode in case it fixes this bug. :wink:

As long as I remember Cubase Undo behaved like J Buckingham described, and now it’s changed which is VERY unfortunate for us who are used to it.

Here are two threads from the past that testify that this was the behaviour for a long time:

https://www.steinberg.net/forums/viewtopic.php?t=69078
https://www.steinberg.net/forums/viewtopic.php?t=117217

This made 10.5 unusable for me as well ;(

Why would they just change things like that with no given options!? That was an advanced feature that was giving Cubase an edge over other daws. Now it’s just dumb as others!

Hi,

The “trick” is (why I couldn’t reproduce it before) to open the Key Editor in the own window, to get it decoupled from the Project window Undo.

Thank you, reported to Steinberg.

Exactly. That’s great to hear Martin, thank you.

Yay! :smiley:
Thanks Shomynik for bringing up this topic again. I actually had forgotten about it. I look forward to working with this feature again.

Well,it seems that Steinberg’s “fix” to this problem was to remove this feature altogether… Huge dealbreaker for me.

Yes please, bring it back, this was saving a lot of time. Now it’s making things difficult to undo a specific step that was modified 15 actions before.

Yes, please bring back the localized undo function in the key editor. It was enough reason for me to downgrade back to Cubase 9.5… I really don’t see any reason why this functionality was removed.

Yes please! Bring this back.

Keep at them guys! :angry:

+1000 for bringing this back….thanks!

Yes. I can’t upgrade until this is addressed. I’m sticking with C9.5 (and I recently purchased to upgrade to C11 too)

This was one of the most useful features of Cubase and has become indispensable to my workflow

Brett

Please don’t forget to vote for this request at the top of the thread. Thx.