Undoing Remove Rests

While trying to reset appearance and position, I accidentally used the wrong macro and removed all the rests in a part. I can’t find a way of getting them back, especially since I’ve done a lot of edits since discovering this and had already saved the file. Is there a global way to do this?

Select the whole part, filter notes, then turn off the Starts Voice and Ends Voice Properties.

Thank you. Actually filtering the notes doesn’t get back rests after a bar rest. I still had to enter them again or to select the bar rest and turn off Ends Voice. That was a stupid mistake I hope I won’t be making again!

Actually, the reason I did this in the first place was that the clarinet part had a number of slurs which were on the wrong side of the note, i.e. on the stem side of several 8th note groups. Resetting the appearance helped this but I’m wondering why it happened. The slurs hadn’t been changed in the score and this wasn’t imported via XML.

Difficult to speculate without seeing the file, or a screenshot at least.

What happened if you selected the passage and filtered Rests? Could you then turn off the Starts Voice and Ends Voice Properties for those?

Slurs aren’t necessarily attached to specific voices, so often you have to flip them manually.

Indeed, I could have done it in two goes.
If I get slur anomalies again, I’ll post a file or a screenshot. Thanks again.

Hi there, I was having a similar problem but on a larger scale - after importing an xml file of a large orchestral work and de-condensing it (as it was manually condensed in the prior program), resetting all the voices of individual staffs to be the first up stem voice, I now have lot and lots of missing rests in all the parts that used to be down-stem parts, all the 2nd voices essentially in the winds and brass. Not just between entries but mid-phrase. I was painstakingly going through them and manually flipping the ‘ends voice’ switch off to regain all the missing rests.

I figured there must be a faster way to do this, and this seemed to be the solution. However, the properties panel does not even display the option if I filter notes of a whole part or even several phrases. It only pops up if I select small phrases.

Am I missing another filter? I’ve checked to make sure only the notes themselves are being selected and everything seems to be working as intended, except for the voice tab in the properties panel not being present (despite only having notes selected).

I’m not able to attach the file as it far exceeds the filesize limit, even on a silence template.

When you Filter Notes, Tuplet brackets/numbers remain selected - in most cases this is advantageous, but in this particular circumstance it’s a hindrance.

Having Filtered Notes, you may then need to set the Filter menu to Deselect (it’s at the top of the menu), then click Tuplets. The properties panel will then reveal note-related properties (unless I’ve forgotten some other exception).

Hi Pianoleo,

For some reason I didn’t get the notification that you replied - thank you.

As it turns out I needed to deselect both tuplets and grace notes before the option appeared again - but appear it did! Thank you so much for saving me hours and hours of work!!

Ok - so I’ve noticed a quirk which might be a bug.

I still had some empty bars and rests missing - I found the culprit was rests that had the ‘ends voice’ or ‘starts voice’ property attached. However when I filter rests the option doesn’t appear.

I did some testing and as it turns out the option disappears when more than one bar-rest is selected. Smaller rests can be selected all together and retain their property dialog - it only disappears when a bar rest is added to any selection.

This isn’t a bug, though I can certainly understand why you might think of it that way. Rests and bar rests are different types of things, so they can have different properties set on them, and hence only their common properties will appear.

Is not ‘end voice’ and ‘start voice’ a common property between rests and bar rests?

Daniel means that only the properties in the section at the left end of the properties panel, labelled “Common”, will show.

Ah, understood