UR 22 MKII driver update stuck on "Preparing to install..."

So im trying to update my UR 22 MKII driver since the interface randomly stopped working with the new windows 10 update. I followed the driver update instructions but every time i run the driver installer, before i get to do anything it just gets stuck at the “Preparing to install…” stage forever. There are no errors or anything, and the only way to close the installer is through Task Manager (Cancel button doesnt work). I don’t think its speed issues either because my desktop has an i7 and 8G of RAM. Ive tried restarting my computer and running then running the installation multiple times.

If anybody could help me with this problem, It would be much appreciated. :smiley:

I have the same problem since the Windows 10 december update… Any luck finding a solution? I haven’t been able to use my UR22 interface with my pc for 2 months now. Seems like the problem might be with ASIO drivers as I can use the interface with other drivers but there is some other issues (latency for one). I’ve tried reinstalling the ASIO4ALL drivers but still doesn’t work.

same problem for me too

https://www.steinberg.net/forums/viewtopic.php?f=157&t=124980