UR-C USB Driver 3.0.5 Causes Problems, NOT Solves Them

Jumped on the chance to actually use my UR22-C, but installing this new USB driver package killed both Logic Pro X 10.6.1 and GarageBand 10.4.2. Both apps totally freeze when checking license status for their AU plugins. I run these 2 apps on a 2017 MBP with 8 GB of RAM and > 150 GB of free disc space on macOS 11.2.3 (Big Sur).
So I try to troubleshoot with the eLicense Control Center App (v. Running it tells me nothing useful. It claims it has nothing to do under Activities>Recover. Maintenance claims it repaired and recovered some unmentioned license issues, but I still cannot open Logic Pro X.
I deleted both apps out of sheer desperation, but their behavior is unchanged when they try to check your AU plugin licenses at start up.
Thanks for nothing, Steinberg. You’ve made a terrible situation even worse by killing 2 different software apps with this terrible USB driver 3.0.5 upgrade.

Are you sure the blame lies there? People are reporting that it’s working, in the Cubase forum.

I am not sure why the driver should have an impact on Logic and the freeze while checking the license status? Please make sure that the latest eLicenser Control Center is installed and it may make sense to reset the preferences for Logic.

Thank you for your suggestions. Unfortunately, none of them fix my problem.
Logic stopped working after I updated the USB driver to 3.0.5. • is the release version of the eLicense app I’m using (which I assume is the latest one). The eLicense app finds nothing to restore or repair. I cannot reset preferences for Logic because it locks up when it tries to check the license status. Resetting preferences is impossible when Logic has frozen.

That number doesn’t correspond with a release. eLicenser Control Center is the latest version

Found and unstalled a newer eLicense app—v., but it changed nothing. Logic still freezes at the same place when it looks for eLicenses on AU plugins.

No app exists on my MBP by this name . Nor does it exist on the macOS app store. However, it is mentioned in Steinberg’s promo material on the UR-C 22 audio interface on the iOS platform. UR22-C Is Steinberg confusing macOS and iOS?
Steinberger’s troubleshooting recommendations found on the screenshot simply do not pertain to this problem. They all pertain to an app that doesn’t exist for my macOS platform. You can’t fix with what doesn’t exist.

thanks! I found this newer version but it changed nothing unfortunately.

No SB is not confusing that.

The error dialog is reporting correct info.

I don’t understand the exact nature of your issue, sorry.

Thanks for engaging here to solve my problem. My problem is that Logic Pro X freezes up after installing the USB driver 3.0.5 for my UR22-C interface. The freeze up happens when it checks AU licenses. The screen shot above was taken AFTER the freeze up had already occurred.
What is SB in your first sentence?
How can the error dialog be reporting correct info when it references things that don’t exist? (There is no application for my platform or on my device named REV-X AU, which caused the error). I cannot click for troubleshooting info nor can I click within an app that doesn’t exist.

You own a UR-C interface, that is software that comes with it.


Yes, but the error message references software that neither came with the interface nor exists for my platform.

It’s not an application, its an AU plugin, so you won’t find it in the Applications directory.

It’s from this: UR-C Updates and Downloads | Steinberg

Did you install that at some previous time?

Anyway, you’re in the USA, so open a support ticket, so you can receive the info and troubleshooting help you need.

Good suggestion. I’ll open a support ticket today.

The error message clearly states, “Application ‘REV-X AU’ has caused the following error:…” (see screen shot) That’s why I call ‘REV-X AU’ an application.
Again, my goal is to have Logic work as it did before I installed the 3.0.5 USB driver.

The driver installs also the tools for UR. Rev-X is one of it. If you don’t have a license for it, you got the error. Go into your vst|au folder and delete all the new plugins (it should be 3 rev and 2 GA, sorry can’t remember the full name right now).

It really sucks when things go wrong, but can’t you just revert to a previous system point (I think macs are very good at that kind of thing), if everything worked earlier?

Or just delete the offending plugin for the time being?

When you install the tools you have the option to select what you want. If you don’t have a license for those plugins you don’t install them. If you do it by mistake you just delete them or buy a license. Is not such a big deal


Thanks for jumping in on this thread. Installing earlier versions of the UR22-C USB driver did not cause Logic Pro X to totally freeze. Only the 3.0.5, and it froze exactly when the plugins were being authenticated. So I decided to activate the code on Steinberg’s Basic FX Suite. That fixed it. Logic now works.

However, Steinberg is solely to blame for engineering a scenario where installing 3.0.5 kills Logic. Remember, I did not have this problem on earlier releases of the USB driver. Why should I lose the function of my DAW just because Steinberg falsely thinks there’s a licensing problem with its plugins? (One solution to the perceived licensing solution would be to include an uninstaller app for plugins—just like the uninstaller for the eLicenser app and the USB plugin).


You hit the nail on the head with your comment. I searched my SSD for but found nothing. I did enter the activation code for Steinberg’s Basic FX Suite and it eliminated the problem.

But I’m going to delete these problematic plugins anyway just in case they might cause problems again in the future.


If you have the license they are pretty good so keep them! :grinning: if you are on Mac download the funter app and search for them!

@J.AlfredPrufrock , this has nothing to do with the driver release per se, but this is the first time, the whole system comes to life on Big Sur - including the TOOLS for UR-C and the Basic FX Suite plug-ins that come with it. Logic tries to load the Basic FX Suite plug-ins and fails as you do not have a license available (as seen in the error message). However, I can see that you have activated the needed license on a Soft-eLicenser today. If that license is stored on the Soft-eLicenser on that system, the error should not appear any longer.