UR22-C "Audio Interruption due to USB error"

Hello!
I have brand new UR22-C, and I can’t get get stable audio playback through the device.
According to ASIO driver status, the dreaded “Audio Interruption due to USB error is detected” message appears in Steinberg USB driver settings, as soon as I try to play any longer audio stream, in addition to audio drops. This makes working with the device impossible. These drops appear only when audio output is loaded, when recording or when playing back with loopback there are no problems.

I am working with different PCs, one is a laptop, with Core i7-1235U CPU, which has integrated Intel USB chipset, and Windows 10 Pro 22H2.
Second is desktop PC, also with Windows 10 22H2, with integrated Intel W790 chipset USB, but I also tried PCI-Express add-on cards, with Renesas USB 3.0 controller, Diodes USB 2.0 to PCIe bridge, ASMedia 3242 PCIe controller (20 Gb/s) and Fresco 3.0 controller. Every single one of these have the same issue.

On the laptop dropouts are much more frequent, and can happen even twice in a second, and generally I haven’t got more than 10 seconds of uninterrupted sound.

On the desktop it’s less frequent, happens usually at most 4-5 seconds apart, and often times I can get 2-3 minutes of uninterrupted audio out of it. I gave up on laptop. I can’t set anything in its BIOS anyway.

I have already done my research in other places, and checked following:

  • UR22-C has newest firmware, and I have newest available software.
  • BIOS, firmwares on everything on the motherboard is up to date. Windows update is regularly ran and all devices - onboard and off-board have their drivers installed.
  • Windows is installed on GPT layout, and boots in UEFI mode. SecureBoot is on, set to Windows OS.
  • Windows boot disk is NOT encrypted.
  • I have ECC RAM, and I ran memtest on it, there weren’t any errors
  • ALL PCI-Express ASPM and power saving features are turned off in BIOS.
  • Power to USB in S5 (soft-off) state is disabled
  • ALL USB power saving features are turned off in OS.

Experiments I ran:

  • XMP is required for this PC to work, but I removed all but one RAM modules, and checked without it anyway - for all of the testing.
  • Turbo Boost is required for this PC to be usable (or it stays in 1.2 GHz clock all cores), but for the sake of test, I also disabled it - for all of the testing.
  • I checked USB ports only directly, without any USB hubs (I don’t have any anyway).
  • I checked both powered with USB-C, and with external micro USB power, using high quality power brick and high quality portable USB power bank.
  • I installed one after another all of the USB controllers listed above
  • I checked obviously both 3.1 and 2.0 modes, all modes (Low Latency, Standard and Stable) and 128/512/2048 values.
  • I talked with my retailer’s support staff, and they agreed to lend me second UR22-C device, it behaved exactly the same.
  • I grabbed another SSD and installed Windows 10 from scratch.
  • I replaced cables with high quality ones - USB-A to USB-C, and USB-C to USB-C, the latter included PD 3.0 certified cables.
    I haven’t noticed any of these having any impact on the issue.

Although I own and use many strange USB devices, none of them ever gave my any issues.

I don’t have any more ideas. Is there anything else I can do?

Wow! You seem to have a stubborn issue here!
I was tempted to suggest an exorcism… but let’s try other options first.

The error message suggested this could be a hardware issue and you did a great job investigating this track.
One last hardware test I can think of is to make sure you use the external power supply (and not the usb-c power) and set the “Power Source” slider in the back accordingly.

Then let’s look into the software side…
Open Task Manager and close/disable/stop all non-critical applications running in the background. I suggest the bulldozer approach where you kill a “large” number of processes and services (take notes) until the error message disappears, then reboot and try by disabling only half of your previous test, until the error shows up again. Then disable half this list, etc. Take a pen and paper to take notes and avoid going nuts.

Let me think about it if I get other ideas… hopefully others here will have seen that issue before and provide a quicker fix.
Very bizarre…

I spent some more time debugging the issue.

As a first order of business, I completely reinstalled my OS from scratch, switching to Windows Server 2022, my reasoning being there is far fewer background stuff going on, and most programs need to politely ask to be run, instead of treating autostart as their home turf. Sadly, to no avail.

I suggest the bulldozer approach where you kill a “large” number of processes and services (take notes) until the error message disappears

You see… the problem is the error never goers away. It wasn’t an issue that started happening, it was present from day 0.

One last hardware test I can think of is to make sure you use the external power supply (and not the usb-c power) and set the “Power Source” slider in the back accordingly.

I already did that test, with truly decent power brick, but I repeated test with laboratory power supply I borrowed from my workplace. Also it didn’t help.

I thought about an exorcism (referring always spot-on: https://www.youtube.com/watch?v=a_90uFCrWWY ) - but gave up.

In another news I lent the device to my friend, who uses Focusrite 2i2 (we switched for a few days). He said, that on his PC (AM4 based PC and Windows 11) he had the error pop up few times, but only on USB extender (he has optical USB extension as his PC in different room), when plugged directly to the PC there was not a single problem.

So if no one else has any ideas… I will probably try some other device. It pains my heart, as UR22 has absolutely everything I want, including built-in effects, which drastically reduce software clutter and my work.