Fix: Audio interruption due to USB error is detected. (Windows)

Windows fix.
Maybe this helps… users reported that some of the settings below helped.
Make sure complete all the tasks below step by step.
I did step 1 and step 2 like many others but noting helped… When i switched the OS Type in the bios from ‘Other OS’ to ‘Windows UEFI’ it worked! and fixed it!But… if you are running on MBR this will not have any effect … so please carefully make sure you do step 1 & 2 before you change things in the bios with step 3.

It seems that the Yamaha driver can’t communicate right sometimes when :

  1. Internal windows audio driver is disabled in bios
  2. When using MBR file system
  3. When using other OS Type setting in bios instead of Windows UEFI mode
    On new systems this option is sometimes automatic on (Other OS)
  4. When using XHCI mode
  5. When Intel Turbo Boost Technology is enabled

Please check step 1 & 2 before you go to bios settings and change things!

Step 1: First make sure you have checked:

  1. The latest drivers for your motherboard USB/USB-C/Thunderboltt/ etc…
    do this by checking your motherboard manufacture website. This because Windows can install universal drivers that are not supported.
  2. The latest drivers for your motherboard.
    do this by checking your motherboard manufacture website. This because Windows can install universal drivers that are not supported.
  3. Latest drivers for your Steinberg hardware
    Check Steinberg website
  4. You are running your OS harddrive on GPT, NO MBR!!
  5. You are using original Steinberg usb cables, if you need longer usb cable it will work only with certified USB cable up to max 3 meters length
  6. You are using no USB HUB for your audio interface, if you want to use a HUB don’t use powered HUB

Step 2: Make sure you have changed these Windows powerplan settings:

You don’t want your USB keyboard/USB devices being disabled if you leave your computer for too long. In big studio projects when this option is on you will get problems with some VST’s and the yamaha driver because they lost connection.

  1. Control Panel > System
  2. Advanced System Settings > Advanced tab
  3. Click Settings under Performance, the Performance Options window will appear
  4. Advanced tab > USB Selective suspend settings
  5. Double click Enabled > click Disabled
  6. Apply > OK

Free up space on your USB bus, helping your PC to recognize devices and install drivers correctly.

  1. Control Panel > Device Manager
  2. Double-click Universal Serial Bus Controllers
  3. Double-click the top USB Root Hub entry
  4. Click on Power Management tab
  5. Uncheck Allow the computer to turn off this device to save power
  6. OK
  7. Repeat for all USB Root Hub entries

Step 3: Bios settings (don’t skip these this!)

This might be helpful for those whose BIOS has the options listed, unfortunately this is not the case for all systems. If you don’t see some of those options… Then just skip it and finish the ones you see in your bios.

If you have Intel raid setup with Intel RST, that is good, then you can skip step 1 '‘change the XHCI setting’'.

  1. Set Motherboard XHCI mode to: MANUAL. Dot not set it to: disable, enable, auto, smart auto!
  2. Set OS type to: Windows UEFI mode / Windows 8 etc… just no Other OS!
  3. Disable: PCI express native power management
  4. Disable: Agressive LMP support
  5. Disable: USB power delivery in soft off state (s5/s4)
  6. Enable: HD audio controller/internal audio/Realtek audio
    You think you don’t need this because you have a audio interface…but Yamaha is communicating with the Windows driver)
  7. Disable: ErP ready
  8. Disable: Intel Turbo Boost Technology (if you have Intel)
    The Intel boost option needs to be off, when on this causes connection issues in real time with the Yamaha driver.*
  9. Enable : Legacy USB support.
  10. Disable: Secure boot
  11. Set boot mode to: Legacy + UEFI
  12. Save & exit bios!

If you are still having problems

  • Please test new USB cable
  • Contact your motherboard manufacture, maybe your MB is defect
  • If you did all the steps and nothing helped… Then just return the products for a repair or do a support ticket to Steinberg.

Thanks me later!!

Thanks for posting-- this might be helpful for those whose BIOS has the options listed, unfortunately this is not the case for all systems.

1 Like

doesn’t work. there is no BIOS settings mentioned in step 3. Beside that if the Secure Boot is enabled, so it means that PC boot in Windows UEFI mode by default.

and yes I will do blame steinberg in this problem. I got 3 different PCs and problem experienced on each one and still not gonna be solved

1 Like

You are wrong… UEFI bios and UEFI secure are 2 diffrent things

When the UEFI Secure Boot feature is active, a UEFI BIOS will only boot cryptographically signed boot loaders whose certificates are stored in the BIOS code. It is possible that your Yamaha driver is blocked because it is not stored as a certificate in your bios and is therefore blocked by secure boot.

Can you try this?
Secure boot: Disable
Boot mode: Legacy+eufi

I really want to help you.

this is the first I’ve tried - doesn’t help

My BIOS has no settings like this. I work on the newest Lenovo Legion and the BIOS is very minimalistic

really appreciate that. thank you

1 Like

@dondawell This is what I have tried to say to you, please be aware of this fact when you post.

1 Like

I’ve just tried that on desktop (it has more BIOS settings) = unfortunately problem still here.
It has OS type selection settings but there is an next options - other OS, Windows 8, Windows 8whql

1 Like

@steve yeah you are right, did the edit in the post.

This might be helpful for those whose BIOS has the options listed, unfortunately this is not the case for all systems. If you don’t see some of those options… Then just skip it and finish the ones you see in your bios.

@stalevar as we spoke in the private chat about more sollutions… i think there is someting broken in your soundcard or there is software related problems in windows that we cannot fix… you did your best!
You can considder to return it for a repair i think…

Goodluck!