UR22 cuts out intermittently

I recently purchased the UR22 but am experiencing an issue with the device. When playing audio through the device (USB connection) with any form of program (tried KONTAKT, VLC media player, chrome ect.) the audio cuts out randomly for usually less than a second. It does this randomly, it can go for 10 minutes without any cut out or it can happen every minute or so. I believe the issue lies with my desktop as I have tried the interface with my laptop and my flatmates macbook with no issue. I have used a scarlet 2i2 (my flatmates) for an extended period of time with the desktop and experienced no issues. I looked online to find out if anyone else has been experiencing the problem and all I could get was performance issue/change the buffer/sample rate settings. My computer is definitely fast enough to use the UR22 and chaning the settings has not effected the problem except maybe reducing the cutout time factionally by increasing the sample rate (which Id rather not do as this increases the latency of the connection).

Id much rather not send back the UR22 as the build quality and sound is more than satisfactory, so how should I fix the issue?

I’m upping this, since i’ve got exactly the same problem.
I think too it might be a problem from windows, since i think it happens when the cpu is used (the problem shows itself more often when i’m trying to load something, etc.).

I’ve just bought a UR22 and am also having this issue. The CPU meter can be low but this still happens just as reported above.
I have even reinstalled Windows 7 (x64), Have tried both x86/x64 Cubase 8 Pro but the issue remains. Any help would be greatly appreciated, although judging by the response from the previous comments that doesn’t appear likely! :slight_smile:

Soooo, i’ve done some little research, plus I got an answer from the team when i emailed the the problem. So this is what I know globaly:
First, Ur22 doesn’t like USB 3.0. So you might change your cable to another port.
Then, the problem might be too a “known” windows issue, caused by drivers that aren’t up to date (and not only the steinberg driver, every driver). And especially something that is called “DPC” latency.
I know it might be that, because when i watch streaming or movies, I’ve got cracking and poping audio (and I’m on my regular sound card). And when I try to plug the my Traktor Kontrol S2, I’ve got the same issue than with my UR22, but less strong, so it’s not just an issue with the UR22.
Here’s a good way to “try” to fix it: http://www.sweetwater.com/sweetcare/articles/solving-dpc-latency-issues/ . Mostly it is caused by a WLAN or ETHERNET driver that isn’t updated, so if you can’t update him, just disable it when you’re using the UR22.Furthermore, Chrome is maybe causing issues too (because it uses the network driver (ndis.sys) even if the network is disabled). And as said before, sometime you have DPC Latency when using “inapropriate” devices on USB 3.0 (as using the UR22 on a USB 3).
But anyway, I say try, becuase it didn’t work for me tho (I tried to disable all my internet, and plug my UR22 in a USB 2.0 HUB, and there was still cuts).

So if anyone knows more than i do, i’de be happy to be helped.
And I hope this solution might have been usefull for some of you.

(And of course sorry for my really poor english haha.)

I don’t think you’ll be able to use a USB Hub reliably. You may need to get a USB 2.0 PCI(e) card, if you don’t have a native connection (built into the MoBo). After getting connected to USB 2.0, you should check to see if you have IRQ conflicts. You may need to move the USB card to a different Bus to avoid potential conflicts.

I guess this is not possible with a laptop…?

If you have a USB card on the Card Bus platform. If your laptop doesn’t have a space for Card Bus, then it wouldn’t be possible… sorry.

USB 2.0 is the current standard for Audio. USB 3.0 is the standard for external storage. Of course some manufacturers are pushing Thunderbolt & such faster connections, but USB 2.0 is adequate for multi-tracking. Even high-end gear such as AD/DA converters are using USB 2.0, AFAIK.

Have you tried a USB hub?
Firstly, if you plug a USB 2 hub into your USB 3 port, it essentially dumbs it down to a USB 2 port. But, depending on what exactly is causing the problems, it might not make any difference. I use a USB 3 port with my UR44 with no problem, so it might not be the difference between us and USB 3, but some incompatibility with the particular card/driver.

Secondly, if you try a powered hub and it works, your USB port might not be putting out enough consistent power for the ur22.

Might be a quick and easy thing to try before buying a whole new USB card.

The thing is: I tried, and i still have this issue.
But now my regular audio is popping and cracking without even using any external soundcard. I guess this is mostly a Windows 8.1 Driver issue i guess. I just have to find which one it is… Pretty unconfortable for live shows etc. tho.

Having real problems with my new UR22. I’m using ableton live 9 on a brand new toshiba windows 8.1 machine and the audio glitches are making the process of making music a chore. I’ve been using PCs for recording music since windows 98’, 2000’ XP, 7 and now this. I’ve tuned the PC to run so it runs really smoothly with hardly any background services running, no wifi when I’m using it for music and no virus software running either. I’ve noticed it glitches when I move sliders, change screen views and selecting tracks. At one point it stopped the UR22 so I had to go to preferences to restart it. It’s connected to the USB socket and has the latest drivers. I’ve been searching for similar symptoms in other software I have and nothing. Only seems to be Ableton Live. Any ideas.

Hello folks

Just wondering is there had been any further discoveries on this issue.

I’ve just got UR22 and am having the same problem.
Whether in a DAW environment or just listening to music on wmplayer or from Spotify, audio drops out for a split second every few minutes with no discernible pattern.
I’m running Windows 7 64bit on a X99 system.
I’ve tried USB 2.0 and 3.0 ports.
I’ve updated the Intel USB 3.0 eXtensible Host Controller and my LAN drivers.
I’ve tried setting processor scheduling to Background Processes.
I changed Power Settings so that USB Selective Suspend was disabled and Minimum Processor State was 100%.
… No Change.
DPC Latency Checker shows no problems at all!
DPC monitor shows occasional problems with NDIS driver and the various graphics kernel drivers - but none of the issues it detects correspond to moments when the audio cuts out!
It’s baffling!
Surely there must be a diagnostic utility of some sort that can at least notice when something like an audio drop out is happening!
Anyway, I’m all out of ideas.
I’ve been trying to see if I can update my chipset drivers. The Intel Driver Update Utility has never been very good so I’m trying to do it manually on the Intel Download Center page. I choose Desktop Boards, but then the options it gives are all alien to me. I have an X99 board, but that is not an option there.
Is an X99 board a Series 9 board?

Any suggestions - or even better: solutions! :slight_smile: - would be very welcome!


I’m in exactly the same boat. Steinberg support isn’t helping me anymore for whatever reason. I’m running Windows 10 64bit and with the latest Win10 driver for the UR22 and it’s nothing but audio dropouts. Device isn’t even a year old, so this issue is very frustrating. Hopefully someone finds a fix for this because I want to use my A/I!

Yeah, it’s very frustrating. And bizarre that (in my case) the dropouts don’t register on DPC Latency Checker - according to this utility I’m all in the green and should have no problems.
I wonder if the UR22 unit is drawing sufficient constant power? Although the LED doesn’t blink so it probably isn’t a power issue.
Someone please help!

I just posted a new thread and realized this topic has already been brought up. My bad.

I have the same issues with UR824’s that had no issue before a new system build.

I will look into the suggestions already presented here.

I hope to find the problem as it is quite embarrassing to have audio drop out when you are charging for recording time…

I have 2 USB ports from my MOBO. I was running the UR824 from these as well as a ‘hub’ that runs Cubase dongle, ILOK, Waves, and CMC controllers. I moved the hub to a USB3 port and so far no dropouts on huge project.

Good for 10 minutes so far. Fingers crossed! :slight_smile:

I will update if things change.

I did have a dropout after about an hour. :frowning: Better than it was, but still unacceptable.

I then went to the support section of my MOBO (ASRock Z97 Extreme4) and found 4 updates that the Intel Update Manager did not suggest. I also updated to the new UR824 driver that was updated for W10 even though I am running W7 Professional.

It seems that nothing is simple.

About 4 hours now without a audio dropout. Fingers still crossed but it looks good!

I knew I shouldn’t have posted that… Just had a dropout.

Way better than before but I can’t figure out why it is happening at all.


Gah! It’s infuriating isn’t it!
I’m working through various steps to see if anything helps.
I haven’t tinkered with C-States and SpeedStepping in BIOS yet. Have you?

Yes it is! Ugh…

I have SpeedStep disabled in BIOS.

Yesterday I decided to take internet connection out of the equation. I only had it on because Waves and Ilok needed it at startup. I found that waves licenses can be placed on flash drive and Ilok update allowed me to not need internet connection.

I haven’t yet had the time to sit and listen for dropouts but have a session tonight that will cause Mr. Ugly to rear it’s head if he still exists.

Fingers crossed again…

Please let me know if you find anything.

Do you have Intel Rapid Storage Technology?
If so, try opening the application, going to the performance tab, then disabling Link Power Management.
I’ve done this, and I tentatively think that the dropouts are at least a bit reduced.
Give it a go and see if you notice any difference.