UR22 mkII - Audio dropouts problem

Hi everyone,

I’ve installed the lastest version of Cubase and Yamaha USB driver on my laptop, and I can’t even record anything. The audio dropout is horrible!!!
I’ve tried to update software, re-install driver, re-install the whole windows 10 operation system and it didn’t helped!

My specs are:
VivoBook_ASUSLaptop X530FN_S530FN
Processor: Intel® Core™ i5-8265U CPU @ 1.60GHz (8 CPUs), ~1.8GHz
Memory: 8192MB RAM
Graphic card: Intel® UHD Graphics 620
Windows 10 Home
Cubase 10.5.12
Yamaha Steinberg USB Driver V2.0.3 for Windows (Tried older version of USB driver, didn’t worked!)

In VST Audio System I’m getting this error message:
“Audio interruption due to USB error is detected. Refer to the troubleshooting in the operation manual.”


Can anyone help me out? Thanks in advance!

Have you tried a higher buffer setting like 512 or 1024? Make sure your computer is not doing any unnecessary stuff in the background such as updates, defragmentation, etc., or that applications are running in the background.

Thank you jaslan for the quick reply. Yes I’ve already tried to change the buffer size and there’s no any running app in the background. The project is empty.
Though something is very weird. When my laptop is plugged, there are too many audio dropouts, but when I unplugged it, I don’t experience too much audio dropouts, almost nothing. Should I try a 5V adapter for my audio interface? but don’t know why it isn’t working like plug and play.

I hope someone experienced similar problem and help me out.
Thanks anyway!

I’m having exactly the same issue, intermittent dropouts that weren’t there before (more than 2 years working without issues until now).
After noticing the problem, I uninstalled the old Yamaha Steinberg ASIO drivers and install the most recent version, following the installation instructions. Tried using a different USB 2.0 port. I’ve also tried different buffer settings, to no avail.

However, I noticed the Event “Device was not migrated due to partial or ambiguous match” is mentioned in the device properties (Device Manager > Steinberg UR22MkII > Properties > Events). I suspect a recent Windows update might be causing this, and the audio issues as a result?

yes i also having this problem, get me very very frustrated with steinberg UR22 mkii.
is there any solution for this?
i’ve tried upgrading memory from 8 to 16gb -> not a solution
also upgrade driver yamaha -> not a solution
changing usb cable and port -> not a solution

and yes, agree with malfunctionigeddy, i’ve also check the log in events, and found the same error in event.

hiks…

me too. I’m so disappointed now! the issue becomes bigger if I play videos on youtube, randomly! A dedicated-pro audio device but work worse than integrated audio like realtek. Im going sell it!!!

Mee too with the new laptop, any solution?

Hello !
I’ve exactly the same issue with UR242 audio unit (same messages, driver update etc…). I noticed that it happens less when power supply is not connected to my laptop. Moreover if I work at 192 Khz (which is not convenient for file sizes, some effects compatibility etc…),it’s clearly better but not totally fixed.
There is obviously an impact of power supply (Which is switch-mode power supply, probably poor quality and can generate noise and harmonics) but it must be an indirect cause.

My config is very similar, and I’m wondering if it could be specific of some Asus Laptop and Chipsets… (same issues are often reported with Asus laptops on forums…)

Asus Zenbook 13 UX331 FA
Core I7-8565U at 1.80 Ghz
8 Go RAM
Graphic card: Intel® UHD Graphics 620
Windows 10 Home
Cubase 10 (but the problem should not be linked to cubase)
Yamaha Steinberg USB Driver V2.0.3 for Windows

The cuts are very random and sometimes it’s better but not comfortable at all. Steinberg must investigate about this, at least for understanding the cause, this is a largely reported problem and particularly frustrating because those units are very good actually, with good preamps, DSP FX and integration in Cubase.

A question for those which have no problems : Which Laptop do you use ?

I agree with you! Now this issue is widely and too annoying.

I got the exact same issue, and the same error messages using the UR-RT4 on my desktop computer, I’ve tried everything metioned above too and no real results, it seems to be worse when i try yo play a vidéo on VLC or on Youtube as well. but it sometimes happen when i’m using Pro tools too.

There’s this message in the control panel:

“Audio interruption due to USB error is detected. Refer to the troubleshooting in the operation manual.”

also the event “Device was not migrated due to partial or ambiguous match” is showing in the device properties (Device Manager > Steinberg UR-RT4 > Properties > Events).

My specs are:

Motherboard: Gigabyte X99-Ultra Gaming-CF
Processor: Intel® Core™ i7-6800K CPU @ 3.40Ghz 340Ghz
Memory: 32Go RAM
Graphic card: NVIDIA GeForce GTX 1080
Windows 10 Enterprise LTSC
Yamaha Steinberg USB Driver V2.0.3 for Windows

Hope you can help us.

Hi! I just got a new computer and Im having these problems also.
ASUS VivoBook S14 S403FA. i7, 16gt Ram, Windows 10 etc. It seams to be working ok when on battery mode, but when I un-plug my computer from its power supply it starts cuttin audio really bad. I was just wondering If theres any problem with other manufacturers right now? (HP for example) . I do still have a chance for refund… My UR22 mkII was workin great for many years with a computer that had poor performance.
Finally I got some power to use BiasFx with ProTools etc. But now this kinda basic and pretty important thing won’t work correctly :smiley: please help!

So…I think I found the cause
I spent 3 full days to investigate all the possibilities and I finally got it.

I explain:

Since the problem was observed only with power supply, I searched for a link with it. I put the quality of the alimentation hypothesis aside…to open mind!
I searched for set ups which are different from battery to power supply in the power management (advanced parameters)
I set up al the same for battery and power supply —> did not fix

BUT : I remarked that when I plugged the power supply, the frequency of CPU was more unstable and higher in the task manager, and actually it’s the cause, and this cause is named : Turbo BOOST
Lots of CPU have now this technology (It’s the case for those you have @Palt0quet @Budailaci, and mine) it can help sometimes when you need high CPU ressources, but it’s not essential.

So I checked with this software : HW monitor (Free and safe). It displays all the processors speeds, temperatures etc…

–> On battery : the speed of each core is capped to the basal frequency (for me 1.80 Ghz, more or less)
–> On power supply : The speed is capped to the maximum speed of turbo boost mode (for me 4.60 Ghz)

So I desactivated the Intel Turbo Boost. it can be done in the Bios for some PC, but not mine.

There are other possibilities for turning off, including set up the maximum CPU utilisation at 99 % in the power management. Follow this link for several ways to turn off Turbo boost:

https://www.geeks3d.com/20170213/how-to-disable-intel-turbo-boost-technology-on-a-notebook/

NB : Depending on your version of windows update, some power options may be hidden, so just follow this link:

https://help.ableton.com/hc/en-us/articles/115000211304-How-to-enable-the-High-performance-power-plan-Windows-

And after 3 hours of music on my computer (switching Turbo boost on and off to see the difference) : It’s OK It’s definitely the cause, at least for this kind of problem i.e: USB dropouts at 44.1 KHz, until 176.4 KHz, and not at 192 KHz, when the power supply is plugged

Important: Sometimes, we are experimenting other dropouts which are due to bad plugins, too much resources needed, bad buffer etc… those dropouts are differents and it makes the analysis of the root cause more difficult.
This solution is fixing one of the cause of dropouts, but one main cause !

Please try to switch off your Turbo boost and keep me informed, i hope that it will work for all of you guys!

I’m transferring directly the information to Steinberg in my opened ticket. Maybe they will find a solution to adapt the device drivers to this issue.
I’m also in contact with Asus for explaining the problem.

Have nice “stay at home” music sessions and take care !

2 Likes

Thanks, worked for me! Hopefully they will fix it. Alltough everything I need probably works from now on with these settings.

That method doesn’t work for me. I turned off EIST function and Turbo Mode. You should test with long long duration, such as 1-2 days at least.

I did not stop to listen and make music through the interface since I fixed the problem, without any issue, so I’m sure it’s the cause for my config. (moreover I checked several times with and without boost)
May depend on your processor. I did not turn of the EIST, maybe you should keep it ?
Given his model of Laptop, JJ95 may have the same processor as me (normally Core I7-8565U at 1.80 Ghz (boost at 4.60 Ghz) ; JJ95 could you confirm ?) and it worked for him too, so no doubt for me.

But it’s tricky, I think it could depend on your processor versions and technologies, What is your configuration just for information, and do you have a separated graphic card (mine is an integrated chipset) ? And by the way what are your sampling rate and buffer size settings ?

Thank you, Pyheme, for confirming that disabling Turbo Boost can help. We also mention this in every configuration article like https://helpcenter.steinberg.de/hc/en-us/articles/360008589880-Windows-10-How-to-set-up-and-optimize-a-Digital-Audio-Workstation-DAW-
The issues with Turbo Boost and EIST are of a more general nature as many current laptop solutions offer a huge clock range. Some have a base clock speed as low as 1.3 GHz but go up to 3 or 4+ GHz. As you have written, this is nice if you need these short performance boosts but that’s about it. Many systems cannot maintain this speed for longer than 30 seconds and clock down again to stay within their thermal boundaries.
I struggled with a Lenovo system (T490) that clocked down to 600 MHz every now and then. These ups and downs are the worst that can happen to a DAW that needs a stable environment to deliver the real-time audio performance needed. Anything else will produce dropouts etc. Of course, drivers also play their part but it’s more than that. In my case, the UEFI BIOS settings and Windows settings I had access to made no real difference but I could stabilize the system by using an application called Throttlestop.https://www.techpowerup.com/download/techpowerup-throttlestop/
For some, this may help as well. Be sure to read the documentation and use it at your own risk! It’s a personal recommendation and not an official one.

1 Like

Yep, Intel Core i7-8565U, 1.80 - 4.60 GHz, 8MB, Quad-Core

It’s not seem that the problem come from our AI, I think it’s related to Windows 10. I’ve spent a lot of time for this problem, I used LatencyMon software to diagnostic and found that the problem stick with something called ndis.sys then wdf01000.sys (my case), others: tcp/ip, etc.

I tried using 1 tab browser (Chrome, Edge) only Youtube or Facebook video, the ndis.sys and wdf01000.sys level is very high (red or even maximum)

1st image: normal play


2nd image: skip play or refresh page or open a new tab

3rd image: more info

You can search on youtube or google something like: “DPC latency windows 10”
or via this forum: https://www.sysnative.com/forums/forums/windows-10.148/
I tried turn off my Antivirus - Kaspersky, just leave default Windows Security then everything fine, but after restarting the problem come back. I don’t want to turn off Windows Security because there are many unsafe thing nowadays so leave one AV at least.

Now I’m too tired of this thing. It took me a lot of time. I just thought about back to windows 7 which is so stable to me at least but I also worried about compatibility in the future while many manufacturers make their products for windows 10.
I need stability for 2-3 years at least, is this too hard for technology nowadays? I - the musician - producer! I am NOT IT technician!

Here is my spec & config:
CPU: I7-4790; RAM 28Gb 1600 - Mainboard MSI B85m-e45 - integrated graphic
UR22 mkII: 48kHz, mode standard, buffer size 512 and 1024, driver: 2.0.3
Hyper-thread/Turbo boost/Speedstep/C-state: Disable
Power management: all set to Diable
Power Advanced Setting: set 100%
additional Network settings follow this: https://helpdesk.flexradio.com/hc/en-us/articles/202118518-Optimizing-Ethernet-Adapter-Settings-for-Maximum-Performance

Indeed it appears that you have a more serious problem, due to those files processus.

Here are some reflexion ways:

ndis (Network Driver Interface Specification) makes the link with Hardware and softwares, for network purposes. It could be used by network adapters (RJ45 or wifi, maybe you have both) and by antivirus (you did observed an impact) and VPN for example.
So for the Ndis case, it may be interesting to put the PC out of network and to momentaneously disable your network adaptors in the device panel, and all your network-link softwares, in order to see if the dropouts occurs and if latencymon score is better. And then turn on step by step.
Given your mainboard, you may have realtek chipset for Network card (normally a Support PCI Express Gb LAN 10/100/1000 Fast Ethernet Realtek® 8111G), and its driver could be also involved with ndis. (The realtek sound chipset must not be linked but you can try to disable in the device panel)

Wdf01000 (windows driver framework) is helping to create drivers in order to communicate with external hardware devices, including for example wireless mouses and keyboards, maybe you have some.
So for this case it could be interesting to remove all the plugged stuff on your PC, and to do a check only with the audio interface plugged.

An other thing that could be important is that your bios, windows version, and your non-audio drivers are all updated.

Maybe you already tried some of thoses ideas, but it could help your reflexion for solving this !
Hope you will find the cause

I just found a reason and solution. That is related to Kaspersky. Pausing or Quitting Kaspersky will not change anything but Removing does! Indeed, pausing and quitting it will do but effective at that moment only and problem will back when restarting computer. But I don’t thing the problem come from Kaspersky because the same version I used on Win 7 is fine. So again, I’m sure that Win 10 has conflict with Antivirus software. I read other forums mention about this thing.
Here is my response though many tab opened in Chrome