UR22 mkII - Audio dropouts problem

Now I have the same problem with my UR22mkII. Nothing above helped.

Sir, I’ve tried your solution. It works better, but still, random audio dropouts occurred. Like after 10 or 15 minutes running silky smooth, suddenly the audio lost for around 1-2 seconds then come back again. But this time the LED indicator is not blinking anymore. Here is what I did to get where I am now:

  1. Update windows until there is no more updates left.
  2. Update every single driver manually from the manufacturer website, includes: chipset driver, network card driver, graphic card driver. I’m using Lenovo laptop so I downloaded all available and most up to date driver from Lenovo’s website.

After updated, I tried the latest Yamaha USB driver but no luck for me. So I installed the older Yamaha USB Driver as you mentioned on your post.

My machine is:
Lenovo Yoga 520 14-IKB
Intel core i5 8250U
8GB RAM
1TB WD Blue SSD SATA
Intel UHD 620 & NVIDIA Geforce GT940MX

Audio interface: Steinberg UR12

Unfortunately, there is no USB 2.0 ports on board so I couldn’t try this option. This problem made me crazy since I never found any single issue for around 1 year using UR12, and I am connecting the audio interface to the USB 3.0 ports since day one. I believe the latest Windows update causing this issue and maybe something has conflict with the Yamaha USB Driver.

Best of luck for all of us :crossed_fingers:t4:

Hi guys,

Just a little update from me.

First of all, I check my machine latency using latencymon and found out that NDIS.SYS is causing the highest latency. So, I googled using keyword “NDIS.SYS latency” and there are lot of people having the same issue. Sadly, I couldn’t find one perfect solution on the internet.

I’ve been looking for solutions on the internet and try to compile any single information that I could use to overcome this issue. So, here is what I did:

  1. Change storage controller mode to AHCI in BIOS. I use SATA SSD Drive and found an article somewhere that it would run best in AHCI mode instead of IDE or RAID (RST).
  2. Uninstall Intel RST storage controller driver. I am not sure what the exact name of the driver, but it should be under Storage Controllers in the Device Manager. If you couldn’t find it, on the top menu of Device Manager click View > show hidden devices. Then it should be appear under Storage Controllers. Remember, I uninstalled it, not just disable the driver.
  3. Disallowing auto turn off for USB devices. In Device Manager, expand Universal Serial Bus controllers. Right click the first USB Controller, click properties. Choose power management tab, untick “Allow the computer to turn off this device to save power”. Hit OK.
  4. Re-install the latest Yamaha USB Driver V2.0.4
  5. Update my network adapter driver to the latest version that I could find on the internet.
  6. Updating Windows to the latest July cumulative update. I didn’t Update and Restart, but I Update and Shut Down, and then turn my laptop back on.

I still found spiking sometimes using the latencymon, but the high latency doesn’t seems causing any audio dropouts or crackling or something else. And now the problem seems gone, hopefully for the rest of the lifetime of using my laptop and the UR12. Hope this helps someone out there.

こちらに記載されている全ての項目を試しても、問題が解決される事はありませんでした。以下は私のパソコン環境です。

Trying all the items listed here did not solve the problem. The following is my computer environment.

OS:Windows 10 Pro (ver.21H1)
CPU:Intel(R) Xeon(R) CPU E5-2620 v4 @ 2.10GHz 2.10 GHz
RAM:128 GB
SSD:1T
SYSTEM:64 Bit operating system, x64-based processor I sincerely hope that the problem will be solved.

64ビット オペレーティング システム、x64 ベース プロセッサ

問題が解決する事を心より望んでいます。

hi
i not normal
maybe you have a conflict with another periphical in windows who share the same usb bus than your usb audio card
so you have to go there (see the image)


see if there no other device who share the same usb bus from your usb audio card.(you will the same number for two device) if it’s so …try to disable the second device and see if your computer still working .
disable all the windows usb save energy mode and put your computer on the maximum performence mode disable all sleep mode put your cpu at 100 % there

see in the bios if usb setting are well ! usb 2 full speed
good chance

Hi Julian
It would be interesting to see if you continue to have no problems. I’ve tried all the solutions over time on here sometimes I think its working then it does it again. I saw an answer below and I think it is definitely power related. I never had the problems with my previous underpowered laptop I couldn’t use 2 things at the same time but no audio dropouts. Since changing to what I thought would be more than enough for recording which is bad enough for audio dropouts, but I cant or just couldn’t use for live performance.

I’ve contemplated buying another brand audio interface I don’t know if anyone has tried and not had the same problem occurring ? This problem though has been around for years I cant understand Steinberg’s lack of investigation or response/solution.
Even if some of these solution going into Bios etc work surely just connecting something the correct way should be sufficient to work or am I expecting too much from Steinberg?

|Processor|Intel(R) Core™ i9-9880H CPU @ 2.30GHz 2.30 GHz|
|Installed RAM|32.0 GB (31.8 GB usable)|
|Device ID|9C776530-934D-464A-8068-73174E8352A3|
|Product ID|00330-52799-04570-AAOEM|
|System type|64-bit operating system, x64-based processor|

Hi David,

First of all, this audio problem is really annoying. I feel you. And you have a more powerful machine than mine, so it should be fine working with the audio interface and more than capable of handling audio works.

I want to update my machine condition right now. Been spending weeks and sleepless nights to investigate the problem and looking for solution. After my last update here, I still found audio dropouts though is rare. But, I finally fix the problem somehow.

I updated Nvidia driver by downloading the most up to date driver and performed a clean install. I didn’t update the driver through Nvidia Geforce Experience. Also, I updated the latest driver for my network cards from device manager. I right clicked the network adapter, open properties, choose update driver. Instead of letting windows find the most up to date driver, I already downloaded it. So, I choose to update the driver from the available offline file. And I choose the available driver from the list.

After that, windows suggest me to reboot my device and I let windows to do the work, while the Steinberg Audio Interface still plugged in to the USB port of my device. Surprisingly the dropouts problem is gone. I haven’t try to shut down my device since then. Will let this device stays on because I have some audio projects to be finished at the end of this month.

I also open Latencymon to see if the latency problem is gone, and it is still have high latency with NDIS.sys driver, but it doesn’t causing any audio dropouts. It is confusing but as long as the dropouts is gone it should be fine for me.

Maybe you should investigate more in what is causing your audio dropouts problem. It could be a crash in driver besides the high DPC latency. And don’t forget to update your windows to the latest version before performing driver updates. Make sure you download the latest version of any driver from the manufacturer’s website. Don’t let windows to look for the most up to date driver since I couldn’t rely on it.

I’ve contemplated to buy another brand of audio interface as well. And even to buy another laptop. But these last couple days everything works fine so I decided to hold my spending. I believe my audio dropouts problem occurred after I updated Windows in the end of June. So, if there is any windows update, you may try to update it to find if it fixes your problem.

Last, if you could do a clean installation of windows (reset) it would be worth to try. I assume you are using windows 10? You can follow the step by step by looking at this link:

And after it finished resetting your PC, let windows find all of the driver needed, install the yamaha steinberg usb driver, and connect your audio interface. I found that this method helps someone in some audio forums out there.

At last, good luck for you, Sir. Hopefully your problem solved really soon. :crossed_fingers:t4: