UR22 USB light flashing

My UR22 USB light is flashing white. So far, I have tried switching ports on the front and back of my computer. Found no solutions on line, so I am hoping that someone can help me.

FYI, I am a newbie for home recording, so it may be a very novice mistake that is causing this.

Windows 7, Cubase 8.05, UR22

Hello jlapierre,

have you installed the drivers for UR22 correctly?

Best regards,
Stefan Schreiber

I was having the same issues. Sometimes, and by that I mean rarely and randomly, the USB light would blink for a couple seconds and then connect. Most of the time it would just blink for hours with no luck. I bought a new USB cable and it seems to be working fine now. I’m curious if this is a fix since it’s so obvious. Hopefully that’s all it was! Crossing my fingers every time I connect it

sookunetta, has the New cable really fixed Your problem? I seem to be having the same issue. Sometimes when starting up the UR22 just doesn’t seem to Connect (keeps blinking), and sometimes it flashes a cople of times and then Connects (steady light). Seems totally random. And if it keeps blinking and I disconnect the cable again and wait a random amount of time it Connects, and again sometimes not. It’s just totally annoying… Any solution?

I am with you it seems totally random and doesn’t seem to have anything to do with the computer. It will blink with any cable I use and no cable at all. If I swith it to class complant mode it still doesn’t work. My Mac will not recognize it regardless even after multiple restarts and then it starts working seemingly randomly.

Just to be clear, are you all turning on the interface (UR22) before starting your computer? That is typically the correct procedure.

Yes and have done multiple restarts of the computer with it on. Crazy thing is after yet another couple restarts it is back to working again.

Thank you for directing me towards a cable problem. All I did was to remove the USB-cable from the computer, and without a restart plug it back in again. Since then, all day to day, it has been blinking, no matter restart or reinstallation of drivers. Changed cable and all is fine.

That is; allmost. The reason for my unplugging of the USB-cable was an irritating problem of silent gaps in every tunes I play. A cuple of times in every tune.
Now I have to find someone who can help me With that.
Again, Thanx!!

I haven’t found that on/off button on my UR22.

when this happens to me it seems that the only thing i can do to fix it is simply
restarting the macbook with the UR22 plugged inn.
and ofcourse have the right driver installed.
but my problem here is that my macbook is from 2011 and it takes to long to restart it
and i really want to find a quicker way to fix this so im still in the same ´ínspirationalzone´´ when i open logic pro x.

I have the same problem. Never happened before, it started to happen after I installed the last drivers 1.10.0.

The strange thing is that when I open my daw it stops and everything works ok. So I think for me is a driver problem, maybe I have to reinstall the previous driver.

Even if I restart the computer it stops, it happens after I turned of the PC and has been off for some time. :confused:

Do you know how to uninstall the drivers and clean up everything related?

Same blinking USB light problem after update to 1.10.0.

Playing audio from web browser doesn’t stop blinking but starting DAW with ASIO drivers does.

Great, so I’m not the only one.

I reverted to previous drivers, everything works fine now.

No answers or fixes from Steinberg. Do I have to think that my UR22 is a victim of programmed obsolescence?

Guys so there was an update for the driver called 1.10 which caused the interface to do that, it wouldn’t work and the usb light would keep blinking. I uninstalled the driver and found an older version of the driver. I installed that and it fixed the problem. http://www.yamahaproaudio.com/global/en/downloads/firmware_software/yamaha_steinberg_usb_driver/yamaha_steinberg_usb_driver_win_latest.jsp

I just bought this unit and can’t get my 2015 macbook to recognize it. However, I just saw an interesting suggestion on another forum about the problem, and that is that the unit isn’t getting enough power from the USB connection. The solution is to connect the power supply. I bought it as demo without any other packaging, so I’ll try and score the power supply and see what happens.

Why don’t the rest of you try that and see if it has any effect.

Connect the power supply to what? UR22 has no hole for power supply! My laptop is connected. I tried also what the guys above suggested - restarting with the interface connected. Still doesn’t work, keeps flashing forever.

hello, i bought a used audio interface UR22 and it didn’t come with the download access code, what should I do? garageband won’t pick it up. Please help, thanks.

I think you have a switch on the back to switch it to class compliant (CC mode on). It should always work but be sure to download the latest firmware and driver updates otherwise. If you have tried both of those things you might have a bad unit.