UR22mkII does not working correctly

Hello there. Problem has started since 16 days ago. Prehistory:
I bought a Steinberg UR22mkII pack that includes:

  1. Himself
    ST-M01 mic
    ST-H01 heaphones

I pluged my UR22mkII in USB computer port, installed latest (1.10.1) Yamaha Steinberg Driver, restarted my PC, installed firmware v1.04 and again restarted him
It was seems to be good but…
The sound stops and again starts sometimes but he starts with smooth fade-in and firstly from one of channels (left or right). USB indication blinks once when that thing happens. This is absolutely random. This could happens once at 30 minutes or could happening every few seconds before I restart my PC. There is no triggers that make this be. USB indication blinking doesn’t affect on monitoring by the UR22mkII. And as I understood - interface still recognizes by the PC when USB indication blinks. Video or audio has to stop for a second when USB indication blinks. All of these could happens even when USB indicaton doesn’t blinks.

I swear to god that the trouble is in inteface because I tried him on 3 diffirent PCs and with 16(!!!) diffirent USB cables.
System: Windows 10 Professional X64 1803 on every PCs i tried on my card

What the problem is?

Everyone and their uncle has this problem with the UR series, thousands of posts going back years. It makes my life hell. I have no solution other than the sweet release of throwing it in the bin.

If you are connecting to a USB 3 port, there can be interactions where Windows momentarily disconnects the driver. There is a fix in the article below:

http://www.tomshardware.com/answers/id-1744364/hard-drive-disconnecting-reconnecting.html

Also look for possible solutions here:

viewtopic.php?f=157&t=135259

Good luck solving your issue!

Pure nonsense.

I’ve had mine for about nine months. Took a while to get it working, and then an update killed it a couple of weeks later. I noticed there was a new update of Cubase and USB driver (I think the problem is the latter). It still does not work. No lights, no nothing. I’ll beat my head against it a little longer,as I’m not used to blowing good money on what is essentially a paperweight.

I’m an engineer, an electronics designer and embedded software developer. I’ve written Windows USB drivers. And I can’t get this to work. The lack of support shown by the company on this forum is pretty sad.

3 Likes

new windows update ,new driver and this same problem,i also bought new pcie usb card hub ,and same issue which mean its not my mobo chipset fault,can you fix it pls? or should i use old win10? im scared of that bcuz of it vurnability of that scary virus that lock your pc!

Hi Everyone, I’m new here from Hungary, and I hope someone can help me. I have an UR22 mkII USB interface … a brand new one. Everything runs well with the PC and with WIN10 … synth line in, mic, MIDI … really everything. Only one problem I have what I do not understand. I cannot record sound with the waveleb and with Cubase example from YouTube or etc. Let’s say any internal sound I cannot record. There is no signal. Very simple what I want, to record a drumloop from youtube for example. Would you have any idea or description what I have to fix or set. What can be the problem?

Thought I would check in here again, to see if there has been any traffic. I may try to get the Paperweight22 MkII working with one of my iPads–I have a brand new one, and one that is a couple of years old. Wish me luck.

Mine does not work since a week now. USB led OK, can be found on Windows10 and seen by my Cubase, but NO phone and NO output sounds.
No feedback on support request.
No support from Steinberg…

SOLUTION THAT FIXED IT FOR ME IT ON WINDOWS 10:
-Go to windows “Data protection settings” (Not sure what it is in English). Then go to microphone settings and make sure that you allow programs to use the microphone. My windows update had reset that setting for me.

Hi I have now issues in guitar input. When I put plug cable there is some odd shimmering. WTF? Mic-inputs works. But yep guitar input is dead. I tried it to new usb-port and installed drivers again but fak it. Weird sounds kihinäää…must send this shit back to music store.

Usb3.0 has some power saving mode that lets the hard drive power down.
Try this: Control panel/power options/change plan settings/change advanced power settings/USB settings /USB selective suspend setting >>>>> DISABLE IT!

1 Like

This post was flagged by the community and is temporarily hidden.