UR22mkII turns on and off for a moment (USB light turns off and on) randomly

I can’t google the same problem at all (I guess?) and I am confused about what to do. It’s connected to USB 2.0 port, I have the latest Yamaha USB Drivers and updater from the official website.

I noticed it while playing, using DAWs and listening to music, sound disappears for a very brief amount of time and appears again. The problem occurs randomly throughout the day. I suppose the whole unit turns off and on because when it happens, USB light indicator turns on and off as well.

1 Like

I have the same problem. Any help?

I am trying to find (hopefully) the software problems first. I will turn on LatencyMon for a couple of hours and see if something happens with latency. I wonder whether it also can be system’s sound drivers switching for some reason or something is wrong with power circuit of the interface.

Have you tried a different USB port on your computer?

The blinking USB light usually points to a problem in the connection with the computer. To make sure there is no driver or hardware problem you can also check the Windows event log in the System area. Try to find error entries that point to USB issues

AMD motherboard, by any chance? If so, revert your BIOS to AGESA 12.0.3c or earlier. Or, turn off PCIE Gen4 (use Gen3); or try a USB hub or card.

Yep, AMD board which is MSI B350 TOMAHAWK. Are all those solutions you listed are specific to AMD mottherboards?

I tried different ports, now it’s connected to USB 2.0 port. LatencyMon seems to show that some network driver may be causing issues, I will try to find solutions for this one.

Unfortunately there’s a whole world of AMD pain regarding AM4 motherboards and borked BIOSes, in respect of USB stutter particularly. Folks have had all sorts of issues with USB disconnects - mice, audio interfaces, the whole lot really.

I don’t think a complete USB disconnect will be due to too much latency - you might get crackles etc. but the hardware shouldn’t switch off.

That said, you have your board and I’m guessing you can easily try the PCIe Gen3 in your BIOS - won’t hurt anything and you can switch it back*. Reverting the BIOS is a different matter - your board may or may not allow going back to earlier BIOSes.

*EDIT - does your board do Gen4, might not?

Check out r/AMD over on Reddit, there’s a whole bunch of useful stuff along with all the moaning.

I could be wrong about this, but it’s easy to check. I have an MSI X570 Tomahawk, BTW. Better to do that before you RMA hardware, or buy new kit.

There’s no PCIe Gen4 on my board, so I guess one less culprit there. I will check out the reddit page, thanks for advice. The LatencyMon program found some latency issues in one driver and I updated it, I am going to watch whether it fixed the problem.

LatencyMon recorded ndis.sys aka the ethernet(I suppose?) driver having latency issues, so I updated it to latest version and going to watch whether it fixed my issue or not. (EDIT: It didn’t fix the problem)

If it’s not the problem, I am going to look into BIOS update way.

I’ve deliberately avoided updating my BIOS due to this very issue. Fortunately I was able to downgrade.

Hope you get it sorted anyway.

I’m on Intel and having this issue on two different computers one is 10th gen and one is 12th gen intel, same audio hardware (UR22 mkII).
Doesn’t matter which computer, I still get dropouts/disconnects.
At some point soon I’m going to test on mac and see if I get dropouts under the same load.
I’ll report back if I notice any difference.