UR242 DSPMix / Cubase Pro 11 -

Has anyone here figured out a valid work-around for the known issues caused by using the UR242 / UR series with Cubase + MacBook Pro.

I’ve experimented - several attempts - with uninstalling drivers, removing the extension file for the DSP utility and checking that the hardware controls for the DSP utility can be seen in the racks section of Cubase and have ensured that the unit has the proper firmware updates installed.

I can get my Macbook to recognise the AI and work with it through other applications but with Cubase there is nothing.

It doesn’t ask for licensing info for Basic Suite also but can open these programs.

It’s obvious that this is a known issue with this series of AI’s. After watching a multitude of videos and reading the forums here I am no closer to fixing this in terms of using it with Cubase.

What version of OSX are you on?

Is this the known issue you are referring to?
https://helpcenter.steinberg.de/hc/en-us/articles/115001790330-macOS-Audio-interface-cannot-be-selected-and-is-missing-in-Audio-MIDI-Setup

macOS Catalina version 10.15.7 -

It’s an issue mentioned by several other threads where the audio cannot be heard in Cubase - this is because it is controlled by the DSP utility outside of Cubase - I’ve tried just about every fix mentioned to resolve it…

The actual interface is installed correctly on my Mac - it’s present in audio MIDI setup and works with other apps.

(Watching from 06:11 explains the issues the unit has with Cubase)

I’m not entirely sure what you mean. dspMixfx is not available when you use Cubase, its functions are replaced in the Hardware tab of the mixer, which is what the author is explaining at 6:11 in the video.

Or did I misunderstand what the problem is?

Understood - The DSP functionality is utilised in Cubase via the hardware tab in the racks section - the video above explains this - but as mentioned above no sound is happening via Cubase. The DSP function shows that the AI is working independently of Cubase and it works in other apps also, it just doesn’t seem to work at all in Cubase in that racks section where you are supposed to be able to control it.

I can hear monitoring via the interface but there is no signal for any audio in Cubase. I’m creating an empty track with just guitar (Mono 1 - Mono bus Line 1 - Stereo out)

I was reading several threads that mention similar problems relating to UR series AI’s

Hi Emma,

Have you had it working before or is this your first go at getting it going? You should be able to turn on monitoring and hear yourself:
https://steinberg.help/cubase_pro_artist/v9/en/cubase_nuendo/topics/setting_up/setting_up_audio_monitoring_c.html?hl=monitoring

Also are you choosing a project template when you open Cubase or a blank project? I use a UR824 and often select the project template with that name because it has all the routing set up already with each of the channel inputs ready to record into. You’ll see in the video you linked he has the all the I/O for the UR242 set up this way:

Have you got all that set up?
https://steinberg.help/cubase_pro_artist/v9/en/cubase_nuendo/topics/vst_connections/vst_connections_c.html

Yes, all the input / output buses are set up. I can hear monitoring through the headphones ok but there is not actual signal for any inputs on tracks I create.

I’m creating an empty track in Cubase with a mono setup to record my acoustic guitar. It can be heard for monitoring and studio setup indicates that the inputs are active that I’ve made buses for.

What about Audio Connections? That also needs to be set up.

But what about the outputs and/or Control Room in Audio Setup?

Outputs are shown as Steinberg UR242 Mix out (Stereo) and also there is an FX output. I didn’t set up control room because as far as I have read it is only available for one output at a time?

You don’t need to use the control room. Though it can certainly have more than one output routed to it.

Your settings seem correct.

Hi Emma – that is really weird. It sux you can’t record any music.

I’m not an expert with this but have used the UR22 MKII and now use the UR824 so I know the software. I am just shotgunning ideas that might help.

We know the interface is powered and working – Cubase must be seeing it in order for those functions to appear in the hardware section above the channels. Have you tried hitting record on the transport and seen if anything is recorded on the track?

Have you definitely got all the latest firmware, drivers and tools installed from here?

Oddly enough, with MacOSX 10.15 you could also try the older packages too if the newer are ones are what you are already using.

Is the CC mode switched off?

Have you given the OS permission to access the microphone?
https://helpcenter.steinberg.de/hc/en-us/articles/360002973880-macOS-Steinberg-program-would-like-to-access-the-microphone-

Have you maybe tried another USB cable as sometimes they can kink internally and leave you with only partial functionality?

Other than that I would try to just go back through manual again especially inside the Cubase part of things and see if there is anything you are missing:
https://download.steinberg.net/downloads_hardware/UR44/UR44_documentation/UR44_OperationManual_en.pdf#G5.1178160

Or it might be that an OSX upgrade could help. I use Cubase in Windows myself and had slight bugs with Cubase and the UR intergration features that were cured by an upgrade to to Win 10 from Win 7.

Short of that you may have to put in a support ticket in your area and see if they can help. I know this is a bit hit and miss for some users:
https://helpcenter.steinberg.de/hc/en-us/articles/206530864

I have been lucky in Australia as they are quite responsive and helpful when I haver reached out to them.