USB Dongle problem!

I’m wondering if someone who is more tech savvy could help me.

I bought a USB e-licenser from the music store and it doesn’t install the proper drivers in my Windows 10 machine. However, on my Macbook, it was detected and I was able to install my license with no problems. Also, I tried it on a newly installed Windows 10 laptop and everything installed as normal. It’s my main machine that is having problems.

Here are the steps I took to install the USB e-licenser:

  1. reboot computer
  2. disable antivirus
  3. install eLicenserControlSetup.exe (asked if I trust Steinberg software, I said yes)
  4. plug in usb e-licenser (light wax and wanes 3 times and light goes out)
  5. reboot
  6. start eLCC with Administrator rights
  7. maintenance
  8. try e-licenser in all usb ports (light wax and wanes 3 times and light goes out)

Windows Device Manager tells me e-licenser does not have drivers installed. Installing from disc could not find any drivers in the folder the eLCC installed in. Selecting manually from list doesn’t give me an entry with Steinberg or under e-licenser.

The problem doesn’t seem to be that it’s not being detected, but that the drivers are not installed.

Outside for reformatting, which I’m reluctant to do just for one software, I don’t have any other ideas.

Thank you in advance for your patience.

A few thoughts/ideas…
Are the USB ports v2 or 3? I believe it needs to be connected to USB2.

Go into device manager and delete the device from there. Reconnect and see what happens.

If that is not possible, try installing/update the driver from the device manager.

Regards. :sunglasses:

I agree with Prock - go into Device Manager and delete the device, unplug it, wait ten seconds and plug it back in.

If that doesn’t work, I’d delete the device again and this time tell Windows to remove the driver as well, then uninstall eLicenser Control Center, reboot, reinstall eLicenser Control Center, reboot again, then plug in the eLicenser and hope.

If that fails, it is possible there is something strange about the USB setup on your main computer. Some details of the computer would help - make, model, details of the motherboard if it was a computer assembled from parts.

  1. Install as Admin
  1. Get a crappy 2.0 USB hub, to overcome the maybe problem with having only newer USB ports.

Thank you everyone with your helpful replies.

The problem right now is that I’m unable to find the driver files. I assume it’s installed with the eLCC program.

I think I did this one okay. I am logged into the administrator account and the install .exe file asks for admin permissions.

I believe I have a Dell Inspiron 15 7559. It has an i7-6700HQ (2.60ghz), but it has 16gb ram and a m.2 SSD (256gb) added in. Unfortunately, I don’t have any information on the motherboard.

Here are the things I’ll need to try:

Unfortunately, this laptop only has USB3 ports. But as strummer says:

I will try and see if I can get a USB 2.0 hub and see what happens.

I will have to try that when I get home. Thank you.

Since you confirmed that you only have USB3 ports…

Check this out about the USB3 concern. it is mentioned that they may work better connected to USB2. This is most likely the cause of your issue. The article mentions something about changing a setting in the BIOS.

https://helpcenter.steinberg.de/hc/en-us/articles/115001649984-USB-eLicenser-is-not-recognized-license-missing-dongle-key-

Sucks… :unamused:

Regards. :sunglasses:

Unfortunately, none of the suggestions worked. I ended up having to reformat and reinstall windows 10, and the e-license USB was installed okay.

Thank you everyone for their advice.

Glad it is working but… yikes, that’s a lot of work! I wonder if doing this scan would have fixed whatever was messed up with Win 10. We have to remember it for next time (hopefully which will never come). :wink:

https://www.steinberg.net/forums/viewtopic.php?f=209&t=162123

Regards :sunglasses: