Using Artist Mix as a Midi controller

I have long wanted to use my Artist Mix as a midi controller and have recently been pursuing this with some vigor. With the help of half a dozen people, we have successfully cracked the code for using the Artist Mix as a midi contoller in EuCon mode without anything more than a virtual midi port. I am on an iMac version 10.14.6 with Cubase 11.0.30.

Everything seems to work great. Pushing and pulling the fader controls the dedicated CC and the instruments are responding as they should. I can open the midi editor and move the fader and see the numerical values of the midi lane raising and falling in real-time. When I go to record, the numerical values change, the instrument responds, but no CC data is being recorded. I also tried recording in the automation lanes as well by enabling the write mode for the track and still nothing is recording. Any ideas on why this is and how to fix it? We tried this on multiple machines and the outcome is the same.

Hi,

Use MIDI Monitor MIDI Insert till find out, the track receives the MIDI data.

If not, double-check the Preferences > MIDI > MIDI Filter, if the data are not filtered out. Also make sure, the MIDI Input is set to All MIDI Inputs on the track. And make sure, your virtual MIDI Port is part of the All MIDI Inputs in the Studio > Studio Setup > MIDI Ports Setup.

Midi Monitor is reading Controller 1 upon moving the Fader as it should.
Everything else you listed is as you listed.
That is what makes this so perplexing. Midi data is getting to the track but it just won’t record.

Hi,

Did you double-check the MIDI Filter, please?

Can you record the MIDI data from any other source?

Is the EuCon component still active at your system in Cubase?

Midi Filter Double checked
Yes, all other midi devices are functioning properly.
Yes, the EuCon component is still active at Cubase and functioning properly.

Hi,

Sorry, I don’t know, how did you crack the EuCon code… Isn’t it in the crack then? Doesn’t the component block to record the MIDI data to the track?

It’s quite a simple set-up. The original way was to use a 3rd party plugin like Bome or Bidule. You set up a dummy midi track and assign a fader from your Eucon device to the dummy track. The midi track received the Eucon signal and send it out on your 3rd party plugin where the midi data is translated and transformed to whichever CC you wanted. Then it is sent back to Cubase as midi in.

The new way you set up a virtual port. Then you create your midi track and you use Cubase midi transformer to change the CC data. Lock a fader on your device to your dummy track and play your instrument. You’re sending the midi data out and back to Cubase on your virtual port.

Hi,

Let me summarise it, if I understand it right.

So the input to the track comes from the virtual MIDI port, right? And you change the MIDI CC by using MIDI Insert Transformer, right? It means, you record the source data to the track and then the data are transformed by the MIDI Insert Transformer. If you want to record the transformed data, use the Input Transformer, please.

Ok so the chain is as following-

there is a locked fader on the device for the Dummy CC track. We’ll Call it CC 1 track
So when you move the fader, the Midi Monitor shows Controller 7 coming in.
On the CC Track, I put the midi transformer and send it out on the virtual port (nothing on the midi in) Now the midi monitor shows controller 1.
The virtual port is listed in the midi in of my midi instrument tracks. These tracks are routed with “All MIDI Inputs”
Midi monitor shows CC 1 when the fader is moved
This message won’t record.

I have tried using the Input Transformer exact same results.

Hi,

Could you try in the Cubase Safe Start Mode [Disable preferences], please?

I did as you asked and opened Cubase in Safe Mode. No change. I tried the transformer as an insert and on the input (separately of course) to no avail. Again the midi meter is showing the proper CC data is being received and transformed, the instruments are responding as they should but the midi cc will not record as midi or automation. I tried both ways just to check. If you have a Eucon Device (Artist Mix in my case) and would like to replicate it, I can provide you with detailed instructions on the setup.

Hi,

What does the MIDI Monitor on the 2nd tracks shows?

If you are talking about the track with the instrument, it shows that Modulation CC 1 is being used.

Hi,

I’m sorry, I’m getting out of ideas…

Could you attach the screenshot of the Preferences > MIDI > MIDI Filter, please?

Hi,

All look OK for me. No more ideas, sorry…

Thanks for trying. I am including a link to a very short and poorly produced video that I just put together showing you what is happening. I enable record and play a master piece using only a few notes with my normal midi controller and keyboard. I keep the recording going and play a few more wonderful notes using the Eucon and keyboard. I notice that it is ‘trying’ to write but something is amiss. Have a look if you will.

Hi,

Thank you for the video. Could you try to select the very first MIDI CC1 event in the Controller lane and then press Arrow Left, please? What can you see in the Info line then? Is there any Controller selected? What is the Start Time? And what happens, if you press the left arrow again?

My expectation at this moment is, there is some kind of timing issue. One of the MIDI device (wither EuCon or the virtual MIDI Port; I would probably say, it’s the virtual MIDI Port) doesn’t send proper information about the time.

Maybe you could see this in the MIDI Monitor too. Maybe the MIDI Messages have different color or there is a node next to the MIDI Message.


That would make sense. I have this project set up to start on measure -1 and I extended the midi event to the begining and still can’t see where the data was written. I will look into a different midi port. THanks for taking a look at this stuff for me. Your assistance is greatly appreciated

Hi,

Even when you are recording the MIDI data from EuCon, we can see, the background is changing at the beginning of the Key Editor (on the left side). So this is a hint, Cubase tries to write the MIDI data to the very left position for some reason.