Vanishing tempo and signature tracks

I’ve experienced this a number of times lately. I know the tracks were there because I edited them. Plus, when I try to add them again I get a message that they already exist. Nonetheless, they’re no longer visible despite all the resizing / toggling / jiggling tricks I can come up with to make the screen refresh.

After an extended period Googling for information on this, the consensus seemed to be, “Your project is corrupt.” Fortunately, I had backup versions so the loss of data was minimal. That said, it’s somewhat disquieting to live in constant fear of these tracks randomly disappearing. With that in mind, I have a couple of questions.

  1. Have others encountered the vanishing tempo / signature track problems? If so, is there a solution or is the project in fact corrupt beyond repair?

  2. If the problem is project corruption, what sorts of known issues are there that would cause this and, more importantly, are there steps I can take in my workflow to avoid corruption?

I’m running the latest patched version of 7.0x . I move between two environments - my desktop and my laptop, both of which are running Windows 7 32 bit.

My system has been very stable and reliable in both environments. The tempo / signature problem is the only project issue that I’ve encountered.

Any insights would be most appreciated.

I’ve not seen this on another system. I’ll send you a PM to see if you would like to send me the .cpr file. Please be sure you are on 7.0.7.

Thanks, Chris!


I just noticed that I can open the project browser and I do see entries for those two tracks. Of course, clicking on them opens the full screen UI, but at least it’s there.

What’s missing are the regular tracks that are created in the view along with tracks such as audio, midi etc.

Just wanted to mention this as I suspect it’s a bug so any info will help the guys slinging code.

Did you click on the “divide track list” button?

Yeah, that was one of the things Google turned up so I tried it, but I just get an empty row.

Are there additional steps to take after clicking the divide tracks button that would help me recover visibility?

If the actual track divider line was pushed all the up to the ruler, you need to click and drag it down with your mouse.

It actually opens up with about an inch of empty vertical space, as though it knew it had two tracks to display, and then just didn’t display them.

Dragging up or down to resize it doesn’t trigger any additional display.

If you’re using Cubase 7.5, is the track visibility on?

I’m running 7.07. I checked for that feature but it appears to be 7.5 specific.

You say, in your original post, that you have experienced this several times. Has it happened in different Projects, or always in the same one?

It’s happened in several projects. Last night I noticed it in 3 or 4 out of around 40 that I opened.

I couldn’t come up with any pattern or commonality between the problem children as they all use the same overall format: Marker, tempo and signature tracks and a collection of audio tracks, no MIDI. All 40 projects are 48k, 32 bit, and were created within the same week.

Ctrl-T is the default key to show the full tempo window - just saying that to help not to fix!!

But maybe these tracks are in a folder somewhere? Maybe the Group, VSTi or FX folder?


Hey, I appreciate any and all help. Yes, Ctrl-T will give me the full window, which is how I salvaged the situation on the tempo. The signature was all 4/4 in this case.

I did discover today that if I bring up the Project Browser window, I can see the tempo and signature tracks listed. Double clicking them brings up the full window, so at least I can get to the data. So, clearly, this is an issue with the display of the tracks and no loss or corruption of the actual tempo or sig data itself.

I’ll take good luck wherever I can find it. :slight_smile:

As an update, I’ve discovered how to reproduce this issue. I run both Cubase AI and the full version. Since these tracks aren’t supported in AI, if you save a project created in the full version in AI, it alters the project file so that these tracks will never again be visible, even in the full version.

It was pointed out to me by GC that this is stated functionality, i.e. saving projects in a limited version turns off the unsupported features. I’ve asked him to submit an enhancement request to fix this in the next update of AI 7.0x as, stated or otherwise, I feel that altering the project so that the full license version loses functionality amounts to data loss. For people like me who use both systems, it means I’m always one accidental save away from project corruption.

My thinking is that a limited version should limit the funcationality rather than preventing the full version from providing it.

Anyway, since I’ve discovered how to reproduce the problem and also have received feedback on it, i wanted to follow up here for the benefit of any others who might encounter this.

Thanks as always to the SB support folks and their rapid responses.

Good to know (and I agree with you completely) :slight_smile:

I have confirmed the issue with the developers and currently it is expected behavior for the feature to be removed when opened in a lower version.

That said, I have placed a feature request with them to allow the Tempo/Signature Track to be either retained or able to be brought back when saving from a higher version to a lower version then back to a higher version. For the time being, my best suggestion would be to continue to use the Tempo Track window (Ctr-T/Command-T).

Thanks for submitting the feature request Chris, much appreciated.

There are some subtle differences between the full view and the track view. I was working on a project last weekend where I needed to change from 4/4 to 6/8 and then back to 4/4. There were already a dozen songs in this sequence with markers at the start of each. I went into the full signature view, which only allows you to insert at measure granularity (as opposed to measure.beat.etc.etc) and added the 6/8 tempo. Then, when I added 4/4 tempo at the measure for the following the song, it and all subsequent song markers shifted to starting at something odd and inconvenient like x.4.1.0 or something.

Once I realized the version problem and had gone through the process of copying / pasting / recreating the entire project into a new one created in full 7.0x, I located to the song marker following the 6/8, deleted the previous time change and in the Signature track added a a new change to 4/4. All markers then started on 1, everything stayed lined up, and it was quick and easy. This is, of course, due to the fact that the next 6/8 measure is landing in a different place than the location of the pre-existing song marker which, in 6/8 time, wouldn’t have been on an even measure 6/8 boundary since it had been placed when all songs were in 4/4.

I’m probably explaining this in a convoluted manner, but suffice to say that having the tracks there offer more than just visual convenience - there’s a functionality difference as well. So, if they’re up for making this change in the next maintenance patch for AI, it would be most appreciated.

The track does not offer more granularity for placing time sigs than the editor window– time sigs by definition are only on beat 1 of a measure, and other object’s bar/beat start time will conform to it.

E.g., you have a 4 bar segment in 4/4, and a marker is at beat 1, bar 3.
You insert a 9/8 sig at bar 2, now the marker is at beat 9, bar 2.

I hope I’ve understood what you were saying!

I’m sure Cubase AI/Elements will not get a sig track– what Chris requested was for the tracks’ existence to not be disrupted through saving in lower Cubase versions. And +1 from me too on that.

Crap. Now I can’t reproduce the fix I did. But it was something very similar to my notes, because I was delighted that I could simply insert the sig at the marker from the sig track and everything lined up.

Oh, well. All’s well that ends well.

And yeah, I wasn’t soliciting AI/Elements getting a sig track, but rather that saving in AI wouldn’t permanently disable the feature in the full version. And I believe that’s the feature request that Chris put in for us.

As a little background to my twitchiness, my first job as a professional software developer was in central Florida, during the summer, where thunderstorms every afternoon are guaranteed. And this shop didn’t have the computers on a UPS, meaning if the power bounced, you lost your work. Consequently, I tend to habitually type about four keystrokes and save, no matter what app I’m in. When I did that in AI, of course, I was screwed, which is how this all came about. Old habits die hard. :slight_smile: