Variaudio keeps freezing Cubase 12, Mac M1 Max

Hello Yall!

Hope I’m posting this in the right Category.

I have upgraded to a Mac m1 Laptop a few months ago, prior to I was on custom PCs.
When using Variaudio, I notice after a time, roughly 2 minutes or so, If I am constantly moving pitch blocks up or down or correcting audio, Cubase will just freeze and give me the spinning rainbow circle. At that point, Cubase is just not responding. It doesn’t crash out nor give me any crash logs, I have to always force-quit Cubase.

I tried to recreate the problem a few times. I found out that the Disk Load goes crazy when I move a pitch block. I noticed it doesn’t spike when dragging a block, but rather it rapidly flashes around 50%.
I tried playing around with the ASIO Guard, taking it off, or keeping it on and playing with low to high guard levels, I also tried with the disk preload at 2 and at 6, and it doesn’t seem to change it much, it still rapidly flashes and then just…freezes.

An important thing to note is that in a fresh project with one small audio file, at 32 to 64 Buffer size it will freeze quicker, at 128 and onwards it seems to survive and not freeze. But when Introducing a large project with many audio tracks, It freezes at its lowest and highest buffer size. Also, I usually work in 44.1 or 48Khz and mostly 24bit, sometimes in 32bit float, though for these tests it’s been 24bit files.

I am led to believe that it’s maybe an issue with the SSD or with my RAM, but I was under the impression that these M.2 ssds could pull off some amazing read and write speeds, and I would have enough ram to boot, I have 64gbs of it.

It’s a shame because I feel Variaudio is very fast and easy to use compared to Repitch and Melodyne. (I own Melodyne and have been playing with the trial or Repitch). I just love that the pitch block cut tool is as easy as holding the shift button and slicing away. I will say that I haven’t had any issues with Melodyne via ARA2 though…but I am a fair bit slower at it. RePitch seemed to be ok too, but also just used it for a bit so I can try to experiment with that and see if it happens.

Would love to see if anyone else has been facing this issue, or if anyone has some ideas to fix it.
I remember seeing people in forums mention this would happen a lot with Hard drives and with audio files that were 88.1kHz and up or 32bit. Larger files and lengthy files seem to cause this more often from what I get.

Here are my specs:
macOS Monterey version 12.5.1
Macbook Pro (14-inch, 2021)
Apple M1 Max
10Core CPU, 24Core GPU
64gb Ram
8tb SSD Storage
Cubase 12.0.52 (Apple Silicon Native Version)
Interface is Steinberg AXR4U