Very laggy EQ animation when being automated (because of VST3?)

When I automate an EQ, as a LP filter for example, the animation is very sluggish. I’ve tried many different ones, including native Cubase Studio EQ, Frequency and Fabfilter Pro Q 2 (VST3) with all the same results.
What I found interesting is that when I tried the VST2 version of Pro Q 2, the animation was ultra smooth. This led me to think that the VST3 is format is causing this issue. Is this true? And more importantly, is there any way I can solve this?


Are you on HiDPI screen? Windows/Mac?

Do you mean the animation of the knob/controller or of the EQ XY graphics?


I figured it would be hard to understand. Here’s a video I just captured:

The first one is the VST3, the latter is VST2. As you can see everything in the VST3 version is very sluggish when being automated.

I’m on Windows 10, with a 1920x1080 screen.


OK, it’s not HiDPI. Interesting would be, if it’s the same with other plug-ins. If the issue is on Cubase or plug-in side.

So after further testing, I have a strong feeling that this problem is tied to the VST3 format. Out of all the plug-ins that I tried, the only ones that suffer from poor animation when being automated are VST3. These include: ALL of Cubase native EQ (Frequency, Studio EQ, DJ EQ), Izotope Neutron EQ, Fabfilter EQ, Ignite Amps The Anvil.
None of the VST2 I tried, from various brands, had the same issue. Really hope to get an official response from Steinberg here.

I had an e-mail exchange with Fabfilter and here’s their response:

“What happens in VST3 is that the automation is applied smoothly to the audio, but it doesn’t look smooth in the interface. The reason for this is that the host is responsible for passing the new parameter values to the interface in a timely matter when automation is played back, and Cubase just doesn’t do this very often (looks like just a couple of times per second).”

Clearly it seems like this is an issue of Cubase. Why limit the fps? I also submitted a ticket to Cubase and haven’t heard back yet.

usually for me this problem occurs when i use VST plugin which uses openGL graphics. vst 2 or 3 doesnt matter.

for excample, i have somewhere plugin - tube tech cl 1b. then i go into this very specific plugins settings, turn off use openGL. (or was it turn on, dont remember)
it requires DAW to restart, then after loading everything is solid and cool. no more lag in faders indicators or graphical equalizers (frequenzy etc)

i have no idea is it a bug or not, but it works.
maybe you have something similar

I’d be very interested to learn how you change the openGL settings of the plugins. I’m not super familiar with this.

as i mentioned, this could not be your case. but it worked for me when i was troubleshooting my own problems which were related to the gui lags.

but for tube tech i just open plugin window. there is setting tab, i go in, and disable openGL usage. thts it.
i was just thinking, that maybe you have similar kind of problem which lays somewhere in graphic usage world. since cubase is using its own GUI engine - at least i understand so, tho there could be conflicts which lay over there… something to consider.

@grypt: Thank you. I’ll investigate further in that direction.

Can everyone who sees this report whether they experience laggy GUI when automating VST3 plugins (including Cubase stock ones) or not? I’d like to know if this is because of my machine or a Cubase bug. Thanks!

Hey there, I am experiencing GUI laggyness on my new Softube EQ MP that requires Analyzer movement smooth just like fabfilter but once in a while the flow freezes then moves again.

I ticked and unticked both options and tried, but no success.

Do you know any fix? I have cubase 11 pro on mac mojave osx…
no luck here yet…

Other plugins, vst3 or vst2, never had laggy GUI issue for me here…

Duplicate post.

I am experiencing this exact same problem on Nuendo 11 with Pro-Q 3 (VST3) - haven’t tested on other plugins, but it looks terrible when the bands of the EQ are following automation and have very laggy animation.

This is not a Fabfilter problem, as it runs butter smooth in Studio One, Reaper, Ableton, etc…