Video Decoder for Avid DNxHD 3.0 update available

Dear Nuendo users,

we are very happy to announce the immediate availability of a free update to the Video Decoder for Avid DNxHD, version 3.0 now offering native Apple silicon and Steinberg Licensing support.

Every registered user will find a Download Access Code (DAC) in their MySteinberg account under the “Vouchers” section to migrate their current eLC-based license to a new Steinberg Licensing license. Once this DAC has been entered in the Steinberg Download Assistant, you’ll find the installers under the “My product downloads” section and a license will be available to be activated in the Steinberg Activation Manager (SAM).

All the best,


Awesome, thank you!

Great news. Thanks!

hey guys sorry where can I get this update ??

Thank you

as stated,

How many simultaneous activations are allowed?
three as Nuendo 12?

I’m not sure but it seems that since I’ve upgraded Steinberg’s DNxHD-decoder to v3, my ProToolsUltimate TimecodeOverlayWindow doesn’t show timecode properly anymore.

Again; I’m not sure that upgrading my DNxHD-decoder was the cause, so I’m searching for fellow-Nuendo&ProTools-users who experience (similar) issues, in order to find the actual cause of my issues.

Anyone also experiencing weird video issues after upgrading the DNxHD-decoder?

Niek/ Amsterdam.

Pro Tools Ultimate 2022.10 / Nuendo 12 / Logic X / WaveLab 11
MacPro 5.1: 12Core 3.46GHz Intel Xeon/ 48GB RAM/ Mac OSX 10.14
MacBook Pro: 2.9 GHz Intel Core i9/ 32 GB RAM/ Mac OSX 10.14
MetricHalo ULN8 + 2882 / RME HDSPe MadiFace
Euphonix MC Pro

Trouble over here on Mac mini 2018 running Mojave… dnxhd license not seen by Nuendo 12.030.
Perhaps it’s a Mojave issue but be warned that it does not work in this setup. (yes I restarted and no I’m not installing 12.0.4 or later due to a project that does not require video).

also on Monterey this is not working in 12.0.5

@Luis_Dongo i have installed and activated via the procedure, why is it not working?

I got the same message after downloading / installing the update, but after I ran the Activation Manager it was fine. Login is a bit inconvenient the way it works but it worked fine for me.

I’d suggest trying that again if you already did.

thanks, i just deactivated and activated again but to no avail. i’m not sure what is going wrong but i’m really happy this is not happening in the middle of a video project!

(see edit below - ended up getting it to work)
I am also unable to get mine working. I just purchased it for the first time (didn’t have the old version), have installed it, and successfully activated it in Steinberg Activation Manager as you can see in the screenshot. Every time I try to import a dnxhd though, I get the error message telling me to buy it. I have restarted Nuendo and my computer. Nothing seems to be working. I have a project starting on Monday that will require this so any help is much appreciated! (I supposed I could just convert to prores in the meantime, but would like to not have to do that since I just bought this!)

Nuendo 12.0.52

*****EDIT: Reinstalled it a second time, restarted computer, and it worked. All good!

I installed it 3 times already… still nothing.

hello?! @Luis_Dongo
Anyone out there?? I’m still not able to work with dnxhd… have also sent a bug report… no response.

Just double checking, in Steinberg Download Assistant, after downloading the DNXHD addon, you clicked “Open” right? And a new installer window opened up? Download Assistant doesn’t actually install it. You have to click Open and install it.

Not being able to work with the product I paid for for five days … I would freak out! (In a very kind and socially acceptable way, of course. :wink:)
I know this comment doesn’t help you. But I feel for you.

You don’t want to upgrade to a higher version, but have you tried reinstalling Nuendo? The warning from above reads like Nuendo can’t access/find the decoder.

I have checked on my other machine with 12.0.51 and it does not work there as well.

yes i opened and installed. 4th time just to be sure since there was an update to elisencer… but not working still

Has anyone figured this out?. I’m having this problem as well and now I’m stuck with not being able to play video even with the original download of video decoder .
It’s embarrassing to not be able to play these videos for clients.

Did you do this?

And exactly this?