Video playback doesn't follow arranger track

Video playback doesn’t follow the cursor when the arranger track is activated.

Steps to reproduce:

  1. Create an empty project
  2. Add an audio track and import a song to it (anything greater than 1 minute length would be ok to see the problem)
  3. Add a video track and import a video clip to it (if video track is related to the audio track will be easier to see the problem)
  4. Create an Arranger track and add 3 events (A, B and C), related to 3 sections of the entire song (parts with the same size will help)
  5. Create a new “Chain” in the arranger track, and add the events in following order: B → A → C
  6. Be sure Arranger track is activated and play it from the beginning.

ISSUE: The song starts in section B, where audio and video is following the cursor. When section B ends, cursor jumps to section A. At this moment, the audio will still follow the cursor but video will be playing part C as no jump occurred.

Cubase 8 Pro 64bits
MacOSX 10.10.1

It’s not a bug, but also you don’t understand how it’s supposed to work. It’s pretty well documented under “Arranging your music to video” in the manual.

Hello SteveInChicago,

Thank you for your answer, but that section in manual you pointed address a different situation where you can use an external MTC master and when arranger track is activated in MTC slave it will follow that time as relative. OK, it is nice but it’s not my point.

In the case I’ve described, you have a single machine and project, and the intent is not “Arranging music to video” but exactly the opposite.

The manual is very clear to say that: “You can also use the arranger track for live performances on the stage, in clubs or at parties.”

“Arranging music to video” is only one possible application where you combine video, audio and arranger track.
IMHO, the expected behavior when using live is that audio and video should follow the cursor. When you have audio and video track in sync, doesn’t make any sense jump audio and not the video.

Imagine you have a bunch of songs in sequence at the same project. Each song has audio and video parts in sync.
Arranger track is totally useless to set a setlist for a show if you lost your video sync.
It’s also unexpected and awkward to see the cursor in a position and a particular track (video) just ignore it. If you simply pause and resume, the video will be in sync again up to the next jump.

Please let me know how I should report it in a way they fix that situation I’ve described. For me it’s clearly a bug, but if steinberg thinks it’s not, at least they should add an option somewhere where I could choose to allow video track to be handled as all other tracks and follow the arranger track.

What is there to fix? It doesn’t work the way you wish it did, so make a feature request.

As you like boss… Done!

Okay chief!

A rather old thread this, but I just want to tell you that I also use the arranger track for live performances. I have the exact same issue as you describe. I have posted this several times to Cubase support but there is no fix. Been a problem since 7.5 and STILL NO FIX! Embarrasing for the developer team in my opinion.
Have you found a solution?

I had posted problems with the arranger and video a long time ago, and also made 2 support requests on this, since the Arranger DEFINITELY has problems.
The post can be found here, just if you think switching to a newer version makes sense in this particular field:

Currently I am using 9.5.50 (coming from 7, switched to 9, now 9.5.50), following the support crew’s initial suggestion to switch over to 9.
The problems have not been solved by now (just tried it again), and I am getting really mad about this issue.


According to information given by Steinberg’s support crew this feature will not be repaired in version 9.5, but is planned for “the next generation of the video engine”. How long it will take wasn’t part of the information, and also to which version this new engine relates to.
A total disappointment in my opinion.

Yup just upgraded to 10 and I still have the issue, great shame really as it would be brilliant if it worked as it should.