Video playback stuttering in full screen mode


I have an annoying issue with the video player in Cubase 10.5 (I can’t remember having the problem in 10 or earlier). I have a four monitor setup with one dedicated display for video playback. The problem is that video playback stutters as soon as I switch to full screen mode. This happens with every codec and resolution I’ve tried, and all the videos play back without any issues in windowed mode.

I found an old post from 2018 that describes a similar issue: - I don’t use a 4k display for video playback though.

So it seems that this problem exists since some time - can anybody confirm this?

There is a practical solution to this. Transcode your video with a low-cpu-use codec before you open it in Cubase. Cubase is not smart enough to do it for you. Same thing if you are planing to export video.“Handbrake” is free (available for Windows) and does the job if you select “Fast decode” in the Video codec.

I had this issue long time ago and the cause was the driver of graphics card. I updated it to the last manufacturer release and the issue was gone.
I use always mov prores 422 proxy as video codec.

Thanks, but that doesn’t fix the problem - as I wrote, it exists with all video codecs, even uncompressed ones.

I just updated the driver again, but unfortunately it made no difference.

Read this:

Read this:

Thank you, but unfortunately this didn’t solve the problem either. They are also not talking about the same issue in that thread:

like passing cars - their movement is jerky as if certain frames are not being played back

It is much worse in my case, the video stutters so badly that I can only see still frames most of the time… Am I really the only one having this problem? I have been using Cubase for many years by now but never encountered something like this before.

Hi, All!

Same problem with Nuendo.
Did someone find a solution?

Are all your monitors connected to just one video card?

It might be wiser to get a dedicated video card just for your video output (such as Blackmagic Design Midi Monitor).

Yes, all of them (three monitors) are on the same GPU (GeForce GTX 1660).
When exit the full screen and choose Half Size, Double Size or manually adjust the image size, everything goes fine.

I found a solution on NVIDIA cards, I found out that it’s the Vertical sync option on the Nvidia settings that makes it stutter. Turn it off either on the global settings, or at least on the program settings for Cubase only and it will not stutter anymore on full sceen.


That’s interesting! I’ll try it as soon as possible.

Didn’t work for me unfortunately. It seems to make the problem a little less severe, but it’s still there and makes working with video in fullscreen mode impossible.

musicay6, thank you so much, that perfectly solved the issue for me which had same symptoms as described here in my Nuendo 11.
It was only stuttering when put on fullscreen on my 3rd screen connected by HDMI from me nvidia card, no matter if H264 codec or prores422. As soon as I had the video in window mode, also scaled to the whole screen, it was fluent.

Same problem here.
4 monitors. 2 nvidia geforce gt 710 graphic cards.
3 of then 1920x1080 connected to one nvidia 710 by hdmi. The Main Cubase window 3840x2160 connected to the other nvidia 710.
All nvidia drivers updated, windows 10 64bits updated. Cubase 10.05
Nvidia 3d options in performance profle. Vsync deactivated.
Cubase 8.5 installed with no video problem. Fullscreen ok.
Same video in Cubase 10.5.30 video with playback stuttering.
My Pc:
Intel i9 2.8ghz
128 Gb Ram
Motherboard ASUS Z490-P 1200 ATX 4XDDR4
All Ssd disks.

I fixed the problem using just one Nvidia card. My nvidia 710 with 4 hdmi ouputs.
I think this was my first option but It gived me bad performance in full screen so i decided to Put another Nvidia Card in my system.
Then with trial and error (2 graphic cards, all monitors with same resolution 1900x1080 and diferent configuration) I have all monitors in the same graphic card with 3 of them at 1900x1080 and Cubase main window in the main monitor at 3800x2160…

It’s 2022, Nuendo 11, Windows 10, I still have this same problem. It went away briefly after installing Nuendo 11. And now it disappeared after deactivating V-Sync on my NVidia card.

Steinberg is seriously starting to piss me off with their ridiculous bugs, I don’t see any of those problems with Reaper happening.

Reaper reads more video formats than VLC, I’m not even joking.