VST-3 plugins are not loaded in Cubase 10

Hi

Major issue - All 3-rd party VST-3 plugins are not loaded in Cubase 10.

E.g. All FabFilter vst3 plugins are missing.
In Cubase 9.5 they work fine.

Attached plugin manager screenshots of Cubase-10 vs. 9.5.

Any idea?
Thanks!
Booli
cubase 10 missing vst3.png

Booli? Is this a serious question? I have to ask because if you look at the C10 load up vs. the C9.5 you will see that C9.5 found VST3 versions of your Fab Filter plugins and C10 only found VST2.4 plugins… (And bear in mind, some 2.4 versions are not what other 2.4 versions are, as C10 points out by accepting some of your cable guys 2.4 plugs and one FF 2.4. You need to point C10 in the right direction - find the file where the VST3 versions of your plugins are.

In my case, to makes things easier for Cubase, when I install a plugin, I check only the box that says ‘VST3’, not ‘AXX’ or ‘VST2’, etc. Why bother installing stuff you can’t use?

the same with vst-3 plugins - polyverse music and others

P_S_, not clear what you are saying but if you are saying C10 with not load these plugins after finding them, then I would remind you the the VST creator was Steinberg. If you are buying plugins that are labeled VST3 and C10 cannot use them, then the plugin manufacturers are not producing true VST3 plugins.

Highly serious question for highly serious issue.
I guess I wasn’t describing the issue clear enough, since your guesses are on the wrong path.

  • I installed C10 using C9.5 configuration, meaning C10 points to the very same plugins paths that C9.5 points at. I.e. this is NOT a path issue.

  • ALL 3rd-party Vst3 plugins are missing in C10. Highly popular plugins (izotope, fabfilter) that work just fine in C9.5.

  • Another symptom is very slow startup of C10 (over 5 minutes!). I guess it might be related, as in these long minutes C10 may try to load unsuccessfully those Vst3 plugins…

Bottom Line:
It seems that C10 currently doesn’t load any of my 3rd-party Vst3 plugins for an unknown reason.

Anybody encountered that?
Any known resolution?

Are you experiencing a significant long startup as well?

Did you check the Blacklist? When Cubase starts, does it get stuck at the VST3 scanning process?

YES

Checked. They are not there.

Hi, same problem: UAd VST Plug-ins (2.4) or Waves (2.4 or 3.6) in insert on mono or stereo tracks are loaded (the GUI works) but no input and no effect. :frowning: Only the Steinberg’s plugins work. Very annoying (Win.10, Cubase 10.0.5)

Booli, OK, I have some answers for you. First off, let me thank you for sending me down this rabbit hole - seriously - because it has really transformed the operation of C10 and WLPro. It opens very quickly now and closes qickly as well, plus, my ‘Other’ folder within the plugins list was reduced by 75% as these redundancies were eliminated. All I can conclude is that Cubase and WLPro were spending a lot of effort locating every possible VST plugin.

OK, before I begin, I realize every OS is different so what and where I changed things may be more (or less) complicated.

Moving on, key for me was using the Plugins Manager in C10 and finding where the various plugins were stored - BUT - also REMOVING THE VST 2.4 versions WHEN THERE IS A VST3 COUNTERPART VERSION AVAILABLE… Let me explain this last remark. I have always, on plugin install, unclicked every version that will be loaded onto my PC EXCEPT VST3. I always have done this - so it would be logical that nothing but VST3 plugins were installed. Well it turns out that this is exactly what happened - ALTHOUGH THE PLUGIN MANAGER CONFUSES ME HERE - because the creators of my plugins offer TWO VERSIONS OF the SAME VST3 PLUGINS: VST3 and VST2.4. Remember here that VST2.4 CAN BE A VST3 PLUGIN, keep this in mind. Interesting. And more interesting is the fact that the Steinberg Plugin Manager records/displays both of these installed versions in it’s listing, but doesn’t necessarily use the VST2.4 version WHEN the VST3 version is available… WHEN the VST3 version is available.

Within my Win7 64bit OS, most of my add-on VST plugins were located here: C > Programs > Common Files > VST3 > (Folder with name of Plugin Manufacturer, in my case: Celemony, HOFA, iZotope, SIR Audio Tools, etc. My Waves plugin shells were here, as well, but not in a folder). (Also NOTE that there will be .dll files and also ‘VST’ labeled files here of the same program. FOR EXAMPLE: iZotope will show both of these files - and - more importantly, they must both remain for the plugin to work in the C10 WL domain. But for other plugins this is not the case, they can operate without the .dll file, they are self contained it seems.

Backing up a bit, to discover where these VST2.4 plugins were located, I opened the Plugin Manager in C10 found and clicked on the particular version, noted where the file was located, and then opened the VST2.4 plugin location (But only WHEN THERE WAS A DUPLICATE VST3 version listed!). (It turns out that Cubase will always use the VST3 version when it has a choice.) When I found these files - and there are many, some stored in places BESIDES the Common Files > VST3 Folder - I closed my Plugins Manager window, created a desktop folder and dragged these possible VST2.4 plugins into it, starting with one. Then I opened the Plugins Manager (in my Project) and searched for the plugin using the Plugin Manager Search window. If It was still there, I opened the project and tried the plugin to make sure it would work. If it did I continued down this path, removing all the VST2.4 plugin versions that had a VST3 counterpart. I will add that concerning the plugins from SIR Audio Tools (I have 4 total), 3 actually use the VST2.4 version, there is not a VST3 labeled version available for all 4 plugins in other words, only 1, the Spectrum Analyzer.

OK, that’s what I did and everything is running much better than it did, you can feel the communication process between Cubase and the various plugins is way better, I’ve never had things running this quickly before. So for this I thank you, Booli! Too, if you are still confused about where a plugin is stored, you can reinstall it and it will typically ask (or tell) you where the plugin is going to be installed. I had to do this with the SIR Audio Tools plugins. I hope this helps you ,Booli.



I’m not sure what are you suggesting.
Is the recommendation to go over my vst2/3 paths, and make cleaning?

Yes. The various plugin makers place their VSTs in at least two places and only one is needed. Also, most plugin makers offer a VST3 version and a VST2.4 version of the same plugin. Both of these will show up in the Plugin Manager but only the VST3 is necessary.

In my one picture, where I opened the ‘Other’ folder, do you see how few plugins are listed? Before I cleaned up the VST2.4 plugins it was almost 3 times this size. This just bogs C10 down and makes it harder to sort youor plugins.

Well, it may look like a lot of work but it is worth it. C10 performs better, faster. I tried to explain what I did so read it over, and again, if you are unclear what plugin version might be necessary to keep, put it in a Desktop folder and take a look at your C10 Plugin Manager.

Look again at the picture of my Plugin Manager, you will see that there are no grayed out duplicate plugins listed - all it shows are the plugin versions I am using.Good luck.

Man I’m not sure you realize the issue. You repeat your paths cleaning mantra…
I have a WORKING Cubase 9.5 environment!!!
Where all my 3rd party vsts, both vst2 and vst3 are working perfectly!!
Its not a paths issue, and not redundant/obsolete vst files…!!!

Cubase 10 on my env is broken:

  1. It freezes for over 5 minutes when opened.
  2. Once opened after those long minutes, all 3rd party plugins are just not there. Not in the plugin list, not in blacklist, no error messages, nothing - they’re just not there!!

It’s pretty felt like a Cubase fault,
Hopefully going to be located and fixed soon by Steinberg guys,
Since currently my C10 is useless. Broken. Not usable.

OK, I see you are on a Mac, too, my info isn’t going to help you much. But, try one thing? In your plugins list in C10 I see you have one FabFilter plugin available, correct? Can you find and open this folder? Is it all by itself?

In your 9.5 version, can you open this folder as well? Is it the same folder?

If all the plugins are there in that folder, and 9.5 elects to use them but C10 DOES NOT, well, then C10 has made a decision - apparently - that these plugins are not usable in C10. Is it possible that C9.5 won’t release them?

Have you tried reinstalling these FabFilter plugins? Maybe do this and see if it helps C10 find them. The Mac may be have stored a preferred user (C9.5) of these plugins, perhaps. Sorry, I don’t know Macs that well. All the best, Booli.

For “C9.5 won’t release them” - Well, it happens also when C9.5 is CLOSED, after MACHINE RESTART, when C10 is the 1st app to be opened.

For “C10 made a decision” -
Did C10 make a decision that NONE of my 100+ MOST POPULAR VENDORS’ VST3 plugins, NONE are usable? None?!? Not even lonely proper one?
Indeed it’s totally not probable, hence it’s not the case!

It indicates that Cubase 10 has a serious issue regarding VST3 plugins loading in some environments.
An issue which I believe relates to another issue - Highly long startup - Over 5 minutes starting progress, while the startup modal is freezed. For each and every start.

Hopefully @Steinberg guys will locate and fix this issue sooner, since currently Cubase 10 is non-usable.

Bummer, 10.0.10 update didn’t resolve this issue… :frowning:

I have a very similar issue. On startup, Cubase Pro 10 asks me to select waves plugins folder, and when i do, nothing happens. The same window just stays there, not accepting any selection I make. If I click cancel, the Cubase starts up and tells me that my Waves Shell file has been put on black list.
In the plugin manager it has it blacklisted, and it has VST2 as the version, eventhough it’s a VST3 file… None of the Waves plug ins are loaded in Cubase.
This is utterly frustrating. This needs to be fixed.
People have projects to do, and they can’t use their tools within Cubase 10… :angry:

I have a similar issue. Some plugins appear in both C9.5 and C10, but they crash on loading in C10 (or produce errors about video card) but work perfectly in C9.5.

I am currently exporting some audio from C10, importing into C9.5, processing, and then reimporting into C10, very frustrating.

I will look at the file paths, but they list in C10 in the plugin manager correctly so not sure what’s causing this?

My friend had the same problem.

The culprit was a seemingly inoffensive (Windows) shortcut that he placed in the VST3 folder (“C:\Program Files\Common Files”). He put it there (and one in his VST64 folder) so that he could quickly switch back and forth between the two folders to make sure that he didn’t have dupes of a given plugin.

Unfortunately for him, Steinberg apparently increased the search scope of the VST3 folder to follow shortcuts outside the VST3 folder. It appears that this change was made in the final update to version 9.5, and was carried over to version 10. I say this because the final update to 9.5 has the same problem, but not the version before it.

Anyway, just make sure that you don’t have any shortcuts in your VST3 folder, especially if they point to a VST2 folder. Cubase will try to read any VST2 plugins it finds in these extra-VST3 folders as VST3 plugins and fail to register all (non-Steinberg) VST3 plugins in the process.

Deleting the shortcut in my friend’s folder not only solved his VST3 problem, but it also greatly decreased load-up time (because Cubase no longer spent time searching the extra-VST3 folders).

Cheers…