VST Connect not connecting

I’m getting into VST connect but it just doesn’t connect.
I have 1 computer running cubase 10 pro with VST connect running and logged in.
I have 2nd computer running VST connect performer with another account logged in. And this computer is connected to net through another connection.

With VST Connect performer computer I can find the 1st computer “user” and add it to my friends.

So both users are now friends and I can see the performer in my cubase VST connect friends list.
I right click “Connect to friend” and it starts trying to connect. It runs the 0-100% bar but nothing else happens. No connection, no help, no nothing.

I’ve tried the connection with cubase and performer but nothing works. NOT COOL!!! :smiling_imp:

Hi and welcome,

I would recommend to post this to the VST Connect thread.

moved. :wink:

You need to make sure that you use the same version on both sides. We currently recommend to download and use the 4.0.30, 4.0.40 is rolling out very soon.


As far as I know, you cannot download VST Connect SE only. You have to deal with the one, which is part of your Cubase installation. Or am I wrong?

And as far as I know, VST Connect is part of Cubase, not Cubase 4.0.30, right?

check http://remocord.com/vstconnect. The PRO installer also updates the SE version.

Looks like I downloaded and installed the “Performer 4.0.30” so it should be right. BTW you can not find the version number anywhere. I had to look my download folder to find the version.

Now I can still see when both computers are online but I get a message “somebody tries to connect to you but uses an incompatible version”

I’m using VST connect SE in cubase and my performer is the version I already told. This is insane!!!

That’s not right. you need, which is available at http://remocord.com/vstconnect

Not here anyway … C10.5.12 SE still has the same version after installing Performer

[EDIT] My mistake, it does update VST Connect SE as well. The installer you need is called “VST_Connect_Pro_4.0.40.180_Installer_win.exe”.

You can, click the words VST Connect Performer in the lower right-hand corner.


This should be officially released soon.


Always by Steinberg plug-ins, when you click the plug-in name (graphics) the splash screen with the version (and other information) appear.

I’ve noticed that the error about versions not matching sometimes pops up even when they do match. In that case I would restart the application and try again, then it works.

Thanks people.
I’ve used cubase in my studio for over 20 years now. I’ve used vst, sx3, cubase 5 and 6. And last year I got cubase 10.
Everything has always worked really well and I never had to write to the forum for advise. This is the first time in over 20 years. I’ve always found the answer on forums or the manual. (BTW:The manual for this app is worthless!)
But now I’m using the connect for the first time and this is getting really annoing!!!
I’ve waves plugins and a million other plugins and over 15 electric guitars and marshalls and vox and ludwig drums and…

So I have everything I need to make a first grade recording.

Now I got everything connected and downloaded(“and not from steinberg site!!!”) and I actually recorded something using the internet. Cool.
So now the performer needs a guitar amp plugin so we can record the clean DI sound and use the amp plugin just for monitoring. But the problem here is that the application does not find the plugins.
It found 3 or 4 plugins but not the once I need right now. Even the Cubase plugins don’t show up with this program.

How is it possible to be soooooo hard to make this thing work???

I first thought I would buy the pro version but no way!!! This is really making me think other possible ways to record online.

all plugs here. which ones are not beeing found?

If you know cubase has about a hundred FX plugins just included and I have just written that I see only about 3 or 4 plugins here. And those are not even built in plugins.
It means that the performer app doesn’t show about 99% of the plugins. Even if I have the vst3 button pressed and even if I change the pluging root.
I have Cubase 5, 6, and 10 installed on my laptop. I’ve tried using every VST folder and of course reboot the program after changing the settings. Nothing helps.
I even downloaded some free vst guitar amps and changed the vst folder to my “downloads” but nothing.

I’m trying to understand the issue

The (remote) performer does not have access to the plugins on your (the studio) system.

If you are going to be using a guitar simulator that lives ONLY on your computer then you are going to have a problem…but there are solutions to this :slight_smile:

also VST3 plugins live in a very specific location on your PC/mac so these can’t be moved in the same way as VST2

I understand it’s frustrating but everyone here is trying to get you up and running - vstconnect isn’t perfect (yet!) but if you give us a little more info we’ll do what we can …

You do understand that only instruments are listed, right? Or maybe you expect your Cubase plugins to show up in the Performer (!) plugins list?
Are you certain that you even know what you want so vividly using vast amounts of offending question and exclamation marks? Pls check to see if you understand what this tech is made for in the first place. We like to help but pls be nice.


I wasn’t able to get VST Connect to work with the documentation provided by Steinberg.
Both, to use the PRO Installer to update Cubase (how mad is that), and the link with the clear instructions and screenshots was really what I needed to get it to work.