VST Connect pro with Cubase 10

Sorry for the silly question but I don’t understand.
I’ve read that VST connect pro is not included in Cubase Pro. But I have Cubase pro 10 and I can open VST connect Pro. I also have VST connect SE in the VST cloud menu as well. So, is it just a demo version? Is it in fact included free in cubase Pro 10? Do I still have to purchase it separately in order to use it? (I opened the VST connect editor window but I didn’t test it in real conditions with a friend…)
Thank you!

Hi Eric,

could it be that you activated “All Products / Features”? There is an option to activate all products/features of Cubase 10 for 24 hours. Question : Can you still open “VST Connect PRO”?


  1. I am quite confused. I was under the impression that Connect Pro is in fact included with Cubase 9 onward. is this the case or is a separate license required? 2. As a reluctant Pro Tools user, I must now consider using Cubase so I can collaborate remotely. The first attempt to set up a VST session with the Cubase 9 trial failed completely. I and the Artist would like to try again. Has anyone posted a literal step-by-step video primer on how to set up a remote session correctly? Thanks

Hello. I couldn’t find any good tutorial. Yesterday, I tried recording with a friend and it worked fine but I’m not sure of how to set things up so I can tweak his headphone mix. I think it’s with VST connect cur send but sometimes he had no sound and sometimes he had sound and I didn’t really understand why. We just had a few minutes to try but we will take more time soon to experiment.

And by the way, I never bought VST connect pro and I have it in Cubase 10.

You may want to take a look at https://connectvst.com/ for in-depth details. However an empty project and “Create VST Connect” should do the trick already. Just assign your mic when asked to and it should all work. Performer output (Master) and input channels (Mic/Instrument) must be assigned to his hardware ports; possibly, in Cubase you will have to move the VST Connect Monitor plugin from Master to Headphones in the Control Room (Studio/VST Connections) if you use headphones.

The mixer that you see in the VST Connect plugin is the same that the Performer sees, you are remote-controlling it. These faders are only for the Performer monitor mix. You send whatever you want him to hear via the cue sends (VST Connect) in the Cubase Mixer. “Create VST Connect” sets it all up for you.

Thank you for your responses. I will be DL the trial version of 10 this week and trying again. Cheers

Hello everyone,
Well, I have done my best to set up a proper VST Connect session but have failed. I do get audio flowing back and forth but nothing is in sync and/or the mic signal from the performer is not centered for him and out of sync with a secondary mic source coming from somewhere I can not figure out. The manual is a non starter as it continuously refers to other sections. What I need is a literal step-by-step primer from booting up Cubase, including the internal audio routing (I have an Apollo interface and can hear the imported stereo track only through the direct outs and not the VST connect app). I am a Pro Tools user and for the moment need to learn only enough about Cubase to make this work. Thank you.

Perhaps one of you would be willing to connect on a remote session and help me through this. Thanks again.

signal source of what’s coming from Performer is set in the Performer Mixer channels at the top, faders control what performer hears and record items control what you hear and record. Sync should just work but don’t use track monitor, it is delayed. You hear the performer at the main output (control room), if you use headphones you may have to move the VST Connect Monitor plugin to the headphone section.
Take a look at https://connectvst.com/ for more in-depth explanations. If that still doesn’t get you going feel free to ask specific questions. Step-by-step instructions are simple enough: create an empty Cubase project, apply “Create VST Connect” and you should be ready to go. Of course you may need to set up Performer audio connections as said before (tiny items at top of the channels).

Ok. I’ll use the guide as you (and perhaps anther user) have suggested and hope that everything works. Back to you with an update. Cheers

I have done my absolute best to follow the step by step guide but have failed to successfully set up a working remote session. Previously, the performer could hear the track but not his voice. Today, the exact opposite even though the metering could be clearly seen on the VST mixer. However, I am very bothered by the inconsistent terminology in the directions (i.e. things that don’t match version 10) as well as the assumptions about having read the manual. I am a very tech savvy individual and have engineered some rather successful recordings but, as a Pro Tools user, I find Cubase almost completely unintuitive. To make matters more difficult, I am dealing with an artist thousands of miles away who is not tech savvy at all. Again, I ask if anyone who understands all this would be willing to act as a test artist. We could be on Skype while helping walk me through the set up problems. Thank you

That’s the whole idea, Performer shoud not have to be tech-savvy, and that’s why you are remote-controlling almost all of his assets just like in a real studio.
The mixer displayed in the VST Connect plugin (not the Cubase mixer!) shows what Performer hears. The “Studio” channel reflects the cuemix that you send. If Performer cannot hear his voice, check the “Mic” channel: do meters move when he speaks? If not, make sure the right hardware port is selected on the performer mixer “Mic” channel and that its fader is up.
I will check the manual, it may be outdated and we’re sorry for that. But as a savvy PT user you should get all problems solved reading connectvst.com, it provides precise routing information and covers almost every pitfall. We’re still happy to help with specific questions :slight_smile:

Hey there:
“check the “Mic” channel: do meters move when he speaks? If not, make sure the right hardware port is selected on the performer mixer “Mic” channel and that its fader is up.”
Yes, I see the metering as you describe and his Presonus interface is selected within the Performer app on his computer.I see it in the setup on my end as well.

I have also done my best to emulate the Cubase setup shown in the primer for the mixer and Studio control modules and I believe they are the same. However, my TB mic (selected as input one of my Apollo in the routing preferences) can not be selected under the VST Cloud menu (always grayed out). Nonetheless, I see meter activity in the VST mixer when I implement TB. I guess that’s ok.

But one thing is for sure, setting up a new VST Cloud session does NOT automatically configure the session for a successful collaboration. Is there a sequence you recommend I follow to take advantage of this?

After hours of frustration with both Cubase 9 and 10 demos I am still hoping to be able to succeed at setting up a working connection. If and when I do, we will be happy to purchase Cubase.

In the meantime, if there is anyone who would be willing to help me set up a test session, I would be grateful. Thanks again.

Can’t set up a test session at this time, but we have some more details, so let’s see.
I assume that you may not been into Control Room yet. Having experience in studio-recording already, it should come easy.
The Talk Back mic is a function of the Control Room, open up CR editor and assign TB mic there if you haven’t already. VST Connect integrates tightly with the Control Room, so when problems arise, this is your second stop. First is “Create VST Connect”, but this may not solve all issues if you have configured too much yourself, so it counts for an “Empty” project. So, more datails:
“Yes, I see the metering as you describe and his Presonus interface” well then he should hear it. The “Master” channel should also move, as it should receive the input. Master is what should be on Performers’ headphone so if any of these "should"s don’t apply, there’s some serious flaw that we haven’t come across yet, like no master bus or having the direct/daw control on the Interface set all to direct, but then he should hear himself for sure.
So: Cubase Mixer Cue + Talkback → Control Room → VST Connect → Internet → Performer → “Studio” Channel. “Studio” + “Mic” + instr + VSTi → Perfomer “Master” channel. The Master channel also has a bus assignment at its top, I assume you have set that to Presonus Headphone output. Make sure Performer hasn’t messed with Presonus HW mixer.
“Mic” + “instr” + “VSTi” → Internet → Cubase VST Connect → a) track input and → b) VST Connect Monitor plugin in following Control Room Master (or Headphones).
I repeat that when Performer Mic channel meters move (in the VST Connect Performer Monitor mixer), “Master” must move along with it (plus what is beeing received from “Studio”) and thus be heard by Performer if Master output is assigned to his Headphone port.
“I have also done my best to emulate the Cubase setup shown in the primer for the mixer and Studio control modules” - what “primer” are you referring to? Will check that and the manual, as it appears to be outdated. Just use “Create VST Connect” (with an “Empty” project!) and then let us know what doesn’t work. And look at the LEDs, they should normally all be green (occasional exceptions are ok). Hope that helps.

I do appreciate all your efforts. I will also stop by the booth at NAMM for a hands-on demonstration with one of your associates. And the primer I refer to is the link you provided, https://connectvst.com/. In the meantime, some progress. I set up an empty project and had the artist swap out his brand new Presonus interface for and older M-Audio he had about. I checked the routing and CR setup per the primer and, after selecting the correct input from the interface (input 1) and lowering the M-Audio buffer to 256, he was able to hear the music mix I imported and his voice in reasonable sync as did I. The TB worked as well. Not at all sure what the difficulty is with the Presonus as it functioned unpredictably. Maybe it doesn’t like the latest Mac OS. Unfortunately, Cubase crashed and did not retain the saved session nor any .bak’s. But before this happened, I began to play with the VST mixer levels and EFX. I was not able to hear any reverb, etc. but I hope to get this working next. Well. at least it’s a step in the right direction. Cheers.

Performer reverb is fed by a tiny fader in each source channel (horizontal reverb send fader). Then if reverb is active and level is up it should work.
Sorry to hear that Cubase crashed, it is very stable normally. If you like, you can send the crashlog as a PM to me so we can check. Also Cubase does auto-save (to .bak), but you may have to enable it in preferences.
Thanks for your patience.

Well, made some good progress last night but still have some issues to resolve. First, when I set up a new session with the artist using his old M Audio interface which had worked the night before, he could see metering in the Performer app but could not hear anything as with the Presonus interface. I finally solved this by de-selecting the M-Audio in the app and immediately re-selecting it. Success!! We tried the same steps with the Presonus and it also worked! Perhaps this is a software bug that can be looked in to. Could also be an OS thing. I also noted that before connecting to the artist, the tiny EFX faders you mentioned are labeled EFX. After connecting, the label disappears. Thanks for showing me where to look.
Now that I can make the system function I can begin to focus on optimizing the setup. Even at the lowest resolution for audio and video, we are still experiencing audio glitches (even without video). I am sure this is due to problems with out internet connections. I am currently unable to hard-wire into the modem due to the location of the music room in my home. My Wi-fi speed is generally 25 MBPS DL and 11 MBPS UL. The connect side meter in the VSTC window shows full. The artist’s setup is currently Wi-fi and shows around 29 MBPS DL but only 5 MBPS UL. The performer meter in the VSTC only shows about 30% green. Is this telling me there is more of an issue on the artist side than mine (he will purchase an ethernet cable shortly)? Thanks

As long as those meters show more than 5% at any time, all should be well and there is no reason for audio glitches, but watch out for the LEDs. Does any of those go red when glitches occur? In any case, as you appear to have a very long distance connection and even the speed of light becomes a limiting factor then, you are advised to raise the “Remote Latency” setting to 2 seconds or so. The only disadvantage is that it takes a bit longer for the music to start when you hit play. Also if possible you should connect via Ethernet, not WiFi. Bandwidth is not of concern nowadays, only connection quality.
“de-selecting the M-Audio in the app and immediately re-selecting it” - you should not have to do this. If the problem persists, we would be interested in an exact sequence of operations, what is selected when Performer is started and what else did you do before and after connecting etc.