VST Enabled track plays other VST tracks as well

I tried posting this earlier, so i’ll try again. When I have one record enabled vst track, my midi keyboard is playing that track and all other vst tracks as well, rather than just playing the one thats enabled. Any help?

Could be caused by several things? Maybe add a few screenshots of your Project and mixer windows.

Hi,

Do you mean an Instrument track?

Make sure the other tracks don’t have the Monitor enabled, please.

Yes i mean instrument track. And yes the other track is monitor enabled because i want to hear the other instrument while recording a new one.

Idk how to embedd an image but here is the link to the screen shot
https://imgur.com/KmP5m5L

Here is the link to the screen shot, dont know how to embed here though.
https://imgur.com/KmP5m5L
You see one track is record enable so you would assume that you can only here that instrument while playing the keyboard, but im also hearing the track above whenever i heat a note on the keyboard as well which i dont want. I just want to hear the other track while recording on the new one

Turn off monitor on your other track as already suggested.

Monitor on = You hear what you are recording.
Monitor off = You hear what has already been recorded.

I cant hear nothing when monitor is off

Can you please post a screenshot and paint an arrow pointing to the monitor button you are using?

Basically turn off monitor on already recorded tracks to hear the normal playback and enable monitor and record on the new track you are about to record.

So when i have the track where the aarow is pointed to. I can hear it during recording on the enabled track. BUT the issue is that instead of hearing the enabled track on my keyboard, im hearing both the enabled track and the track with input monitor when ever i hit the keys. Instead of just hear tubular bells on my midi keyboard, Im hearing both tubular bells and the piano. Now if disable monitor on the piano track, I cant hear that all while recording on tubular bells

It’s hard to see because your screenshot resolution is too low.
You have monitor enabled on the wrong track. Enable monitor on the track that are also record enabled and disable it on the track where the arrow is.
Again, the monitor button is to monitor a live input. Disable it to hear the normal playback of a track.

If i disable it on the track that Im not recording on, Im not able to hear that track at all. And i want to hear that track while im recording on the enabled track. What you’re explaining does not solve the problem of hearing both instrument tracks playing sounds while playing the keyboard, while only one instrument track is record enabled

Okay just realized that these are midi tracks and not audio tracks. With audio tracks it works like I described above.
Could you try go to Edit --> Preferences --> Midi and tell me if “Midi Thru Active” Is enabled or disabled?

Midi Thru is Active is Enabled

I also see that these are instrument tracks, not sure how they are working exactly as im always using midi tracks with rack instruments and with those the monitor button doesn’t need to be enabled to hear playback.
However, and there may be a better way that i don’t know about, you could just select the already recorded track and in the track inspector to the left just change the input to not connected.
I think this is the only way when using Track instruments instead of rack instruments with midi tracks.

Yea that seems to be the only way. Kinda an inconvenient workflow, but i guess i’ll have to make it work somehow

This inconvenient workflow shouldn’t be necessary.
Something is very wrong if you can’t hear a track playing back when monitor is disabled. Really hard to tell without a decent sized screen grab of your settings though.

You are right actually, just tested and instrument track plays back just fine with monitor disabled.

And also for OP, could please upload screenshots with 1920x1080 resolution or higher so we can actually see what’s going on.

Idk how to get the screen shot bigger in this forum but here is another link to the screen shot https://chamberphotography.smugmug.com/Bnbnbn/n-V5PvZJ/i-L2pLths/A

Hi,

In this project, the GM 003 track doesn’t need to have Monitor switched On to be able to play it back.

Well I cant hear anything when its switched off