VST Instruments lose sound or MIDI when arming track or closing instrument editor

Hi all. I’m having the following problem with my newly installed version of Cubase 13 Pro on Mac Sonoma on a Macbook Pro M3 Pro.

*Anything marked NO below I consider a problem.

TL;DR - Certain VST instruments stop producing sound or responding to MIDI, either on the plugin’s built in on-screen keyboard or with MIDI controller. The cause of the issue seems to be when opening the instrument editor (plugin window - not the Key Editor!) but the record-arm button seems to cause it to lose MIDI functionality and sound too.

ADD INSTRUMENT TRACK, example ‘Retrologue/Padshop/Halion Sonic’

-Sound from plugin’s keyboard - YES


-MIDI/sound triggered by MIDI keyboard - YES


-Sound from plugin’s keyboard - NO


-MIDI/sound triggered by MIDI keyboard - NO


ADD INSTRUMENT TRACK, example ‘Retrologue/Padshop/Halion Sonic’


-MIDI/sound triggered by MIDI keyboard - YES


-MIDI/sound triggered by MIDI keyboard - NO


-Sound from plugin’s keyboard - NO

I have MIDI Input set to ALL and MIDI channel set to ANY.

This problem happens consistently with Steinberg instrument plugins but also with various others including Albino 3 Legend and Korg Legacy Collection instruments. This doesn’t happen with Arturia, Serum and others. All plugins are the latest versions.

Any thoughts? Thanks!

Hi and welcome to the forum,

Is the Record enabled by default, or not? If you are using default Cubase setup, then any selected track becomes Record enabled. In this case, this is expected result.

Expected result.

Expected result, if the Monitor is also disabled.

You should hear the signal here.

When did you open the Key Editor? Do you have the Record in Editor option enabled?

Please, provie more details. A video screens recording might help, to see more details.

Hi Martin, and thanks for your comments.

It’s those unexpected results I’m having a problem with.

Those results are when I enable and disable the track’s record-arm or when I open the instrument editor (plugin window, not the Key Editor).

Record-arm should of course enable MIDI control of the instrument plugin. It does do that initially but it loses connection somehow if I disable and re-enable record.

Not all plugins suffer the problem, just Steinberg ones and a couple of others as mentioned in my post above.

I’m trying to work out if there’s a bug or if I’m the bug…

I’ll do a screen-recording soon.



Could you try to increase the Audio Device’s Buffer Size, please?

Thinking out loud here… Do you have the setting “Release Driver when Application is in Background” enabled? (It is found in Studio Setup.)

I increased it, it makes no difference.

Tried it, it makes no difference.


I believe, we need more details about the settings in the Preferenes > Editing > Project & MixConsole. And the video screen recording could show some more details.

I’m away from my computer for a while but as a follow up to your message, surely record-enabling a Steinberg vst instrument should allow it to make a sound regardless of Cubase’s preference settings?

My audio connections are set up and active, my MIDI interface is active and recognised. Other vst instruments work fine apart from one or two other third-party plugins.

Interestingly Spitfire LABS opens up with its master volume at zero…

What reason could there be for a plugin to lose its ability to play just by opening the plugin window?

Here’s a screen recording showing the problem when using certain plugins’ built-in keyboard. Same problem happens using a MIDI keyboard controller too.

As you can see, Retrologue and Padshop produce no sound. Sometimes these plugins open up with a stuck key, sometimes not.

Spitfire LABS and Serum both produce sound although LABS always opens up with the plugin volume on zero.

Here are my settings in Preferences > Editing > Project & MixConsole


Doesn’t any of your device send MIDI CC7 or CC11 by any chance? Could you double-check with the MIDI Monitor, please?

Hi Martin,

It’s an Arturia Keystep, it doesn’t have a volume control function, just pitch bend and modulation.


Could you put the MIDI Monitor on the Input in the Studio > Studio Setup > MIDI Ports Setup and double-check? Just to be 100% sure?

I’m unclear what you mean. I can put a MIDI monitor on the instrument channel as a MIDI insert but don’t understand what you mean about putting it in ‘on the Input in the Studio > Studio Setup > MIDI Ports Setup’

I’ve just drawn in some notes in the key editor and drawn in a CC7 in the MIDI editor. I have sound.

This proves to me that when opening up Retrologue, CC7 has been set to zero, as it has also done in the LABS plugin.

I just need to find out why this is happening.

Click the icon in the Monitor column.

1 Like

Thank you.

This is what it shows.


Have you tried all MIDI Inputs, please?

Do you mean this?

Screenshot 2024-05-12 at 12.06.33


No, I mean to test all MIDI Inputs in the MIDI Ports Setup by using the MIDI Monitor.