Vst preset in inspector work correctly with some plugins but not with others?

Hello ,

I have an issue , maybe someone know the solution ?

let’s say i have an Arturia Vsti instrument (vst3), if i want to load a preset from the inspector, i can’t, i get a list of programname01 etc … and nothing.

This issue is only happening with All Arturia plugins and on KV331 products on my side.

No preset in inspector

To load a preset i need to open the vst instrument (or mediabay) and click on the load preset and it open the list with my preset.

but if i do this with retrologue or other plugins i own (except Arturia and KV331), the name of the preset is written in the inspector, and if i click on the name it open the preset list (small version of the mediabay) and i can load it from here and the name stay there in the inspector.

what’s wrong i’m doing ? i had this issue since several years. i thought it was an issue with a VST2 or VST3 instrument but here, both instruments are VST3, so it’s not that. any idea ?

I have the same issue with Arturia Piano V2 and others ones from their V-Collection range : Arturia is using a proprietary format for the presets, this, I think to avoid the .vstpreset mess that actually has only worked with Steinberg plug-ins/contents, on my end.

As an example, AAS does the same thing for their Lounge Lizard VSTi (VST 3.6.7), probably for a reason…

:frowning: s… is there any answer from steinberg on this subject ? yes, the issue happen with some other plugins too, but not all of them and, here AAS work ok !

  • Doesn’t Work :
    Arturia = doesn’t work
    KV331 Synthmaster 2.9 and one = not working

  • Work :
    AAS player = work ok for me (??? weird…)
    Spitfire Audio BBC Orchestra Core = work ok
    Garritan CFX (lite and pro = work ok (vst2)
    Gospel musicians stuff = ok
    Ik Multimedia = work ok
    Korg Wavestation legacy collection = ok (was not working in the past maybe when it was vst2)
    Dexed = work ok
    Toontrack (SuperiorDrummer3) = ok
    U-he Diva = ok
    Uvi Workstation = Ok

So if AAS is not working for you, but work for me, maybe the issue is related to something that can be fixed on our side ?

When you say “Work”, do you have a functional Programs list in the inspector for AAS Lounge Lizard ? I don’t.

Sure, I could browse every bank/program combination for it and save each and every one to a .vstpreset (if I have summed this accurately, they are 243 “factory” presets installed…) as, contrarily to VST 2.x plug-ins, the Convert program List to VST presets command is not available in a VST3 plug-ins window. Beside this, I have two problems, doing so :

  • It brings nothing useful to do such a tedious work, beside populating a Program setting that I have learned, through the years, to not use.
  • In MediaBay, double clicking to select a .vstpreset, saved as a test, actually creates another track with the .vstpreset appearing in… the inspector Trackpreset area. Where is the consistency ? :thinking:

I would be glad to help fixing the whole thing, so, if you have any suggestion… On my end, and since a big while I gave up hoping any improvement of it. Happily, Cubase has other strengths…

Since Cubase 4 (the first time that the VST3/Vstpreset/trackpreset nightmare appeared - more than 15 years ago, already), I have learned to avoid as much as possible, this whole half-baked system which got not a single improvement since. I use it strictly for the Steinberg bundled plug-ins/VSTis and avoid it as the plague for every other third-party stuff…

maybe we don’t talk about the same thing, or the same way to work. i use a lot this feature, for track presets too, with subcategory etc because i tags a lot of them for my own use, with artist, name of track, album, style etc. i did this some years ago, hundred and hundred of ones (but not all of them).
for some i found the vstpreset list on internet, some did them (like for the Korg Wavestation one).

but since 2 days ago, someone here told me how to save the vstpreset in a way that it’s done in batch with a small utility (tinytask) by using a macro with mouse move. it can take a long time, but it can be very fast too. i did the ones already for CS80, B3, DX7, for arturia, just finished the one for the BBC orchestra.

we’re talking about it there :

so if we can maybe find why it’s not working, that would cool. by the way I did a mistake, it’s the AAS player that i have which make appears the sound list, but i’m sure it’s the same for the other AAS product.

but let be clear : these instruments are not shipped with the vstpreset list already done, except the steinberg one. we must do the list ourselve, by using a macro feature (fast) or by hand (slow).

Different folks, different strokes…

I can understand among others, the use of the tags in MediaBay, etc. Simply the whole vst/trackpreset is not reliable for me, using a given third-party plug-in, for these reasons :

  • As I stated previously, the .vstpreset doesn’t work as expected in Mediabay : with a given VST-i/FX plug-in, double-clicking on a .vstpreset should load the related settings for it, nothing more. Creating an added track should be an exclusive .trackpreset feature.
  • Using .vstpreset with a given plug-in with its propriatary presets management leads to a confusing duplicated mess in which updating a preset for it isn’t reflected in the corresponding .vstpreset involved.
  • The .trackpreset system, even more than 15 years after its release, is unable to cope with a set of several different kinds of tracks, such as one which would involve an instrument rack with its related VST and MIDI tracks.

After this, and again, I’m open to any suggestion. Simply, and from a daily basis Cubase usage on my end, the .vst/trackpreset system is still not reliable and has never been so. Can’t say a lot more than this…

That’s fine, but it’s not the case with Lounge Lizard, and I have a rather recent version of it (4.3.0)…

yes, but it’s not my issue lol. you’re not happy with it , i understand it, but I am ! i created the topic, it’s about finding a solution to this issue, not about the fact you have this fonction even when it’s working.

Look at the subject ;). it’s about vstpreset in the inspector program list, not about “i hate it”.

there is a trial i think of loung lizard, i’m sure it’s working, i’ll test it.

No problem, though the title of your thread was suggesting something related to different plug-ins behavior concerning the .vstpreset management. Hope you’ll find the expected answer…

anyway, i confirm it s working with lounge lizard 4


It doesn’t, here…

what’s happen when you click on Lounglizard_locationTes ?

P.S : (didn’t see an Adat since 1995 ! wow ! :slight_smile: ) !

It’s a .vstpreset that I have saved for test purposes. If I click on it, I get the settings related to the Lounge Lizard internal preset that was active at this moment. By the way, see how it is shown in both the Program and trackpreset areas.

That could seems perfect, at first glance, but it’s not, as any edit and save in the internal Lounge Lizard presets management will NOT be reflected in the active .vstpreset : a confusing overlapped feature…

Beside this, and concerning the ADAT : it’s one of the inputs/outputs of my Behringer ADA-8200 unit, connected to my RME Fireface UCX via two TOSLink optical cables.

this is working AS espected. the vst preset list of Steinberg is different and not related to the one from the plugin. to have what you want working, modifing a preset in the plugin and the modifications added to the cubase vst preset, it’s an another story. it would need that both software use the same way to deal with preset, something that nobody did unfortunatly. it’s not the issue of steinberg for this i’m afraid.
so your plugin work normally as espected, like any steinberg plugin or any other plugin.

it’s not my issue. my issue is that for Arturia and for some other plugins (not all), the preset list is not appearing, i get a bunch of progamname01, programname02 , on a blanck menu and with a number of preset more related to the programchange of Midi than a list of sound.

P.S : got it, it’s not an Adat SVHS one, it’s using the Adat connection !

Not exactly…

A never ending one, it seems : it keeps going on since 2006…

… contrarily to Steinberg claims through the years : a supposedly universal way of dealing with presets. And it’s Steinberg which choosed to break its own FXB/FXP standard…

Yes, considering the half-baked implementation for which any edits and save are not reflected in the .vstpreset active at this moment …and no : the VST3 Steinberg plug-ins behaved differently. Any edits are reliably saved, as there is no “proprietary” presets management in them…

We’re going in circles, at this point. I already stated, in a previous post, what’s going on with Arturia VSTis.

Again, I hope that you’ll find the expected answer… :slightly_smiling_face: