W10 users: How do you get Windows key to be an actual mod key, when using Cubase?

Tons of my key commands use what in Windows would be the Win key, and in Windows that key always activates Windows Menu functions instead of Cubase key commands, which is of course impossible for Cubase use. I know this might be a newbie question, but I’m a new W10 user coming from Mac and can’t figure out the answer to this one online: How do I disable the Win key from activating the Windows Start Menu/Windows functions when using Cubase, but let it instead be used only as a mod key? Basically have it be the exact same as the extra mod key Macs have.

On Macs this key is freely usable as a mod key only and doesn’t only access any System stuff, which gives you a huge amount of extra custom key commands .

Are you saying

  1. You have the Window focused on Cubase
  2. You want to use the ALT key as either a tool modifier or in a Key Command
  3. But when you hold down the ALT key it activates the “Windows Menu” (by which I assume you mean the Windows Start Menu, or maybe something else???)

Yeah that is not normal Windows behavior. The Start Menu is normally opened using the Windows key which is next to the left ALT key. Does it do this for both the left & right ALT keys? If it’s only the left then maybe the keyboard is broke and it is also triggering the key next to it. Try it with a different keyboard.

Whoops…I mistakenly wrote ALT instead of the Windows key. I’m a bit topsy-turvy with this stuff since switching to W10, due to the fact that I’m using my favorite Mac keyboard and had to re-map the Win key.

See the revised post above.

On keyboards with or without the Windows key, the start menu in Windows is invoked with the CTRL-ESC key combination. If you are reprogramming your Mac keyboard, that’s where you should place the Start Menu key. As far as I know, there are no Cubase commands associated with that combination.

I use classic shell and you can then alter what happens if you use the windows key with that program. I just tried on my internet machine and indeed the the windows key does nothing, if it is available then for cubase I don’t know.

Oh classic shell is also open source now as Open shell

For me, simply pushing the Win key on its own activates the Start menu. I’m a little unclear on precisely how I would reprogram the Mac keyboard in the way you suggest. I use SharpKeys to remap.

I’m hesitant to use a shell type of program on my music PC, but will look into it.

For those who want to do this, I just found an answer that works. It’s #3 on this link and uses AutoHotKey and also Gpedit (native Windows) to achieve two different things (or both) regarding this, depending on your wishes: https://superuser.com/questions/151304/prevent-windows-key-from-opening-start-menu-in-windows-7

BUT, now I’m seeing that Cubase doesn’t recognize the Windows key as another mod key, which defeats the whole purpose of doing this. Is there a way to change that? It means around half as many available key commands as on Mac if I can’t enable it to be a mod key for Cubase. I’ll start a new thread.

I modified W10 so that the Windows key doesn’t activate Windows. But now I’m seeing that Cubase doesn’t recognize the Windows key as another mod key. Is there a way to change that? It means a huge amount less possible key commands as on Mac if I can’t enable it to be a mod key for Cubase. Some programs enable the Windows key to be used as a mod key, from what I’ve been reading…Cubase needs this to make it as flexible and expandable key-command-wise as Mac.

Is there a preference I’m missing? If not, is there a hack somewhere for this?

ALTernatively (see what I did there), a basic Logitech PC keyboard can be had for about $20 & it works with Cubase right out of the box.

FYI I believe it is Microsoft and not Steinberg that limits the use of the Window key.

Ha!

Well, the Apple keyboard works perfectly – it’s only the Windows/Option key that’s the issue, for any keyboard. I’ve read that other programs let you use the Windows/Option key, but I can’t remember which off the top of my head.

That key kinda belongs to Microsoft.

Are you sure you really want to jump through a bunch of hoops to basically break a small hunk of the OS?

I’m not a Mac guy but its my impression that the Mac has 2 mod keys that are used in Cubase Cmd & Option. And the PC has 2 mod keys Ctrl which corresponds with Cmd and Alt which corresponds with Option.

I don’t get why you are trying to use the Windows key at all? I’ve been using Windows since it was DOS with out windows and have never run into the Windows key used as a modifier. It’s intended to be a dedicated key used by the OS.

Mac has control, option, and command. In Cubase you can use all three as mod keys.

Windows replaces option with the Windows button, which doesn’t work in Cubase.

As I understand it, It should use the Alt key for Option and not the Windows key.

Hopefully someone who switches between both OS will chime in. Maybe you should tweak this thread’s subject line to entice some more Mac folks into the discussion.

Under any circumstances trying to re-purpose the Windows key in general seems like a bad approach.

I’m all confused now because I’m using a Mac keyboard with Windows and I switched two keys – I can’t remember what matched with what anymore. But even if I had a regular Windows keyboard it’s exactly the same wish: It would be great if Cubase could utilize the Windows key as a mod key for a much larger amount of possible custom key commands – perhaps make it an option for people who prefer the Windows key as is when using Cubase, sacrificing all of the extra custom key command possibilities.

The only issue I’m talking about here is that the Windows key can’t be used as a mod key in Cubase – how it translates on an actual Mac keyboard doesn’t matter because I’m only talking about Windows.

Cubase won’t recognize the Win key, but you can use AutoHotkey to send any combination Cubase does recognize, using the Win key as the modifier.

Good to know, thank you.

Edit: this stopped working in Cubase 11, no idea why. I fixed it though, see my post below

Here’s my setup, it’s really quite simple

 #=Win,!=alt, ^=ctrl +=Shift



#a::Send,{F17}
#z::Send,{F18}
#w::Send,{F19}
#s::Send,^{F16}
#x::Send,^{F17}
#e::Send,^{F18}
#d::Send,^{F19}
#c::Send,+{F16}
#r::Send,+{F17}
#f::Send,+{F18}
#v::Send,+{F19}
#t::Send,!{F16}
#g::Send,!{F17}
#b::Send,!{F18}
#y::Send,!{F19}