WaveLab 11 GUI Lag with Certain Plugins

WaveLab Version: 11.0.20

I’ve recently moved to WaveLab from Sequoia and I’m absolutely loving it! I have, however, noticed some strangeness in the UI regarding performance that I can consistently reproduce as follows on both macOS and Windows.

  1. Open WaveLab to an empty project.
  2. Load any wave file into the audio editor.
  3. Instantiate SuperVision in one slot (I was using the playback processing slots but it doesn’t appear to matter) and open it.
  4. At this stage, all the GUI animations are smooth during playback (e.g. the metering, SuperVision and so on).
  5. Instantiate iZotope Insight 2. You need not have it open to reproduce this.
  6. During playback there will be noticeable frame rate issues with the inbuilt metering and SuperVision .

I should note that this is not the only set of plugins with which I experience this, but just the simplest set.

Please let me know what information I can provide in order to help diagnose this issue.

This is “simply” because the Izotope plugin is consuming too many resources (Supervision is also a resource consumer).

That is odd. It is definitely specific to WaveLab as I can load those plugins and more with all GUIs open in Nuendo and various other DAWs. What I’m seeing just doesn’t gel with the performance I see in other plug-in hosts; does WL do something special or differently in this regard?

Aside Supervision, WaveLab has many other real-time meters, that are also consuming graphic resources. I assume, you don’t use “scroll on play”, which is the most consuming graphic activity of all.

I’m not using scroll-on-play, no. Additionally, I can reproduce the behaviour with all meters hidden (the windows not open, not just not visible tabs) except for SuperVision.

I did initially consider that it might be some kind of hitting GPU acceleration limits, but even on my mac (with a much less powerful GPU), the maximum load is 40%, with average hovering around 30%. This would make even less sense on my Windows machine which is equipped with an RTX 3090 as a rendering card for video-intensive work, and sees exactly the same symptoms in exactly the same way.

Addendum: Upon closer observation of a profiling recording (using instruments) it looks like the GPU load actually decreases when enabling Insight 2.

I don’t have equivalent profiling tools on the windows machine as I don’t do any development work on it, but observation of GPU load in GeForce Experience shows similar results. While the load itself is much lower (a maximum of 17% with an average of 15%), the same behaviour is observed.

On both machines, the GPU load for the WL metering alone (everything else closed) is negligible (0-1%).

WaveLab is not using the GPU. Maybe the Izotope does also its graphics without the GPU. That would explain the bottleneck.

Then I’m even more confused! CPU load on both machines is negligible (5%) and doesn’t change noticeably when enabling or disabling Insight 2. No core even gets close to work saturation while the issue is occurring.

Your 5% is the average consumption for all cores. The more cores, the smaller this value. You would need to monitor the consumption for the main core only, something between 0 and 100%, if you find the right tool for this.

It does look like the WL thread using the maximum amount of CPU is indeed going over 100% of a core sometimes when both SuperVision and Insight 2 are running (with all WL native metering closed).

That said, I have some questions:

  • Why is this slow-down observable even when the plugin UIs are closed? If it is graphics related then I would expect that to result in less load but it appears to be the same regardless of whether I have one, both, or none open. Is it more likely to be the analyses run by the plugins?
  • Do you know why I would not be observing the same slow-down in other DAWs? I see this even when I have WL’s metering all closed, but cannot reproduce the same in other DAWs.

UI drawing is one thing. Preparation, of the data to plot, is another. And this one is more CPU-consuming.

That is the most likely explanation. WaveLab 11.0.20 has an option (ON by default) but this can’t do miracles. It’s only useful with complex Supervision setups.
image

Very difficult to know.

Thank you for the pointer to that option! I do actually use a fairly complex SuperVision layout. Enabling this (it was disabled for some reason) has actually helped!

1 Like