Wavelab 7 Elements File Creation Errors

(under Win 8 x64).

I seem to have a lot of problems creating files, both using ‘save as’ and when rendering. FWIW these have carried over from the time I was using Windows 7.

Basically I get an error messages as per the attached screenshot.

I can then normally get around this by drastically truncating the file name, but that is obviously a very clumsy solution .

Is there a proper solution for this, or alternatively can somebody please provide a set of guidelines for acceptable file names?
wavelabFileWriteError.png

I don’t see any illegal file name characters for Windows, and you mention truncating file names, so it looks like you exceed the full file path limit of 260 (IIRC) in Windows. Instead of truncating the file name, you better rethink your directory structure and use less deep paths.

Thanks for the quick reply Arjan.

Good point about the stupid 260 char full path limit in Windows. However, it wasn’t that, at least not directly.

First of all I tried to measure the path I had been using and it was well within the 260 char limit.

But then I tried to save the name directly under C:\ and I got a different error message (see below) that seems to indicate Wavelab is making some sort of weird filename translation.

Any other idea?
wavelabFileWriteErrorVersion1.png

Sorry, I think this is where PG chimes in… :sunglasses:

Your temporary file is set to C:
which is a path under reduced access rights. You should change the temp path to seomething else, like
C:\Temp
Do this from WaveLab > Options > Folders

I’m afraid that didn’t work, PG.

Is there anything else I can try?

Yet, your second picture really show a problem. This should not happen. Can you reproduce this “picture” after you have changed the temp folder?

Yes I can – see new screenshot taken just now after I changed the temp file location.

Note the file name alphanumeric code appears to be the same except for the final 5 digits after the ‘-’.

Hope this somehow helps.
wavelabFileWriteErrorVersion2.png

BTW, I haven’t rebooted (got other things going on).

Could that be a factor?

Rebooting, no. Quitting WaveLab yes.
If you still get the problem, show me your Folder dialog.

OK, I have restarted several times, and still get the error.

And just to be clear the error message in the previous screenshot is using the same filename/parameters as the prior example.

Done. See below.
wavelabFileWriteErrorFolderOptions.png

What is the full path and name of the file you are trying to save? And what way do you use to save it?

The file name is “Romanthony -‎ Ministry Of Love (Organ Grinder Dub)”

The directory is “C:”

The file in memory is a 24bit 96khz Wav file and I am using the File–>Save As command to save it in flac format for archival.

EDIT: FWIW, It seems I invariably have to cut back the file name to before the “-” separator to get the save to work.

As told before, C:\ is reserved by Windows, you should not put files there. You can’t avoid a mistake if you do this.

It doesn’t matter what directory I try to write it to; nothing seems to work, and I get the error message first posted (without the alphanumeric stuff).

. . .However, the problem may be specifically related to writing flac files.

Writing a wav file with the same parameters as above works, whereas writing a flac fails every time.

It might also be worth mentioning that I have the Flac package from souceforge installed (http://flac.sourceforge.net/index.html)

Not sure if Wavelab uses that or has its own conversion library built in, or even whether any of that could be having any kind of impact; just keep to sort this out!

You don’t need to have any flac package installed.
Please show me the message you get when writing a file that is not in C:
What is the full source file name and desired output file name?

I get the message I posted a screen shot of in the first post in this thread.

OK, I see you want more info.

Error message is as above.

Source is: C:\Media\xM Process\Process Folder\Source (Vinyl)\Wavelab 24-96\Romanthony -‎ Ministry Of Love (Organ Grinder Dub).wav

Target dir is: C:\Temp\

Target file name is: Romanthony -‎ Ministry Of Love (Organ Grinder Dub).flac

Output format is set to Flac, match input source/streams