WaveLab 8.5 crashes with Fabfilter Q 2

Hello,

when using Fabfilter Q 2 and starting playback, WaveLab 8.5 crashes.

I think you’ll need to provide more info like operating system and where you have ProQ2 inserted when it crashes (clip/track/montage master/global master).

I use FF ProQ2 regularly in Wavelab and I don’t experience any crashes from simple playback.

I do experience playback glitches when loading in a CPU heavy preset like linear phase - high quality while the transport plays but I doesn’t cause a crash. I just need to stop playback and restart and it goes away.

I do experience some crashes when rendering files and DDPs when a montage contains FF plugins along with UAD plugins but we can’t seem to pinpoint the problem.

I use Win7 x64, FF Q2 inserted as a clip plugin.

See my other thread but I am having similar problems. Just started recently. Better with 8.5.3 and I just updated my RME software. Best of luck!

Windows 7-64. Wavelab 8.5.30 (32).

I just got the same problem today while trying out Wavelab 8.5.30 for the first time. I opened an audio file in a montage and added FabFilter EQ as a clip plugin. I went to play the clip, and it crashed, with a cascade of “a serious error has occurred inside the plugin…” messages. I had to force-quit Wavelab. Then I tried the FabFilter Multiband as a clip plugin, and got the same crash.

But it turns out I had unintentionally loaded the FabFilter VST2 version plugins.

So I went back and loaded the FabFilter VST3 versions as clip plugins, and those didn’t crash. The VST3 seem to have no problem at all as clip plugins.

The FabFilter VST2 seem to work OK in the Master Section but not as clip plugins (at least not here). I didn’t try them as Track or Montage Master plugins, so I don’t know what happens when they’re used there.

Is this something that could be fixed for the FabFilter VST2 on clips, or something to report to FabFilter if it’s on their end?

Also, after finding this, there is one thing I would like to ask: Is there is a way to tell which version of the plugin (VST2 or VST3) you’re using once the plugin is loaded in the program? I couldn’t find any indication of path or filename for the plugins once loaded in Wavelab, and I couldn’t see any indication on the plugin itself.

Hey Bob,

It’s kind of subtle (to me anyway) but you’ll notice in plugin menus that if you see 3 slashes by the name like this:
/// (kind of like the Adidas logo), it means that it’s a VST3 plugin. I’m guessing you may already have known that and just meant how to tell after it’s loaded…

The way I can tell is that the preset menus for VST2 and VST3 are different. VST2 has “banks” where VST3 has what I call more of a normal preset menu. That being said…I can’t remember what plugin in is, but I am pretty sure I saw a case where a VST2 plugin had a VST3 style menu or maybe it was the opposite. I’ll have find it but generally speaking, the banks vs. no banks in the preset section is the biggest clue for me.

I’ll attach some screen shots. In my screen shot of the menu, notice that the Sonnox and UAD plugins don’t have the /// next to them because they do not offer VST3 plugins yet.
VST3.jpg
VST2.jpg
VST2-3.png

Thanks jperkinski. That answered my question, the preset menus. Although it’s a little odd that’s the only way to tell after loading, that works for me, so I’m glad you found that.

re: the FabFilter VST2 clip crashing, I was wondering if you, or anyone else, ever tried the FabFilter VST2 plugins on clips on Mac?

After getting the crash on Windows in WL 8.5.30, I’ve gone back and tried the FabFilter VST2 plugins on clips in Wavelab 8.0.4 and get the same crash on play, so I don’t know how far back this goes in Wavelab on Windows. Maybe few people tried the FabFilter VST2 plugins on clips, and went right to the VST3 plugins that work. Or only tried the VST2 plugins in the Master Section, where they seem to work ok.

I pretty much only use VST3 FabFilter in WL 8.5.30. I was using VST2 Pro-L for a bit to troubleshoot a different crashing problem earlier this year.

I’ve never had Wavelab crash simply from pressing play with Pro-Q2 inserted. My FabFilter crashes always happened during renders of DDP files or rendering WAVs of each CD track from a montage.

It was a very bizarre crash because it was only re-produceable if I had Pro-Q 2 VST3 on an audio clip, a UAD plugin in the first slot on the montage master, and then FabFilter Pro-L VST3 after that. Recalling VST3 presets and/or WL plugin chain settings seemed to induce the problem fairly easy.

If I moved the UAD to the track insert, the crash wouldn’t happen. I couldn’t pin the crash on FabFilter or UAD but something was certainly causing the crash about 70% of the time. It still happens to this day but I try to work around it and avoid it.

The only playback related issue I’ve seen with FabFilter is if I start a new montage, add some audio files, play the transport, drop Pro-Q 2 on a clip insert and recall a VST3 preset. Especially if the VST3 preset had a CPU heavy preset like Linear Phase - High, then the audio would be very jittery and distorted until I stopped the transport and restarted it. Usually after this happened one time it wouldn’t happen again in a given montage.

I often felt my rendering crashes were related to recalling presets and tweaking vs. just loading Pro-Q 2 and dialing something in from it’s default state. Something about the presets seem to trigger the rendering crash.

There are also some graphics bugs that FabFilter claims is a Wavelab bug but they have been implementing workarounds on their end for now. Pro-Q 2 and Pro-MB don’t have the graphics issue anymore, but Pro-L and Saturn still do as they haven’t been updated in awhile. The problem is that the GUI can become stretched out irregularly horizontally when it shares a plugin chain window with other shaped plugins. This makes it hard to actually adjust parameters because the buttons are not where they should be. Turning off graphics acceleration solves the problem but of course, then the graphics don’t look as smooth and the GUI is one of the highlights of Pro-L and many other FabFilter plugins. Folding and unfolding the plugin GUI, or moving to another plugin and back fixes the stretched GUI.

FabFilter says they reported the Wavelab bug they found to the Wavelab developer but haven’t heard back about it.

Maybe PG can offer some info on your particular crash when pressing play, but it would also be worth emailing FabFilter support. They’re pretty good about getting back although sometimes there are lapses of a few weeks between emails. They also have a forum which they check regularly too.

I think there is definitely room for better interaction/cooperation between FabFilter plugins and Wavelab. It seems like there are a handful of minor to moderate issues depending on the variables.

I can test VST2 Pro-Q 2 specifically on clips Sunday evening and report back, but VST3 on clips definitely hasn’t caused any instant playback crashes. Also agreed that better distinction between VST2 and VST3 would be ideal.

I tried the FabFilter VST2 plugins on Track and Montage Master, and get the same crashes as on Clip. But the Montage Master crash is not as severe, and only presents one “a serious error…” message, which can be closed without force-quiting Wavelab. (the Clip and Track crashes cause many duplicate “serious error…” messages).

and fwiw, all of these things are the same when tried in Wavelab 7. In Wavelab 7 with the VST2 plugins, Master Section ok. Clip and Track not ok.

Maybe it doesn’t matter anymore if the VST3 plugins work, but I’ll report it to FabFilter anyway.

Thanks, I appreciate it.

I tried these two things on Windows 7, and couldn’t reproduce them. Saving and loading presets, making adjustments etc… Sorry I couldn’t make any of it fail. I don’t have the UAD BAX, but I tried UAD Precision EQ and Limiter, 1176, LA2, Pultec. Using PCI-e UAD. But I’m not sure it means anything, because you might need someone on Mac with all this stuff to reproduce it. I don’t have a PCI-e Mac.

But if you think of some other method I could try on Windows, I’d be happy to try.

Well. VST2 of FabFilter Pro-Q 2 and Pro-MB both crash Wavelab hard right when I press play. Pro-L VST2 doesn’t crash but it also hasn’t been updated in awhile so maybe the cause of this crash was induced in a newer update of FabFilter plugins.

I will report to FabFilter as well. Even though I rarely use VST2, there has to be a a way for FabFilter and Wavelab to be more agreeable whether it’s from one party or both.

I was getting crashes from inserting Pro-Q 2 and Pro-MB VST2 in the clip effect, track effects, and montage master effects.

I didn’t seem to get a crash from inserting in the global master section.

It’s things like this that make me wonder if it’s more of a Wavelab bug, just like with my FabFilter/UAD crash. How can a plugin know if it’s in a clip, track, or montage master slot, or global master. It seems like at some point the DAW/Audio Editor needs to make sure it’s handling plugins properly too if it has unique features as Wavelab does.

I’ll attach a few of the crash reports incase PG sees this and cares to investigate.

I’m on OS X 10.10.4 and WL 8.5.30
Wavelab_FabFilter_VST2_Crashes.zip (122 KB)

Thanks for checking. I think the render crash was happening with any UAD plugin inserted, not BAX specifically. That just happens to be my usual first plugin on the montage master.

Were you testing on the montage master rather than the global master section? It’s a quirky bug and didn’t always happen. It might be specific to my configuration. Pro-Q 2 on a clip insert, UAD first on montage master followed by Pro-L. The montage master inserted are always loaded by using a plugin chain preset. The clip effects Pro-Q 2 is manually inserted from Favorites and then a preset is recalled from the VST3 menu.

The Pro-Q2 and Pro-L are VST3 and UAD is VST2 obviously.

I have a video somewhere of the playback bug where the sounds gets very weird if you load Pro-Q 2 (and probably other FF plugins) while the transport is playing, and then load a preset that has some more intense CPU like linear phase - medium and higher. I’ll try to find that video.

I hadn’t noticed about Pro-L. You’re right. Pro-L, Pro-C, and Pro-G don’t crash on Windows.
I think the most obvious difference between those plugs and Pro-Q 2 and Pro-MB (which do crash on Windows), is that Pro-Q 2 and Pro-MB have full-screen capability and the others don’t. I’m not using them full screen, but they have the capability, and those are the ones that crash. Also on Windows they have the larger default window than the others. And I’m still talking about VST2 only here.

In the latest reports I have received, I see clearly a crash inside the plugin code, related to memory handling.

Thanks. I’ve sent my crash reports to FabFilter and some comments about the memory problem. I really hope that it will clear up some problems between Wavelab and FabFilter, even on the VST3 versions which is where I saw the major crash problems when rendering WAVs and DDP files from the montage.

Yes I was using Montage Master, not the Master Section. I was following your notes exactly. And now tried again with MM chain load and Pro-q2 favorite load from your notes. Rendering to Regions/CD tracks. Still no problems.
But it occurred to me I’m probably using older UAD-2 software than you are. Mine is at least 3 years old. That could possibly be a factor. I’ll see if I can update with full rollback, but I can’t make any guarantees.

I’ll try again with linear phase high preset. I’m not sure I’d found those settings before (bottom left?). I think I was just using a complex factory preset. Only just recently got the FabFilters.

Thanks, but definitely don’t jeopardize your system just for this test. I am using a UAD PCIe Octo Card (in a thunderbolt chassis) with the latest UAD software, and the issue existed with my old PCIe Quad as well. I have a feeling that based on PG’s feedback on this crash that it’s also a memory related FabFilter bug. It’s been happening nearly a year now so it’s existed through all the minor UAD/FabFilter, and Wavelab updates.

I’ll try again with linear phase high preset. I’m not sure I’d found that setting before. I think I was just using a complex factory preset. Only just recently got the FabFilters.[/quote]

I thought this bug may have gone away but I just had it happen today doing an all “In the box” mastering project. It seems to be CPU related in some way. Before it would happen even with the first Pro Q-2 instance. Now it doesn’t seem to happen as easily.

But, with a fair amount of plugins running in a montage, transport playing, setting a Pro-Q 2 instance on an audio clip to Linear Phase - High or Very High now causes all the audio on that clip to mute even though the transport still plays. Once I stop the transport and restart, then the audio is fine. With Pro-MB, I changed to 4x oversampling while audio was playing and got that slight jittery/fuzzy sound until I stopped playback and restarted.

I’d say, if you can, put a few CPU intense plugins in a montage and then change some FabFilter settings to be more CPU intense and see if you get glitches or muted playback.

This bug doesn’t bother me all that much but it would be good to get it resolved and maybe be a clue for other instabilities between FabFilter and Wavelab.

It seems to be related to recalling higher CPU intense settings or presets while the transport in Wavelab plays, I don’t experience this with any other plugin brands.

I found an old video I made of the FabFilter glitchy playback test;
https://www.dropbox.com/s/vv0nhcvcd67xqip/JP_WL_Jitter_01.mov?dl=0

Also, here is an older video I found of the render crash:
https://www.dropbox.com/s/1dqrewp8hkc56vm/WL_UAD-FF_TEST_01.mov?dl=0

It seems to be very tricky or impossible for others to reproduce but it happens to me all the time.

When I get stuck on a montage and can’t successfully render it, my work around is to move the UAD BAX to both of the track inserts which in theory should sound the same, but increases render times and is generally not ideal.

When I do this, the crashes instantly disappear. So, it’s hard to know if the problem is from FabFilter, UAD, Wavelab, or somewhere in between.

I just tried this again paying more attention to the Linear Phase settings, and I get the same results you’re getting. Glitching and muting. I did this on Windows 7 with Wavelab 8.0.4. No presets, no extreme settings (besides max linear phase), just default flat settings on all the plugins I used.

This is how I always got glitching:

Using a 96KHz file:
Pro-Q 2 on Clip slot 1.
Pro-L (or anything else) on Clip slot 2.
Pro-L (or anything else) on Montage Master.
Start playback.
Remove Pro-Q 2 from Clip slot 1.
Add Pro-Q 2 back to clip slot 1.
Change settings (on lower left in Pro-Q 2) to Linear Phase - Maximum.
95% of the time that would start the audio glitching, which would continue until you stopped and restarted playback, after which it would be perfectly clean.

But it seems like it gets better if you get the plugins further from the Clip, the furthest being with all 3 plugins in the Master Section. When I finally did that, I got no glitching or muting at all.

If I moved the first two plugins to Track (instead of Clip), I got glitching if I changed the setting to Natural Phase, but muting if I changed to Linear Phase - Maximum.

If i moved all three plugins to Montage Master, I would either get muting or no problem.

So I think there’s definitely something going on, but it all hinged on the Pro-Q 2 “Zero Latency/Natural Phase/Linear Phase” settings for me. And the placement in the Clip/Track/Master/Master Section path.

edit: I had tried paring it down to just the Pro-Q 2, but in order to get it to glitch or mute it seemed to require more in the chain after it. Didn’t matter what. I also tried UAD instead of FabFilter after the Pro-Q, with the same results.

Thanks for checking on this Bob. I also noticed that the playback glitch/mute problem seems to happen most easily at the clip level. In my older video I was able to produce the problem with just one audio clip and no other plugins anywhere, but Pro-Q 2 has been updated since then. It seems to require more plugins/CPU usage in a montage now to trigger it, but as you see, it still happens.

I can’t help but wonder if many of these FabFilter/WaveLab issues aren’t all related to a few critical bugs/coding problems but so far FabFilter and PG/WaveLab insist that it’s the other parties bug(s) so I don’t see a resolution happening any time soon (or maybe ever). The list of minor issues keeps growing so much that it might become hard to use FabFilter and WaveLab together without battling some crashes/glitches or other anomalies.

The playback/mute glitch itself is not that huge of a deal, but I think it points to some underlaying problems that should be resolved by one or both parties.