WaveLab 9 Cannot find any CD drive to burn to

I recently reinstalled WaveLab 9 due to a computer crash and have just finished working on a major project. When I go to burn a CD with ‘Write audio CD or DDP’ the only device option is ‘DDP Image’. I have used gear driver installer and checker. I’m able to read and write audio CDs in other programs so this must be WaveLab specific. Any idea on what could be causing this? I really need to get this up and running ASAP.

As a side note:
I also have WaveLab installed on two other computers, one Mac and one PC, and have no problems burning CDs from those. Neither of them had a crash.

Wavelab 9.0.25, Windows 7 with SP1

Did you check this?

I did and everything was checked and it was OK. WL is the only program that cannot burn to the CD recorders. All the other DAWs work fine. Puzzling and I need to get out a big job. Any help would be appreciated.

There is a list of things to check mentioned in this thread: Import Audio CD doesn’t work

Thanks for the information. Everything has been checked and double checked except for the last ITUNES suggestion.I will post when I try that.

Just to clarify every other program EXCEPT WL works well with the drives so it has to be something in WL’s setup and not a registry problem.

Thanks again!

I have no clue, because until today, all cases I was reported about, could be solved using the gear driver update and check list.

What was your original computer crash about? What did you reinstall WaveLab for this?
You can still try to remove your WaveLab preferences for a while.

That does not follow; the programs could be looking at the registry information in different ways, for instance.


My computer crash was from my intern attempting to “defrag” my SSD instead of optimizing it and when he realized his mistake he stopped the process and it messed up the SSD. Many programs were OK some had to be reinstalled. WL is the only one that cannot write to the CD burners. Thanks for all the help so far!!! We have uninstalled and reinstalled WL about 4 times doing a complete uninstall and even tossing out all the WL folders. By the way WL 6 sill works perfectly and sill can write to the CD drives. FWIW

My computer crash was from my intern attempting to “defrag” my SSD instead of optimizing it and when he realized his mistake he stopped the process and it messed up the SSD

Hum, not a small mistake. I am afraid you will have to reinstall Windows. This is what I would do in your place.

It was suggested that we do an upgrade via the install disc which we did from Windows 7 to Windows 7. The computer now is running fine and all the programs on it are running fine. The only problem now is that WL 9.0.25 cannot see any of my CD drives. We copied all the files to our transfer computer, put the WL9 dongle on the computer and burned what we needed to burn. Now I need to figure out what is going on with WL in our mastering computer. Long tedious process.

My interns are the best but sometimes they act more like the Sorcerer’s Apprentices instead of an audio intern when they decide to do things “their way” instead of asking questions on how to do something the correct way.

Thanks for all the help so far.

It is simply not worth the battle. Reinstall Windows.

it may come to that but it would take me an entire week to load all the programs back on a fresh install of Windows. Right now we have 40 transfer projects in house I don’t have time to do what you are suggesting. Thanks very much for your suggestion and if the time crunch were different I would have already done that.

I have forgotten how to do that, Is there a sticky on how to properly uninstall the preference from WL? Thanks in advance.

Quit WaveLab, Windows key + R, type “%appdata%\Steinberg” and delete the folder “WaveLab Pro 9”.

If your income depends on WaveLab (or any software), it would be prudent to have an image backup. I use TeraByte products but there are many others available.

Thanks so much. I normally have a cloned disc that I can just switch to since all my working files are on other drives. This time, of course, since we are so busy I did not clone my SSD…Bummer.

Until you have time to reinstall Windows, you could always render the project to DDP and then burn the discs with WaveLab 8.5 or the extremely affordable HOFA DDP Player app (10 bucks) or maybe you already have another app that can burn DDP to CD-R.

I tend to burn CDs from DDP anyway so I can double check the WaveLab rendering side of things and check for plugin errors and things before burning CDs.

Somewhat off topic of course, but while we’re here, does anyone have any recommendations for current optical drives? (Topic over here).

NO joy, Still does not see the discs.

Every other program sees the discs.

As to CD drives. Plexor would be my first choice but the new Samsung DVD drives seems GREAT!

Just wondered, did you download and run the Gear Checker app, on the page PG sent you:
or did you follow the manual checklist on that page?
You might want to do whichever you didn’t do, or do both again, because that’s always found this problem before.
That’s how Mads found the iTunes fix when nothing else worked, including Gear driver uninstall and re-install, and WL preferences trash.

It has been done three times (both automatic and manual) but I will look at it again.

Thanks for the suggestion.