Wavelab won't find all Waves Plug-ins [SOLVED]

In Cubase 10.5, Cubase locates every plug-in including all Waves plug-ins. Therefore I can conclude this is not a problem with Waves, but with Wavelab. While, when scanning, I can see Wavelab scan the Waveshell, it simply doesn’t scan all Waves programs. It omits about 3/4s of all Waves programs.

I attached 2 Waveshells to show their locations. One is for VST3, the other VST2. These paths are reflected in the list “on start up the following folders were searched…” The “scan on next start-up” doesn’t change anything. I’m advised to not move either locations of Waves Waveshells.
I also attached the Waves plug-ins that do show up.

Things I have tried and failed:

  1. Force Plug-in Detection at next launch. (in the past week probably 100 times trying different things)
  2. Hold control > Force Plug-in Detection at next launch. I then deleted everything in Steinberg>Wavelab>9.5>Cache
  3. Trash Preferences Delete C>users>user name> app data>Wavelab pro 9.5
  4. Uninstall then reinstall Wavelab 9.5.15. it didn’t show 3/4ths of the Waves plugs, then ran the Wavelab 9.5.50 update, and there was no change.

What is left to try? Is there deeper Wavelab residue that needs to be deleted?

Steinberg support just forwarded a System Information File to the “development team” which doesn’t sound very encouraging.

The only success I have had in Wavelab showing all Waves plug-ins to show up, is take a Wavelab Preferences folder that I had saved from last November, and place it at C>users>user name> app data>Wavelab pro 9.5. That did make all Waves plug-ins show up, but once I did a “Force Plug-in Detection at next launch” it’s back to the bad behavior of only 1/4s of Waves plugs showing up.

What else should I try and thanks in advance?

I must say I have no clue. Because for Waves plugin, there is a single “shell” file to load, and this file lists all plugins.
Actually there are 2 shells, one for vst2 and one for vst3.
BTW, I recommend you to suppress the vst2 version, unless you have a specific need.

The scan is actually done by the Waves shell plugin itself. That could mean the shell does not find all plugins.
Therefore this is the Waves plugins you should reinstall, not WaveLab.

BTW, possibly Cubase has the settings stored in a cache.


My next try will be temporarily remove (I guess that means suppress) the VST2 version. If that doesn’t work, then a uninstall/re-install of all my Waves plug-ins.

Today I removed both the VST2 Waves shell and the VST3 Waves shell to see if Cubase would still show the Waves plugs. As expected, Cubase did not show any Waves plugs once booted. All Waves plugs are grayed out in the plug-in manager. So I can conclude they are not stored in a cache in Cubase.

Removing the VST2 Waves shell and keeping VST3 Waveshell in place did not make a difference other than the file classification in Wavelab plug-ins. I also tried removing VST3 and keeping VST2 with no luck.

The scan goes in alphabetical order, but simply stops after about 1/4 of all my Waves Plug-ins, as shown in my 1st attachment.

I also uninstalled all Waves, then reinstalled Waves with no difference. I’ll contact them again today since I have uninstalled/re-installed.

Searching threads, I haven’t found anyone else with this problem, so it seems something is screwed up on my PC. After uninstalling Wavelab9 and deleting AppData>roaming>steinberg>Walvlab Pro 9.5 folder, is there anything else that possibly should be deleted that is not being deleted?

In file: AppData\Roaming\Steinberg\WaveLab Pro 9.5\Cache\plugin-cache-xxx.txt

you can see all registered plugins. There must be some Waves entry. Do you a reduced number of items, or more than what you can see from WaveLab?

Yes PG, there are 2 Waves entries in the cache list. One for VST2 and the path is C:\Program Files\VSTPlugins\WaveShell1-VST 9.92_x64.dll. Here, in alphabetical order, API through GTR Stomp plug-ins show up in the cache list, and this is exactly what shows up in Wavelab. No Waves plug-ins after the letter G show up. Again, this is EXACTLY a reflection of what is listed in the Wavelab Preferences>plug-ins>waves, and of course I can load these in the master section.

The other for VST3 is at: C:\Program Files\Common Files\VST3\WaveShell1-VST3 9.92_x64.vst3. Here, only API plug-ins show up, nothing else. I would think the Waves VST3 should be an exact reflection of the VST2, but the plugin cache only shows API plugs, and nothing else. (see attachment)

I’m also working with Waves support doing Team Viewer. All plug-ins show up in Cubase 10.5, and I removed all the Waves plug-ins then they do not show up in Cubase, so I don’t think its a Cubase cache issue. There are a few more things Waves support is going to try tomorrow. I’m very impressed by their support. At this time, I’m not even sure if this is a Wavelab problem or a Waves problem.

Since the Wavelab cache is the very same as what shows up in Wavelab, would this indicate an issue with Waves?

If you have an old cache file with the complete plugins entries, you could try to copy / paste that to the current cache. But only copy the part

Plugins {


Then launch WaveLab and see if you can load the previously missing plugins.

I did not do this yet, however remember in my initial post above I wrote:
“The only success I have had in Wavelab showing all Waves plug-ins to show up, is take a Wavelab folder that I had saved from last November, and place it at C>users>user name> app data>Wavelab pro 9.5. That did make all Waves plug-ins show up, but once I did a “Force Plug-in Detection at next launch” it’s back to the bad behavior of only 1/4s of Waves plugs showing up.”

So this time, instead of deleting the entire Wavelab folder which is (c>users>greg>appdata>roaming>steinberg> wavelab Pro 9.5) I copied an old cache file, and replaced it with the cache file that currently existed inside the Cache folder. Then I did a “Force Plug-in-Detection at next launch” hoping it would not result in missing most of the Waves Plug-Ins…and it did not miss them. :smiley:

My conclusion is I should not have deleted the Wavelab Pro 9.5 folder, but only the cache file that resides inside the cache folder.

I haven’t tested the “Ignored Plur-ins” function, but I hope it only does what it should without deleting any Waves Plugs.

With this said, I didn’t copy then paste any plugs only between the { and } as you suggested, but instead just copy and past the entire “plugin-cache-…txt”. Am I setting myself up for failure in the future? :confused: I still haven’t a clue as to what caused this to happen.

Then I did a “Force Plug-in-Detection at next launch” hoping it would not result in missing most of the Waves Plug-Ins…and it did not miss them

This function just deletes the cache file, so that WaveLab has to recreate it.
Therefore, it’s like if plugins were really found this time.
Strange. Keep a copy of the cache file anyway.

I have exactly the same problem.
Today I updated all plugins to V11 and hoped to get the problem fixed without old versions.
Removed all old Versions (V10, V9.2) with Waves Central.
No way.

I totally agree that this must be a problem of Wavelab 9.5 since Cubase 10 and Wavelab 8 on same computer are recognizing ALL Waves plugins seamlessly!

I hope that somebody else has a solution.

Do any Waves plugs open in Wavelab?

When Wavelab scans the plugs, do you see it scanning the Waveshells and the individual Waves plugs?

I have spent a total of 5-6 hours over 3 different occasions with 3 different waves support guys & Team Viewer. I have to say, Waves support has gone 100% attempting to figure out the issue when I’m not even sure it’s a Waves problem. How much time has Steinberg USA Phone Support spent? Nothing! Send us information, and “we will turn it into the team.” When asking if Team Viewer might help the repose was “I could take a look, but I highly doubt I could resolve your issue.” I have been told multiple times a Steinberg representative will call me back but that hasn’t happened either.

Keep in mind that Waves and Wavelab 10 is not officially supported yet. Any testing should be done with Waves & WL 9.5.

All versions of Cubase scan and find all my Waves plug-ins 100%.

Honestly, the Waves guy was exasperated after the last solid 2 hour team viewer session, however I felt his conclusion was a bit rushed. And since his help, I have read a bit more about what might be causing this.

Feel free to PM me for a possible solution before you contact Waves. It may save them some time. :wink:

Yes, the detected plugins can be opened in Wavelab.

I see scanning Waveshells 1,3 and 6. Waveshell 6 is now the only one with plugins. But out of 26 there are only 3 detected. I see them while scanning.
Wavelab 9.5 is still unusable for me with this problem. Still working with WL8.

Thanks for the offer. I’ll send a PM

Same problem here: Nuendo 12 does recognize my Waves-plugins, but Wavelab Pro 11 does only recognize a few of them.
Anyone a solution in the meantime?
Thanks Gert

Did you try the “Force Plug-in Detection at next launch” option?

Of course I did.
I also made a new reference-folder (deleting old one and let Wavelab make a new one): a trick Steinberg often suggest.
Nothing helps…

I recommend installing only the VST-3 plugins. Did you so that?
Alternatively, installing only the VST-2 plugins. Did you try that?

Yes, I only installed VST3 (VST2 is not working on Mac M1).
I also did a detection-run with only the Wavelab-folder selected.
So a few plugins are loaded, but only 25% of the plugins I own.
Very weird!


Did you try run WaveLab in Rosetta mode ?

regards S-EH

No, not Rosetta, only native.
In rosetta Wavelab is a bit unstable and crashes time by time. So I only work native.

Fwiw, my issue was solved by Waves shortly after this thread.

With all the vitriol Waves is currently receiving, regardless of right or wrong, IMO they have excellent support. I must have spent several hours over several days with Waves doing Team Viewer trying to detect my issue.

The issue was on my end. It had to do with 2 different Windows user accounts. The Waves guy showed me and proved to me that was my problem why Wavelab would not load particular Waves plugs.

Its a bit embarrassing, especially the amount of time Waves support spend with me doing Team Viewer, but you live and learn.