Weird crossfade pointer? Crossfades cannot be moved (properly)? Crossfades deleted automatically?

EDIT:

There is something weird going on, when moving crossfades in certain scenarios.

1) When the crossfade of an audio event is 11ms or longer, and you are zoomed in, there are different arrows when hovering over the crossfade from left to right.
This one on the left of the Crossfade to change the length of the fade:
image

A normal mouse pointer in the middle to move the entire crossfade as it is:
image

And this one on the right of the Crossfade to also change the length:
image

If you zoom out to a certain level, the mouse arrows left/right disappear and only the normal mouse pointer remains to move the crossfade around. This is one “issue”, as depending on the zoom level it can be really hard to select only the crossfade and move it around, so you can accidentally move the event on the left or right of the crossfade. As long as you are zoomed in, this a fairly easy task, but nvm, this topic is not about that specifically.

2) When the crossfade of an audio event is 10ms or shorter, and you are zoomed in, there is an additional mouse pointer added, which is really really hard to select and on the very left side of the crossfade only :
image

When moving this one, it removes the crossfade entirely and even when you want to crossfade the 2 adjacent events again aftwards by hitting the crossfade hotkey, it will crossfade them, but set the length to 0. So basically you have no crossfade left and have to open the crossfade menu and set the values manually. As said before, this one only shows up, when the crossfade length is 10ms or shorter.

When zooming out now, depending on the zoom level, instead of having a normal mouse pointer like in example nr 1), you see only the newly added mouse pointer, when hovering over the crossfade. Now, depending on your zoom level you may or not may be able to select the crossfade where you can move it. It happens constantly, that you always select this new pointer and screw up your crossfade.

Why does this new pointer even exist? And why only when the crossfade is below 10 ms? This thing causes only problems.

To complicate this situation even further this tool does not work on multiple events when more are selected. All the other pointers work in that scenario, just not this new one. Moving shorter crossfades on multirecorded instruments, when zoomed out, makes it a complete nightmare:

Steps to reproduce:

  • record audio track
  • cut it somewhere in the middle
  • create a crossfade which is shorter than 11ms (10ms and lower)
  • check if you have the new mouse pointer
  • try to move it around while zoomed in
  • you will see it screws your crossfade and you cannot apply another crossfade afterwards, it will stay at length 0 ms
  • set the crossfade again manually to 10 ms or lower
  • zoom out, and try to select the crossfade easily to move it around, it can happen, that you will select the crossfade with the new pointer, basically screwing up your crossfade again
  • now duplicate all the tracks, select them, and try to move the crossfades on all of them simultaneously
  • if you select the new pointer by accident, only the crossfade of one event will be moved, the others stay where they are

PS: It might be possible, that the length threshold (10 or 11 ms) is somewhere different on your system, I am not sure yet if it has to do with the project length or whatever. Just a side note…

I realised, that this pointer
image
usually shows up, when having 2 events, which are not crossfaded with each other, to move the edge of both around at the same time. So the main issue here is, that Cubase sees a crossfade with a length below 11 ms, as “no crossfade” and treats it like it.

That’s not how it works.
Maybe, read the manual to understand what the handles can do.

@st10ss What has that to do with the issue report I just opened?
Please read the post, before suggesting random stuff.

That’s not how it works.

@st10ss But the fact is, it happens. Unfortunately this pointer appears on crossfaded events too, when the crossfade is shorter than 11 ms.

@Tj99 I 100% agree with all of this.

When the Crossfade is too short, this pointer image (that normally appears to slide the Split points) will appear on the very left side of the Crossfade, and clicking it will remove the Crossfade and the two Events will end with normal fades (the Fades seem to slide toward each Event), and when the zoom is too low, the pointer image will be the only one that appears because its “hitbox” is probably on the foreground (sorry I’m a also a gamer lol).

So in short, when Crossfades are under 10 ms in length, the left side of it is detected as a Split point, and “using” this pointer will effectively replace the Crossfade with a Split.


Also, here are also two other issues related to Crossfades :

  1. In the Crossfade Editor, it’s almost impossible to use the mouse (Click + Drag on the value field) to adjust the Fade Length. The behavior is totally erratic, plus it seems to be a combination of linear and rotary control, making it impossible to dial in a value precisely. All other fields work fine except for Fade In/Out Length.

  2. In Preferences > Event Display, the Show Overlaps setting has three different options, but the On Mouse Over option isn’t working, it still shows overlap stripes for the entire project, same as when Always is selected. Just noting that the different settings for this preference aren’t even listed and explained on the Manual

1 Like

Thanks for confirming!

Yes, agree, this was working fine once IIRC.

And if I may add something to this:

yes unfortunately, that is the case. It would be great though, to see a dedicated pointer, when hovering over crossfades when zoomed out/low zoom, as with the normal mouse pointer image it is very very hard to see, if you were able to grab the crossfade or if you just moved one of the adjacent events.

Just not this pointer image, as it has a completely different usage :sweat_smile:

Yeah but when the crossfade is one pixel wide you can’t have all three controls, adjust left, move and adjust right :sweat_smile: I think it should simply disable the pointers until you zoom in enough to see the actual crossfade.

Adjust left and adjust right will vanish anyway after a certain zoom level and are used not that much compared to moving the crossfade (at least for me) :thinking: