Why do Maschine MK3 transport controls also trigger VST sounds?

I have Maschine MK3 with Cubase 10 Pro. I’m running them on my Mac M1.

I found a tutorial how to set up Maschine to also use transport controls in Cubase (from D-One).

I want to have all other pads assigned to regular pads and transport control to control the Play and Stop buttons.

But for some reason when I set it up, the transport buttons also trigger piano keys in a VST. So when I press Play the project in Cubase starts running, but with it it also triggers the sounds in my VST.

I don’t underrstand how to turn this off.

As per the Tutorial I added a new Mackie Control and assigned the input and output ports to Machine MK3 Virtual input/output.

There is an option to select Machine MK3 as both input and output, but it didn’t do anything, so I selected the Virtual ones.

Screenshot 2022-09-05 at 12.30.31.jpg

I then opened Controller Editor, added a Mackie Control and also enabled “Host Transport Control”:

Screenshot 2022-09-05 at 12.26.41.jpg

At the moment the pads on the right are assigned to some functions, but I will change those to trigger the actual sounds later, so I don’t care about that for the moment.

Then I select the Play button and assign it to the “Play” function, which has the Parameter ID 94.

Screenshot 2022-09-05 at 12.26.59.jpg

So now to my understanding only the Play function is assigned to this button. It shouldn’t be allowed to trigger anything else. Right?

So how come when I now press Play it does work BUT with it it also triggers some high pitched sound from my VST?
And it’s the same with other transport buttons.

How can I get this to stop?
Are there any other MIDI settings in Cubase that I should also set up correctly?

Thank you very much.

Hi,

In the Studio Setup > MIDI Port Setup, disable the Machine MK3 Virtual Input from the All MIDI Inputs column, please.

Oh wow, this worked!

But I don’t understand what this does. Will I now be limited in any way from using the controller’s pads and other stuff for beatmaking?

Hmmm I seem to now have lost my pads function. Now only the Transport works but nothing else.

Hi,

The device sends common MIDI Messages to Cubase. The Remote Device (Mackie Control in this case) changes the MIDI Message to the command. But the MIDI Track also receives the MIDI Message. If you disable the option, this means, once you select the ‘All MIDI Inputs’ as the input of your MIDI Track, the track receives the source MIDI data, which mento to be to control Cubase too. So you have to remove given MIDI Port from the ‘All MIDI Inputs’, to block the MIDI data (meant for Cubase control) to go to the MIDI/Instrument Tracks.

1 Like

Thanks.

I found out the problem still persists. I thought it works but that was because I was in Groove Agent with only one pad active with a sample on C1.
As soon as I went to a VST with a piano roll, I got the high pitched noise again when pressing Play or Stop. Which means besides the Play function, for example, a C5 or whatever the last notes on the piano roll are, plays again.

Hi,

Could you attach a screenshot of the MIDI Port Setup, please?

Hey. Sure.

I have tried also all these options from the picture below:

  1. All midi inputs: Plays transport normally, pads don’t work.
  2. Chord pads: Plays transport normally, pads don’t work.
  3. Pigments - Midi Out: Plays transport, but with some weird glitched sound.
  4. Maschine MK3: Plays transport, pads don’t work.
  5. Maschine MK3Virtual Input: Plays transport but with added sound from the pads, pads work.

I have found out the Play button plays the A#5 pad sound.

Another thing is, it doesn’t matter if in the Maschine Controller editor the “Host Transport Control” is checked or not. Cubase behaves the same.

Hi,

I would disable the virtual port only for the All MIDI Inputs.

Yeah, I’ve tried that, too, but no luck.

I’m just gonna settle without this control, or try to find a workaround without the Mackie option.

Thank you for all your help, I’ve learned some new stuff.

Hi,

What happened in this case, please?

Everything is exatcly the same. Looks like only the Maschine Virtual input is important, Maschine MK3 doesn’t matter in this case at all. At least in these options.

Hi,

Could you use any MIDI Monitor to test, which MIDI Port is in use for the Machine Pads and for the Transport buttons, please?

I pressed Play once, then Stop once and then C3 on the pad once, to show all of the different signals.

I left the bottom picture on “All MIDI Inputs”.
Although it works exactly the same with “Maschine MK3VirtualInput”.
These two are the only ones that control the Transport and the pads. Just that unfortunately the Transport buttons also play pad sounds, too.
Other options work the Transport controls NORMALLY but then the Pads don’t work.

And these are all the different options to select from:

This is the Maschine Controller Editor main page. The pads have some other functions but I changed the bottom left one to a C3 note, so I can test if everything works normally:

This is the setting for the Pad C3 note:

This is the setting for the Play button in Controller editor:

Perhaps this should be something else than MCU button (Start option doesn’t do anything - I tried this)

This is the current setting in Cubase for MIDI:

So, in the end, the “Play” button works, but also plays the A#5 note and “Stop” works, but also plays the A5 note.
I don’t understand why, because the Play button is assigned to Midi ID 94, which is “Play” function.

Hi,

From this screenshot, we can see, Machine really sends all the MIDI Messages over the Virtual MIDI Port.

What you could do is to add the Input Transformer to filter the Transport MIDI Notes out. In this case, it would be something like

Filter Target
( Type is | Equal | Note | And
Pitch | Inside Range | A5 | A#5 )

Action Target
---
Function
Filter

Hi,

Mackie Control Protocol defines, the MIDI Note 94 has been assigned to the Play function in the DAW.

I’m lost here. Can you tell me where to start with this? I’ll figure out the rest.

Hi,

See the description in the manual, please.

Amazing!

I’ll work on this. Thank you for all your help. I appreciate it a lot.