Why does Cubase automatically set event start locations?


When I import a sample, Cubase sets ‘event start’ position to some weird, arbitrary place.
In that sample’s case, it apparently set it to the END of the sample.
And when I have the ‘snap’ on, it won’t snap to the first bar of the grid.
Why does this happen?

Hi,

The Event Start is obviously placed at the start of the Event, as shown in your screenshot.
You have even added a red box to highlight it.

I believe you are talking about the Snap Point, this sets where the Event will snap on the Grid.
Indeed there is an issue where the Snap Point is placed to the end of the Event under certain circumstances. If that’s the case, then simply open the Sample Editor, find the S handle, and grab it where you want it to be.

Thanks.

How do I make it so that it never creates any snap points in between?
How do I prevent from this ever happening again?

Btw, the ‘s handle’ is nowhere to be seen.

You can’t, Snap Point cannot be disabled.
It’s a bug and there’s no way to prevent it until it’s fixed.

Are you sure you don’t see it ? Normally it’s in the center of the waveform. You can adjust the Editor view options to Global Zoom and Show Clips and Events.