Why doesn't this PLE preset work consistently?

The setup:

  • Create 8 audio tracks in a blank project.
  • Put the first 4 in one folder, the other 4 in another folder.
  • Close both folders.
  • Enable “Sync Project and Mixconsole” (optional, see below)
  • Build this PLE preset.

The goal here is to select a track by any means (personally I select them from the mixconsole on another monitor, that’s why “Sync Project and Mixconsole” has to be enabled), and apply the preset.

  • Select track 1, apply preset.
  • Select track 8, apply preset.
  • Select track 1, apply preset.
  • Select track 8, apply preset.
  • repeat…

Does it work for you ALL the times, irrespective of how fast you select channels and apply the preset?

Is this Pre & Post Commands not waiting for each other to finish their sentences again?

I can not see anything happening. I have the 8 audio tracks, split to two folders, then closed. Created the PLE as shown below, then select a channel in the mixer, with Sync On, and… nothing happens. What should happen? Should it open the folder of the selected track and display the selected track? Should it hide the folder that doesn’t contain the selected track? Aren’t the Pre and Post commands cancelling each other so that’s why I’m not seeing anything happen?

Sorry, I forgot about that.

The idea is: We select an audio channel in a closed folder, and then we apply the preset so that the folder containing the originally selected track becomes selected.

I’m trying to break down a process in steps, so “Select Parent of track” is the first step I would like to have. (For example, in a project with many closed folders, select a track (from the mixconsole) and then just open the folder that contains that track.)

Edit: And, to flatten the preset in real time. A track in a closed folder is selected. Apply visibility agent show selected tracks. Now, only the folder and the selected track are visible, the track still selected. Now the main ple body selects the folder. Then an undo visibility brings us back to the original state, with both folders closed, but the one that contained the original track selected.

It works for me. But when doing it fast enough (applying the preset faster than about quarter = 48) will make it produce unpredictable results. I expect people with machines faster than my i7 6700 to get away with faster tempos, but I’m not sure.

OK, I see. So I re-sized things so I could go through this quickly, and starting with neither folder selected each time I alternated through all the audio tracks twice (1,5,2,6,3,7,4,8, 1,5,2,6,3,7,4,8) and each time the correct folder was selected, but not opened. So that’s 100% with an n=16. Seems to be working fine here.

1 Like

Pfff, what’s wrong over here then? :thinking:

Dunno. So it works sometimes for you but not all the time? Think there could be some sketchiness because your mix console you’re synced to is on another screen? Could test by checking with the mix console open on the same screen as main console.

1 Like

Good idea. Tried with disabled preferences too just now, still failing at some point. I will try the lower zone mixconsole now.

Just for the record:
Win 10 Pro 1909
Cubase Pro 12.0.52

Select Parent Folder

It’s as if the last undo visibility doesn’t want to go.

Same here.

That’s strange. Don’t know what to tell you.

1 Like

I upgraded to the last nVidia studio drivers, too. Still the same deal. I really don’t know what’s the problem here.

I appreciate your effort @SF_Green! :+1:t3:

1 Like

No problem. Wish I could have been more help.

One thing - what SW do you use for the screen cap video?

It says Licecap. I do wash everyday though.

1 Like

I confirm the issue.
Sometimes it gets stuck on showing the selected track only, because the post-process command doesn’t apply properly, which is in fact the main issue.

You don’t even need to enable “Sync Project and Mixconsole” and use Folders to reproduce this.
Just two plain tracks are enough, and it even occurs when trying to apply the preset on the same track multiple times in a row.
The Event Target Filters in PLE isn’t involved in this, can be left blank.

PLE preset bug


Great! Well not great, you understand. :blush: So it’s now 2 of us that have this, and SF_Green who managed an impressive 16 steps without failure! Let’s see if others find the time to do a run too and see how the numbers come out.

1 Like

It’s probably just the old problem of there being no pause or wait function.


Probably, but I’m trying to see the extent of this. SF_Green did 16 steps on their machine at their own pace. I did 2, same as Louis. I’m using an i7 6700k. I want to see if a faster processor has anything to do with this.

It’s a real pity this. A brand new feature, so convienent, to be sabotaged in such manner.

@ggmanestraki feel like uploading your test project?

Sure! Just give me a couple of hours until I get back home.

Edit: Here it is.

PLE test project.cpr (376.6 KB)

Sometimes yes, sometimes no.

1 Like