Windows 10, intel 12th/13th gen CPUs? any core allocation problems?

According to a post from a developer, this bug isn’t new in C12, so it’s been present for a long time I guess. A lot of people are, and have always been, as long as I can remember, complaining about performance issues even with an “empty project”. It’s this bug right there. So the devs were aware but never ever talked about it until November 2022. Better leave users struggle ugh?

I remember when C12 was released, an enormous amount of people complained about performance issues, and the sentence that came up most frequently was “even with an empty project” when they were trying to figure out where the issue could originate from.

Not only that, but it was also affecting clean projects that didn’t have the bug initially (projects created in C11 or earlier), and I am very sure it was the same bug. On some systems any project you would open would recover the bug. Now they fixed this, but it still remains when you create a new project right after launching Cubase. So yes, once you “fix” it and save, it will never come back on this project.

What @auggybendoggy3 says about replacing the default cpr file is a bit intriguing, because as I said earlier, when we open a project that doesn’t have the bug, any subsequent new project you create as long as you don’t close Cubase won’t have the bug either, and without fixing it in audio connections, we are able to save the project, close Cubase, and open this same project, and the bug will not be there. This would mean the issues comes from the Cubase.exe code and not from the project file.

Sorry for the rather long post but it’s in case a developer sees this. :slight_smile:


Loius you know far more than me so take my words as simple guesses really. Thank again for the help, really appreciated.

Also Starnaf, what buffer setting are you using? I’m like at 256.

Usually 256. However having bigger project (50+ tracks with plugins etc) I have to switch to 1024 - to be able to work at all (having i7 12th gen CPU and 64 Gb RAM??? Come on Steinberg, you screwed something seriously!) Generally I am thinking of switching to Studio One which performs muuuch better. Pity, because I have been using Cubase for over 20 years and really had no issues till version 12.

Hello Louis,

Can you send me the link to your video tutorial? Not only cubase 12 pro but also cubase 10.5 pro with core i7 th12 configuration, 16gb ram…windows 11.

I have done everything with the focusrite 2i2 gen 3 sound card, but every time I open cubase, there is a very annoying little click. Are you willing. Thank.

Hello, there is no video for this.
The issue is explained in the following post :

As my post still gets shared here and there, here’s a small correction to my original post.
As stated in point 2., Cubase (12, 11, 10,… all versions) will process the Main output bus with real time latency in certain cases, leading to high load, especially when you have plugins on the master bus.
What we found out after my post: deleting and recreating the Main out (as suggested in workaround 1.) will solve the issue only temporarily, as Main out will return to real time processing, once you use a “preview” (e.g., listening to media in the media bay or in the editors). That means, the high load symptom will return after a while, because most users need a preview at some point.
Conclusion: if you are affected by this issue, workaround no. 2. will be your choice, as solution 1. will only solve the issue temporarily.
Sorry, I cannot edit the original post. I hope, this update finds its way to the ones affected, anyway. Have a nice weekend!

1 Like

Thanks for the follow up on this, @Chriss

This is not what I’m experiencing personally, but I might take some time to dig into it again, if this can help. What I’ve found is that saving the project with workaround 1. (delete + replace with new one) fixes the bug completely and it never comes back again on this project. As I am typing this, I tried using the preview from the MediaBay, File Browser and Play tool in the editor, and I assure you that the bug does not come back. If that was the case I would have already raised a new topic for this particular issue, because I do preview all the time and I would have definitely noticed it if that was the case.

EDIT : More info in my post below.

If this can help, my setup is Cubase 12.0.60, Presonus StudioLive AR16c (latest driver), Windows 11 and Intel i7-9700K.

I will Investigate with workaround 2.

1 Like

What I wanted to ask - You mean the subsequent outputs are processed always with ASIO Guard - this mean the next one after first in a row or any not the ‘‘Main Mix’’ one? First one I created Mute Out output, and second one is my Main Mix out. Does I made it correct to not to have this issue? @Chriss

I’ve been following threads about this subject with some curiosity. We’re not seeing the bus problem on either Nuendo 12 or Cubase 12 Pro here (and weren’t seeing it on version 11 either).
What are these ‘certain cases’ that cause this?
Enquiring minds would like to know.

@Chriss I have investigated the issue more thoroughly. (that’s with workaround 1.)

I have found that the bug behaves differently depending whether the Control Room is enabled or not.

In both cases, the bug occurs when creating a new empty project or opening a project that has the bug, right after launching Cubase.
By empty I mean with the Create Empty button when no template is selected
(I have tried opening a template and in this case the project opens clean.)

The bug is fixed by removing the default output under the Outputs tab, and creating a new one (this is Chriss’ workaround 1.).

How it behaves afterwards is tied to the Control Room :

CR Disabled :
Previewing the audio (MediaBay, File Explorer, Scrub tool and Play tool) will indeed instantly make the bug return. When this happens you’ll have to do the above fix once again.

CR Enabled :
Previewing the audio does not make the bug return.
Moreover, when we Enable the CR when the bug is occurring (from CR Disabled), the issue goes away as soon as we try to preview audio, same as when we remove and recreate the output.

Actually, after thinking about it, the fact that the Control Room is enabled actually acts like workaround 2. : create a second output bus and use it instead of the first bus. That’s why people who are using the CR do not experience the issue at all, especially if they are starting new projects from custom templates that have been saved bug free.

Additionally, once you have replaced the output and saved the project, it is internally considered as fixed, even if it returns because you have the CR Disabled. This can be verified by making the issue return by previewing audio, saving the project, closing Cubase completely, and opening everything again. The project will open in the fixed state.

However, if you first save the project without fixing the issue initially, this project will remain in the buggy state until you fix it and save it. And what’s important to note is that when we open a project that does not have the bug, close it, then load a buggy project, the buggy project will receive the fix from the clean project, without us having to remove the buggy output, and saving it will effectively fix it. That’s a bit weird but very important to note. I have already talked about that earlier in this topic but gathering all information here is a good thing.


Hi @Arlicht , indeed I’m referring to the Main Out. The Main Out can of course also be on second or any other position, depending on which output you assigned to be the Main Out.

I’m about to build a new system with a 13900ks on an ASUS Pro Art z790 mobo, 96gb ram.

I haven’t read through everything related to this, can you clarify if this is a bug/software/OS issue in which Steinberg is trying to solve/mitigate/reduce?