[Windows]USB Midi Device Not Recognized After CB8 Is Running

+1. This problem is really annoying.

Sometimes I forget the UR 44 interface to connect to the USB port.
On Cubase start, it can not find the interface. I would like a function that the equipment can be re-read.
currently. The only way at the moment is to close and restart Cubase when plugged the interface.

That’s interesting… Meaning you are reporting that you are experiencing this on a Mac. I thought this was related to us running CB and our USB connected stuff on a PC. Maybe you are doing something wrong? Not to highjack this thread maybe you should post your issue again (with more specifics) in the “general” forum section and see if someone can assist.

Good luck. :slight_smile:

Regards :sunglasses:

Edit: Tonylife’s post is gone but his memory and issue live on… :laughing:

Also adding a record of another thread here so that I can keep these requests nice and tidy:
http://www.steinberg.net/forums/viewtopic.php?f=228&t=74134&start=25#p460235

Best of all, this topic again gets to the front page baby. Nice! :wink:

+1

Unbelievable that this still happens. Very annoying.

+1… windows issue or not ,please make some efforts to solve this annoying issue.

+1… yes please!!

Another +1

I would love this, as I forget to turn on my keyboard frequently. :mrgreen:

+1. But it’s been years, and nothing has changed… One of these day, they’re gonna do it and advertise it as a new “feature”… Because, you know, they actually have to do a bit of programming, not like on mac where the os is already doing all the job.

I know people will want to clobber me for saying this, but for those who hate restarting Cubase to plug in a MIDI device, why not use Loopbe MIDI Loopback and MIDI-OX as a go between?

Why, I’ll pulverize ya… Not. :wink:

Steve should never be clobbered for suggesting a workaround. But, I hope Steinberg doesn’t use these suggested workarounds as a reason to not consider this request. That might be “clobber” worthy for them. :cry:

Also apparently there is another program named “rtpMIDI” that can be used as a workaround too.

For me, I hate installing and having extra programs/processes running on my PC. So I never tried any of the suggested workarounds to see if they actually work. Trouping on, I will just continue to restart CB until Steinberg incorporates the feature.

Regards. :sunglasses:

Please make this happen… or at least tell us why it’s not going to happen/ taking so long.

+1

Slight push …

+1

I hope that soon we are going to see some improvement, and maybe with the introduction of the new internal midi system in Windows 10 with the MIDI API.

As said on internet : MIDI API - also available across all Windows 10 devices - this new API allows multi-client access to single MIDI hardware, new jitter-free operation, plus other bug fixes - we hope they embrace the RTP MIDI (over the network too)” .
Actually the common behavior on Windows is that two applications can’t use the same MIDI ports at once, and what’s also common behavior is that a DAW will lock up all of the MIDI ports making it impossible for another application to do anything with MIDI.
If i understand correctly it means that with Windows 10 those problems will be gone, but before software will needs to get updated to support it.

Here the problem is maybe a litlle different because we use only one software, but new MIDI API on Windows 10 will allow us to use few midi applications at the same time, sharing the same midi hardware port number with no conflict or “workaround solution”.
At the end we have new functionalities that should open new “doors” in midi area.

Iam not a specialist at all on programmation, but that new concept in Windows will, i hope, allow new way to conceive midi sharing programmation for Steinberg and so to get rid of those few midi problems.

I couldn’t wait any longer, so I tried something.

I bought a M-Audio MIDISport 1x1 http://www.m-audio.com/products/view/midisport-1x1#.VkShNuKtPhY and connected it to the Yamaha KX8 I use. Now, if I turn on the keyboard and change the output to MIDI from USB after Cubase has started, all is well. Cubase sees the keyboard and I can record etc. I still lose out though, as the transport controls on the KX8 don’t work over MIDI, just USB.

Concerning to what i wrote, there is a interesting video about the futur new midi/audio features in Windows 10 https://www.youtube.com/watch?v=LHaz3p_H8iM

Bumped for CB version 8.5.

Regards :sunglasses:

Here’s my two cents worth of pleading for this.

I’ll even give 5 cents if it helps.

I’m willing to pay oodles of money for the software if that inspires you (using the trial version at this time). And with the current USD/CAD exchange rate, that’s a lot of cash.

Bump.

Over the years CB has trained me to turn on everything before starting it, and every time I do that, I’m sadly reminded of this unanswered request.