Workaround to Bypass Inserts, Sends, Channel Strip, EQ and Cue Sends with short key

Workaround to Bypass Inserts, Sends, Channel Strip, EQ and Cue Sends.

My Workaround is a result of these two posts. If you are interested why I was not able to solve this with the Project logical Editor enjoy the read.
shortcut-to-bypass-inserts-send-and-eq-on-a-single-channel
and
bug-logical-project-editor-track-operation

I am on Cubase 11 and Windows 10.

Now what is my Workaround and what does it do?

It is a Macro that allows you to bypass Inserts, EQ, Cue Sends and Sends on any selected/marked track or multiple selected/marked Tracks.

• it does not bypass all tracks at once unless you mark/select all tracks for bypassing.
• it does not require the Mixer to be in focus when using the short key
• it bypasses the Audio section and not the MIDI section on Instrument and Sampler tracks
• you can set it up to bypass EQ (but this works better in the Project logical Editor), Inserts, Channel Strip and cue Sends.
• With a small amendment you can set it up to bypass all tracks at once without having to select them and without having to put the mixer in focus.

This approach has its draw backs, as mentioned it’s a workaround, and I will start by listing those.

• Any Mixer you assign the macro to needs to have all tracks visible in the centre Zone of that Mixer. Any Tracks assigned to the right or left Zone of that Mixer will be triggered/bypassed by the short key regardless if they are selected or not.
• You cannot assign the “MixConsole in Project Window” mixer to the macro if you plan on splitting tracks by zones in any of the other mixers, and having that mixer window open at the time you apply the macro. This will result in the same as above.
An example for better understanding:

  1. If all tracks are set to the centre zone selecting any
    one or multiple tracks will result in only those tracks being bypassed this is the way it should be !!
  2. If the zones are split and you set all inputs to the left Zone, all tracks and groups to the centre
    Zone and all FX and outputs are set to the right Zone by selecting the same tracks as before, this time the result would be that all tracks in the left and right zone including the selected tracks would be bypassed.

• The Mixer assigned to the macro can never be open at the same time you plan on using the macro. This will result in the command being ignored.
Example for better understanding:

  1. If the mixer applied to the macro is Mixer 3 and you have Mixer 3 open on your screen the short key will be ignored.
  2. If you have the macro applied to the Project window Mixer and that is open this will result in the command being ignored.
  3. If you have the macro assigned to the project mixer window and you have any other mixer window open in which you have split the zones you will witness the behaviour explained in the second bulletin.

• If you have A EUCON controller do not assign the Macro as a EUCON command instead assign a short key to the Macro and use the key command to trigger the bypass.
• This Macro does not bypass the MIDI inserts on Instrument and Sample Tracks if you need this functionality you will have to add the respective command to the Macro or create a separate short key to do this.
• You will see a short flash of the Mixer on screen when using the short key.
• There might still be situations that I have not yet encountered, resulting in my Workaround not functioning properly. Should I find such a situation I will update this post.

Now for the Macro!

• Create a new Macro in the Key Commands Editor.
• Name it as you like. I named mine “Toggle-Bypass Insert-eto”
• Add the Commands shown in the Image below to your macro


• Add a short key to your Macro
• Use it :blush:

After listing all the drawbacks above, it sounds like a nightmare to use my macro but now that you know what to look out for all you need to do after setting up the macro is keep these 3 basic things in mind and you should be good to go without any issues.

Best Practice:

  1. Use Mixer 3 for the Macro if you can and set it up to have all tracks located in the centre Zone. (I am not sure if all versions of Cubase offer multiple Mixers so your milage may vary.)

  2. Don’t use Mixer 3 for anything else.

  3. Don’t have the Mixer 3 Window open when you are using the macro.

Let me know if this worked for you and if it is something you are able to use.

1 Like

you are awesome! ty

would be fine to disable inserts without clicking on the mixconsole first.
ty

You really did your homework on this one. Great one!
I originally wanted to dedicate 8 keys with key commands for bypassing insert slots 1-8 on selected channel. For quick A/Bing the outcome of an individual insert effect. So not all at once. But that seems to be only possible with a generic device. However…your marco is well thought out. Props!