Shortcut to Bypass Inserts, Send and EQ on a Single Channel

Bypass function for Inserts, Send and EQ on a Single Channel.

Why are there no Short keys on the Short key List to bypass Inserts, Channel Strip, EQ, Sends or Cue Sends on a single Channel? (The active Chanel I am working on)

Without these short key’s controller assigned functionality is verry difficult and in some cases not possible for a single channel in Focus.

I am Aware that there are similar short key functions in the Mixer tab for Bypassing all channels inserts, EQ’s etc…. at once or do the same for only the Main Mix channel.

And yes, I am aware I can do all that with the mouse but that is not what I am looking for because I would like to use a controller or short keys to access the individual functionality of those parameters.

If I am missing something please let me know where to find this functionality.

If it does not exist it would be nice if Steinberg could add the possibility to create short keys for these functions in the short key list.

The exact functionality of what I am looking for is possible for Inserts on a MIDI track.

It is called “Toggle insert bypass for MIDI” and can be found in the “Process Project Logical Editor” Folder on the Short key list.

Aren’t the various Bypass commands in the Mixer section of Key Commands doing what you want? Have you tried assigning Key Commands to any of those?

In the Generic Remote, the various bypass commands are in the VST Mixer section - for example here’s the Sends Bypass I configured for one of my remote controllers:

1 Like

Dear Nico5

THX for taking the time to offer me a working Solution.

This solution should work for anyone using a Midi controller.

After trying your solution, I stumbled onto this one. And since I use a EUCON controller this solution worked better for me.

But anybody having the same issue as I did gets two solutions if they read this thread. :blush:

Thank you again for support and detailed description.

My Solution was to use the Project Logical Editor.

When opened I loaded a preset called “Toggle Insert Bypass for MIDI”

Now I edited this preset to match the settings Below and saved it as a new preset. In my case I saved it as “Toggle Insert Bypass for Audio and Instrument” You will need to add one line to the top Section by using the first plus button.

Now that my preset is saved I can assign a Short Key to it or address it with a EUCON controller if I wish to do so. Under Key Commands you will find your preset as shown below.

Repeat steps for EQ, Chanel strip, Sends etc…. only now you can start with your preset instead of the MIDI preset I first.

Hope these solutions are Helpful to Others.

THX again Nico5

1 Like

Those commands bypass all Inserts/Sends at once, not only the ones on a selected track. (And in the project window, it only works if the mixer in the lower zone is opened and has the focus.)

I’ve set up this exact same preset before. But with a selected instrument track, it bypasses only its MIDI inserts, not the wanted audio ones. And since I mainly use instrument tracks, I still search for a solution…

Hi grz
I have it working on audio and instruments Tracks. And I think you missed a few steps on setting this up from my example . But maybe I did not do a good job explaining.

PLS check and see if your self created preset settings in the Project logical Editor are exactly the same as mine. With this setting it should work on any audio and Instrument Track that has been selected.
Let me know if this helped you.

Hi Unoute,
thanks for your fast response!
I’ve double and triple checked my preset (it’s not that complicated…) but it still only bypasses the MIDI inserts here. Very strange…
I’m using a German Cubase but it’s not hard to see that I’ve set up the exact same preset:


BTW: the keycommand for bypassing the inserts on all tracks bypasses the audio inserts on instrument tracks

Hi grz,

You are right sorry about that.

On Instrument tracks my solution only turns off the midi inserts and not the Audio insert effect of the Instruments.

I’ll keep trying to find a solution as this bugs me too so once I have one I’ll post it back here.

Sorry for the confusion.

Thanks for checking again.
At least I know now it’s not me or my system :grinning:

1 Like

Hi grz,

Sorry but after trying all day and yesterday and this morning, I have come to the conclusion that the logical Editor has a Bug.

I am not able to get it to work as expected on Instrument Tracks.

I Reported A Bug to Steinberg let’s see what they say.

In case you are interested this is my Bug report. Should I find another solution I’ll be happy to post it back here.

All the Best for 2021 :wink:

I can confirm, works the same on my system.

Since Instrument tracks can have midi and audio inserts, the command Bypass Inserts is ambiguous – and it happens to pick the wrong one for some use cases. But it’s the right choice for other use cases.

So arguably it’s not a bug, but maybe more of a missing feature?

Try this settings in the Project logical Editor

When applying it this happens. Which would be verry close to what I would want to do with the editor.

Now change the setting to Toggle and suddenly you get this behaviour.


I see no logic in this.

Let’s go back to the first setting and add a command to the top section.
should look like this now:

With this setting it should technically speaking turn of The Audio-Insert effect on the Midi Channel like it did when I did not limit it with the other conditions.

But it does not … :man_shrugging:t5:
Or maybe the logic behind this is too complicated for me to comprehend.

And maybe You are right and its just a missing feature.

mmmhhh - isn’t an automation event one of those little dots on an automation lane? So do you actually have any automation events on the selected instrument track?

No none that I am aware of.
Unless the instrument loads it but then Again in the Initial setup without the other conditions it also turns off the audio track inserts and I have no Automation on that.

Very interesting findings Unoute!

For your first example there’s already a keycommand available: Mixer -> Bypass Inserts. It toggles the inserts on all tracks and chooses the audio inserts on tracks with 2 kinds of inserts (sampler and instrument).

Your second example only works on pure automation tracks (outs, groups and FX).

The simplest (and only AFAIK) solution would be Steinberg adding keycommands for bypasing Inserts and sends on selected tracks resp. channels only. Best would be to not limit those on channels like the existing ones so the mixer wouldn’t have to have the focus.

Or to change the PLE behavior so that it always uses the audio inserts…

That would break all the scripts where users intend to mute midi inserts on purpose - so I don’t think Steinberg would do that.


As I mentioned in my prior post, this is not a bug, but should be a feature request.

Media Type is Automation
Automation Events are the little dots in the automation lane. It doesn’t really make much sense to use them in the PLE for changing the audio fx bypass of a whole track.

For example in the PLE, this is one example how it would make sense to use them. In the screen capture:

  • My PLE is set to move the selected automation events to an earlier time, when I hit the Apply button.
  • First I select a few automation events
  • and then click “Apply” a few times – and each time the selected automation events move left a little

Hi Nico5,

As mentioned in my previous post I have no automation on any of the tracks that was programmed by myself. And just to be sure I checked through all the possible automation lanes on every track and none of them have any automation written to them.

I agree with you that what you are describing is exactly the way I would expect the automation option to work as well.
But it is not working the way I would expect it to work, if it did it would not be turning on /Off the Inserts with the settings I showed you.

Maybe you are right and it is a feature request I would be happy with a short key option to bypass

active/focoused track Inserts and sends.

But if the Editor is not working as intended and I still believe that is the case, too me that is a bug and maybe Steinberg should look into it. Or at least offer a logical explanation why this behaviour is logical and intended.

Never the less I have reported it with Steinberg lets see what they say. I’ll keep you posted once I get an answer. :grinning:

Thank you for sharing your thoughts with me and trying to find a solution for my issue.

Have a great switchover to 2021

1 Like

Hi grz,

I think I have found a way to assign a short key for bypassing the Audio Inserts that also works on Instrument and sampler tracks.

I created A Macro and for my workflow this seems to be the best solution until Steinberg either create a short key for bypassing selected/focused tracks.

This approach has its draw backs and I will start by listing those.

  • You can not have the Mixer in the Lower Zone Open (ALT+F3) when using my version of the short key. If the (ALT+F3) Mixer is open the short key will be ignored. But it will work if the Normal Mix console Window (F3) is open.
  • If You need the Mixer in the Lower Zone to be Open for your workflow then you will need to assign a different Mixer to the Macro that you create. In my case I tried it with Mixer 3 Drawback of this approach is that
    • Only Cubase Pro offers Multiple Mixer Windows (I believe but not sure about this statement)
    • If you use the Main Mixer (F3) you will have the same restriction as mentioned with the Mixer opened in the Lower Zone (ALT+F3).
    • If you choose to use The Main Mixer or one of the other 3 Mixers the Mixer Window will flash on screen for a brief moment.
    • Depending on your Workflow you will loose one of your 3 Mixer windows to the extent that that Mixer window cannot be open when using the short key
  • If you have A EUCON controller do not assign the Macro as a EUCON command instead assign a short key to the Macro and use the key command to trigger the bypass.
  • This Macro does not bypass the MIDI inserts on Instrument and Sample Tracks if you need this you will have to add the respective command to the Macro or create a separate short key to do this.

Now for the Macro:

  • Create a new Macro in the Key Commands Editor.
  • Name it as you like. I named mine Toggle-Bypass Insert-eto
  • Add the Commands shown in the Image below to your macro
  • Add a key command to your Macro
  • Use it :blush:

Commands to add English Version:

Commands to add German Version:


Let me know if this worked for you and if it is something you are able to use.

1 Like

This is brilliant, thank you very much !!!1

Right now I use the macro with Mixer 3, it’s the most flexible approach. It works independent of any focus and doesn’t care if the lower mixer is open or not…

I’ve set up another similar macro (Mixer 3, Bypass: Inserts, Mixer 3) for bypasing all Inserts since the existing key command only works with the focus on a mixer.

Thanks again for your efforts and for sharing!

1 Like

Update:

Corrected version of this macro can be found on this post.