Worst support ever seen

I got Cubes Elements 11 as a gift.
Installed on Win10 64 20H2 64bit with admin privs.

The software installs properly, but not the licenser, It ends up with not getting access to the license server. Any action (with admin privs) fails, incl deactivating any AV.

Ticket created. Needs more than 4 weeks to get a reply with a link to a support program to fix the issue. Done. No improvement.

Even worse: Online Link to the ticket runs into error 404! So there is no chance to reply or update.

Is there any hope? What do you propose as Cubase alternative? I don’t see options to resolve this.

Since this is a Steinberg user support forum, it could be the wrong place to ask this…
At least we need information, what is the intended use for Cubase.
Recording? MIDI production?

Let us know if we should assist you with another try…

As this was a gift, it is not only disappointing for me. Therefore I would like to give it a last chance.

Did you used the Software Download assistant for the installation?

1 Like

Yeah, I think I was sent a reply to my issue, like, moths later XD…

I would post here buddy, this is an amazing community and people are extremely helpful.

Also browse for answers on this forum, I found a ton of extremely helpful info here.

Is there a specific message that the e-licenser throws?


Yes, I did use the Download Assistant. After I saw, that since my first try a newer version is available, I tried 1-31-1 as well after complete deinstallation.

Did you tried this?

What is the “Meine Produkt-Downloads” tab showing?
And it is updating automatically on start up if there are newer versions available.

The Download Assistant works fine, it is the eLicences behind, which fails to connect.

I just deinstalled and again installed (as admin admin and without firewall) everything.
The installation is not showing issues (except two images at the end):

2022-01-29 12:14:27.604 INFO 17444 — [JavaFX-Launcher] o.s.boot.SpringApplication : Starting application on capricorn with PID 17444 (C:\Program Files (x86)\Steinberg\Download Assistant\app\Steinberg Download Assistant.jar started by Frank in C:\Program Files (x86)\Steinberg\Download Assistant\app)
2022-01-29 12:14:27.605 INFO 17444 — [JavaFX-Launcher] o.s.boot.SpringApplication : No active profile set, falling back to default profiles: default
2022-01-29 12:14:30.761 INFO 17444 — [JavaFX-Launcher] n.s.e.d.d.a.internal.Aria2Configuration : Aria2 Installation found. Starting …
2022-01-29 12:14:30.823 INFO 17444 — [JavaFX-Launcher] n.s.e.d.c.SystemInformationServiceImpl : getPid() - This JVM’s name is ‘17444@capricorn’
2022-01-29 12:14:30.824 INFO 17444 — [JavaFX-Launcher] n.s.e.d.d.aria2.internal.Aria2Process : Start Aria2: C:\Program Files (x86)\Steinberg\Download Assistant\3rd Party\optional\aria2\aria2c.exe, --enable-rpc, --rpc-listen-all=false, --dir=C:\Users\Frank\Downloads\Steinberg, --auto-save-interval=1, --retry-wait=5, --max-concurrent-downloads=5, --max-overall-download-limit=0K, --max-tries=5, --stop-with-process=17444, --file-allocation=falloc
2022-01-29 12:14:30.879 INFO 17444 — [Thread-7] n.s.e.d.d.aria2.internal.Aria2Process : stream: 01/29 12:14:30 [e[1;32mNOTICEe[0m] IPv4 RPC: listening on TCP port 6800
2022-01-29 12:14:31.508 INFO 17444 — [JavaFX-Launcher] n.s.e.d.d.r.PersistedDownloadRepository : Loaded 5 persisted downloads
2022-01-29 12:14:31.629 INFO 17444 — [JavaFX-Launcher] n.s.e.d.c.UserAgentServiceFromSystem : getUserAgent() - User Agent: Steinberg Download Assistant/1.31.1 ({“ClientBits”:“32”, “OSName”:“Windows 10 Enterprise”, “OSVersion”:“10.0 (19041.1.amd64fre.vb_release.191206-1406)”, “OSBits”:“64”, “OSLanguage”:“de_DE”, “AriaVersion”:“1.18.10”}; +http://www.steinberg.net/en/extras/about.html)
2022-01-29 12:14:32.836 INFO 17444 — [JavaFX-Launcher] o.s.boot.SpringApplication : Started application in 5.773 seconds (JVM running for 8.853)
2022-01-29 12:14:32.841 INFO 17444 — [JavaFX-Launcher] n.s.elicenser.download.Application : Java Version: 1.8.0_312
2022-01-29 12:14:32.842 INFO 17444 — [JavaFX-Launcher] n.s.elicenser.download.Application : Java Home: C:\Program Files (x86)\Steinberg\Download Assistant\runtime
2022-01-29 12:14:33.134 INFO 17444 — [JavaFX Application Thread] n.s.e.d.selfupdate.SelfUpdateService : SelfUpdate completed … there is no newer version available…
2022-01-29 12:14:33.154 INFO 17444 — [JavaFX Application Thread] n.s.e.download.oidc.NimbusOIDCService : Restoring persisted authorization
2022-01-29 12:14:33.186 INFO 17444 — [JavaFX Application Thread] n.s.e.download.oidc.NimbusOIDCService : Refreshing authorization
2022-01-29 12:14:33.202 INFO 17444 — [JavaFX Application Thread] n.s.e.d.o.t.TokenRequestClientNimbus : Requesting tokens with grant refresh_token
2022-01-29 12:14:33.336 INFO 17444 — [JavaFX Application Thread] n.s.e.d.o.t.TokenRequestClientNimbus : Successfully retrieved tokens
2022-01-29 12:14:33.608 INFO 17444 — [JavaFX Application Thread] n.s.e.d.o.u.UserInfoRequestClientNimbus : Successfully retrieved userinfo
2022-01-29 12:14:33.609 INFO 17444 — [JavaFX Application Thread] n.s.e.download.oidc.NimbusOIDCService : Updating authorization successful
2022-01-29 12:14:34.538 INFO 17444 — [tornadofx-thread-1] n.s.e.d.r.RuntimeComponentServiceImpl : Found the following installed runtime components: [Steinberg Library Manager, eLicenser Control, Steinberg Install Assistant, Steinberg Activation Manager]
2022-01-29 12:14:34.978 INFO 17444 — [tornadofx-thread-1] e.d.g.r.RuntimeComponentUpdateController : No updates of runtime components necessary.
2022-01-29 12:14:41.958 ERROR 17444 — [Load product images] .e.d.p.ProductImageServiceImpl$Companion : Could not load image at path http://download.steinberg.net/automated_updates/sda_downloads/09fe1a8d-d057-4f3d-b683-f73b6b0d51b1/SpectraLayers-Elements-6_SDA_800x200.png. Will use default image instead.
2022-01-29 12:14:42.896 ERROR 17444 — [Load product images] .e.d.p.ProductImageServiceImpl$Companion : Could not load image at path http://download.steinberg.net/automated_updates/sda_downloads/09fe1a8d-d057-4f3d-b683-f73b6b0d51b1/SPECTRALAYERS-PRO-6_SDA_800x200.png. Will use default image instead.

And now (as admin admin and without firewall) I ran the elc-installation-helper.exe, which seems to perform a complete eLC-reinstall. No improvement. Still no connect to the License Server.

But doesn’t the Steinberg Download Assistant automatically update the elicenser software for you? Should you manually install the elicenser on top of it?

The advice with the helper came from the first response of the hotline yesterday evening. But as I have reinstalled everything just right now, it should all beup to the latest versions.


I see there’s a .3303 here?

Are you up to date with .NET framework and all that?


It tries to update, but fails.
The eLicenser itself is not yet registered. So I am not surprised that I cannot activate Cubase.
I have no clue, what might hinder eLC to establish a connection.

Unfortunately the same behaviour:

I don’t know what’s wrong, Frank. Maybe the other guys can help more.

For me, it’s easy. - Enter first code (Download Access Code) in Download Assistant. - Enter second code that comes to me by mail in Elicenser, and that’s all.

Thanks for your support.
The way you describe for activation is exactly what I would have expected as well.
My PC is usually on the last recent software versions whereever possible.

The only idea I have is, that the router blocks something. But I need to know the port, if changes are necessary.