Worst support ever seen

Does your router allow outgoing connections? If so, no changes needed.
Do you use wired connection to the router?

At least for any other software I use there are no blockings. At the moment I use a wired connection yes, but I can also try one of my WLANs.

Do you use Java based software on your system?

You’ll never know, which software has Java included (Steinbarg has, as it can be seen from the log above). But I don not have a explicit Java installation nor a path to Java set in the environment vars.

In C:\ProgramData\eLicenser\Logs20220129-122332_ELCC_General.txt I found the XML, which seems to be the registration for the eLC and the connected server:
licensetransfer.elicenser.net/POSFilesTransfer/servlet/POSFilesTransferServlet
Calling this server from ther browser returns a 102, probably the HTTP Error code for processing error, which can be expected with a bare call. But it means, my computer can connect to the license server.

But the log shows:
2022-01-29T12:23:39.319 - ELCC - → LCCProcessSendSupportInformation ended
2022-01-29T12:23:39.319 - ELCC - Exception occured->
2022-01-29T12:23:39.319 - ELCC - UnicodeMLS::getUMLSText EC: → 18446744073709551615
2022-01-29T12:23:39.319 - ELCC - UnicodeMLS::getUMLSText Reason: →
2022-01-29T12:23:39.319 - ELCC - UnicodeMLS::getUMLSText MLSKey: → LCC_LSEXCEPTION_ERROR_LS_NOT_AVAILABLE
2022-01-29T12:23:40.744 - ELCC - → LCCProcessMaintenance ended
2022-01-29T12:23:40.750 - ELCC - THREAD SWITCH!!! Entered thread: 2A50
2022-01-29T12:23:40.750 - ELCC - → LCCProcessGetELicenserDescriptionList started

The point is, it’s working on many systems at the moment. So the server is up and running.
But some rare systems fail on this.
Maybe @Ed_Doll or a moderator (@steve or @Martin.Jirsak ) can chime in and suggest some troubleshooting.
I have no ideas left for now.

Nothing in your hosts file blocking it?

What should this be like?

c:…>ping licensetransfer.elicenser.net

Ping wird ausgeführt für licensetransfer.elicenser.net [212.79.59.34] mit 32 Bytes Daten:
Antwort von 212.79.59.34: Bytes=32 Zeit=20ms TTL=59
Antwort von 212.79.59.34: Bytes=32 Zeit=18ms TTL=58
Antwort von 212.79.59.34: Bytes=32 Zeit=18ms TTL=58
Antwort von 212.79.59.34: Bytes=32 Zeit=17ms TTL=58

Ping-Statistik für 212.79.59.34:
Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
(0% Verlust),
Ca. Zeitangaben in Millisek.:
Minimum = 17ms, Maximum = 20ms, Mittelwert = 18ms

I think it has nothing to do with the network itself, I think something fails to talk to the server in the right way. Something inside the eLicenser software.
Did you enter the activation code somewhere already?
Did you installed the software with the Download Activation Key successful?
Or did this fail as well?

The software installation looks good. In the download manager I can enter the Download Access Code and it returns the License Activation Code. But the activation fails.

If I try to register the licenser itself, it fails:

What Windows version are you using buddy?

Are you using the latest service pack?

Are you all up to date??

A lot of things wont work with Cubase and e-licensers in general, unless you have the latest Windows and latest service packs.

I hope this helps

I found a suggestion to fix the issue here on this forum,

Fail Code 1001 can be fixed this way (follow link and suggestion):

Sorry, you missed the point… he already tried this many times, but it always fails to connect to the server… this happens from the beginning.

He mentioned this already… yes his system is up to date…

@Frank_Tiex
Do you have a MySteinberg account?

Fair enough…

Thanks for your patience. A new clue:
In the eLC I enabled logging and created a support file.
I had a look inside and found some errors with the MS VC++ redistributable!
(packed the file in a ZIP for upload, TXT and the original GZ extension are not allowed for upload here)
In fact I find two MS VC++ Redistr. 2015-2019 on my system: 14.28.29914 (installed today) and 14.27.29016 (from 26.04.2021, so from other software). I ran the “repair” option for the younger one. No success. Deinstalled the second one. Still the eLC (always closed and restarted) shows the same connection failure.

Entpacke Dateien
Installiere VC-Redistributable
Executing C:\Users\Frank\AppData\Local\Temp/eLC_Installer_6.12.8.2300_20220129-122300/VCRedistributable/VC_redist.x86.exe /install /quiet /norestart
Script exit code: 1638

Script output:

Script stderr:
Program ended with an error exit code

Fehler beim Ausführen C:\Users\Frank\AppData\Local\Temp/eLC_Installer_6.12.8.2300_20220129-122300/VCRedistributable/VC_redist.x86.exe /install /quiet /norestart: Program ended with an error exit code
[12:23:01] VC redistributable x86 installation failed; error code: ‘1638’
Executing C:\Users\Frank\AppData\Local\Temp/eLC_Installer_6.12.8.2300_20220129-122300/VCRedistributable/VC_redist.x64.exe /install /quiet /norestart
Script exit code: 1638

Script output:

Script stderr:
Program ended with an error exit code

Fehler beim Ausführen C:\Users\Frank\AppData\Local\Temp/eLC_Installer_6.12.8.2300_20220129-122300/VCRedistributable/VC_redist.x64.exe /install /quiet /norestart: Program ended with an error exit code
[12:23:02] VC redistributable x64 installation failed; error code: ‘1638’
Entpacke Dateien
Entpacke Dateien
Entpacke Dateien
Entpacke Dateien
Entpacke Dateien
Entpacke Dateien
Konfiguriere eLicenser-Control-Komponente
Executing C:\WINDOWS\system32\icacls.exe C:\Windows\System32\SYNSOACC.dll /grant:r *S-1-1-0:RX /Q /C
Script exit code: 0

Script output:
1 Dateien erfolgreich verarbeitet, bei 0 Dateien ist ein Verarbeitungsfehler aufgetreten.

Script stderr:

Entpacke Dateien
[12:23:04] Installing driver, expecting error code ‘1’ or ‘256’
Installiere eLicenser-Treiber
Executing C:\Users\Frank\AppData\Local\Temp/eLC_Installer_6.12.8.2300_20220129-122300/eLicenser Driver Package - x64/DPInst.exe /se /sa /sw /f
Script exit code: 256

Script output:

Script stderr:
Program ended with an error exit code

eLC Support File.txt.zip (15.9 KB)

I downloaded the latest versions of the Redistributables, both 14.30.30708 (meanwhile named MS VC++ 2015-2022) for x86 and x64, installed both and restarted the machine. No improvement :frowning:

So, the point here could be that the installation of the VC++ package fails…

damn…

I think read somewhere in the forum, that another user had a similar problem, because some paths were pointing to different locations. What I could try is to uninstall everything again incl the VC++ packs, then reboot and reinstall from scratch again.