Wrong chord in score

When trying to put in a Em7 chord in the score it turn out to be D#m7. In the sopranosax part in wright, F#m7 transpose.(see film)

Please upload the project (or a cutdown version of the project) as per the (fourth of the) guidelines.

The video gives a useful illustration of the symptoms but won’t help with the cause of the problem.

It’s there

Interestingly, entering Em7/E gives that as the chord symbol, but Em7 doggedly keeps showing D#m7 - on all the instruments. It happens in Dorico 3.5.12 also.

The problem is definitely that something in Library > Chord Symbols (aka Engraving Options > Chord Symbols > Project Default Appearances) has been meddled with, but I don’t have the nous to work out what. The list of overrides there doesn’t show anything for this specific chord symbol, nor do the Chord Symbol Appearances or Chord Symbol Components in the Library Manager.

You can definitely fix it by going to Library > Chord Symbols and using the Reset to Factory button at the bottom; hopefully someone from the development team will be able to figure out a more targeted method.

Further to Leo’s suggestion:

In Library > Chord Symbols… > Project Default Appearances, deleting the D#m7 seems to have the desired effect.

Continuing the discussion from Wrong chord in score:

Still have this problem with chords not showing right. Please make the chords and the chord editor a fix, lot of bugs!

As pointed out in the other thread, this is all a result of your overrides. I don’t have your fonts installed, but if I delete all of your overrides, all the roots transpose correctly in the gif below. (I added changes in the Bari part for reference.)


The chord symbol Project Default Appearances overrides are really for modifying the design of each suffix, not manually transposing roots. (There really should be an option to modify a suffix for all roots too.) Since I don’t have your fonts, what design changes were you trying to accomplish with the overrides? There may be Engraving Options to accomplish the same, or some global library changes that can accomplish the same results without manually reassigning roots.

This problem happens frequently(see film)

As mentioned above, you must have overridden the appearance of these chord symbols in such a way that Dorico will use them as defaults in future. Please upload the project you’re working on so we can take a closer look.

The problem is in bar 43 and bar 51. The chord should be Bm7b5 and displace as C#m7b5.

Hmm, I’m sorta stumped. I think there could be some sort of bug at play here. I’ve narrowed it down and it’s definitely this override causing an issue:

However, that clearly shows up in Project Default Appearances as an override for C#m7(b5), not Bm7(b5). It’s also not the chord that’s displaying in the score, as the override has MI7b5 and the score has m7b5. With that override deleted, the score now shows this (I obviously don’t have the specified fonts):

I count 17 (!) overrides for the B glyph though.

I don’t have time to check all of them, but possibly one of them is affecting things too.

Apologies for not being able to follow, but what specifically is the bug here? I can see that there’s a Bm7b5 chord in b.43 of the “1983.dorico” project but I’m not sure what’s supposed to be wrong with it.

Try entering an Em7 chord symbol (anywhere) - it magically morphs into a D#m7 symbol. Weird!

That’s not happening for me, inputting into the Full Score, whether I’m using Concert pitch or Transposed pitch - I get an Em7. (This is in 4.3.11)

Well it happens here (also 4.3.11) - even with all options returned to factory settings in Library manager.

Are you inputting the chord from the popover or MIDI keyboard? What instrument do you have selected when you start chord input?

Popover (shift-q em7). Any instrument.

Ah, I can reproduce this with just “Em” on its own - I’ll take a look, thanks.

Curious. Em works fine here. It is only Em7 that appears as D#m7. Every other chord I’ve tried works as expected.