Alt+Tab Windows Switching

Hi,
I just updated from Cubase 12 to 13. Can anyone explain why the ALT+TAB shortcut (Windows) isn’t working? It only works when Cubase doesn’t have additional windows open or when the mixer window is open. If the Transport Panel or video window is open, the ALT+TAB shortcut doesn’t switch to the main Cubase window.
So, for example, I have Chrome running on the first virtual desktop. On the second virtual desktop, I have Cubase with the Transport Panel open. Now I’m in Chrome. I press ALT+TAB, and only the Transport Panel appears. The entire Cubase doesn’t show up. Do you also experience this?
Best regards
Jarek

1 Like

As per the Cubase 13 release notes, the Cubase windowing behaviour has been changed to be more native to Windows standards.

I addition, things behave slightly different when a Cubase sub window has been set to “always on top”.

Also worth exploring: Ctrl-tab to switch between different Cubase windows.

I have various programs open. ALT+TAB switches between them seamlessly. The only program that doesn’t appear is Cubase. In my opinion, it’s just an inconvenience. Now, to switch between another program and Cubase, I have to swipe four fingers on the touchpad of my laptop, whereas for years, it simply worked with ALT+TAB. CTRL+TAB is something else. I want to switch between, for example, Chrome and Cubase. It used to be so simple and natural. Now it’s not.
By the way. Transport Panel and video window can’t be set to Always on display.

1 Like

EDIT:

I think I misunderstood the original scenario, which seems to be related to using virtual desktops.

Next post (immediately below this) is hopefully more applicable.

I think I was finally able to replicate what you described using multiple virtual desktops on Windows 10.

It seems that when Cubase has one or more “always on top” type of windows open (which includes the Transport Panel, which is always configured to “always on top”), then the Alt-Tab key combination to go back to the main Cubase Window does not display the main Cubase Window, but just the “always on top” windows. Interestingly enough, the main Cubase window is invisibly active, since Key Commands (like Play and Stop) seem to work .

Hitting Ctrl-Tab after Alt-Tab seems to display the main Cubase Window ok - and things seem normal. - At least on my system. (Assuming I’ve set the Windows Settings > System > Multitasking configured, so Alt-Tab shows open windows across all virtual desktops).

I have no idea if this is technically a bug that can be fixed by Steinberg, or if it’s a Windows limitation to the “always on top” child window implementation that Cubase uses.

A couple of potential workarounds that may be more or less satisfying, depending on one’s particular workflow:

  • Avoid the Transport Panel (and any other “always on top” Cubase panels and windows, but add Transport controls to the top Toolbar or bottom Transport Bar of the main Cubase window instead,

or

  • Use some sort of Windows scripting (e.g. Powershell and/or AutoHotKey) to create a single key command execute a sequence of commands and/or keystrokes to navigate to the main Cubase Window.

Thank you for your response.
I need the transport panel at the top and in a separate window. So, this solution is not suitable for me ;))
Second, In every project, I work with video, so the video window is open all the time.
Conclusion. After the update, the program is unsuitable for me :))
Really, I don’t understand why they did it.

Hi @nilbul

Thanks for your report. I would like to help but I am a little bit confused but maybe I’m not the power user of virtual desktops on Windows yet so I’m eager to learn something.

You are using several virtual desktops but you are referring to alt+tab in this thread whereas alt+tab only works within one desktop and not throughout several virtual desktops. If I want to switch from one virtual desktop to another one I personally use Windows+tab.

So which use case are you referring to exactly?

Thank you very much for your help!

Cheers,
Armand

I’m going to jump in here with something that’s at least related, if not the same problem (and I don’t use virtual desktops):

Every other Windows program I use that uses multiple windows allows me to Alt-Tab to the window I need - except Cubase: If I Alt-Tab to the project window (the one with the timeline), it will not get selected (go into the foreground). Oddly enough, if I Alt-Tab to the Mixer window (which I also have open), it will then activate all of the Cubase Windows (incl. the Project window), which I then can Alt-Tab to.

Hi Armand. I have just upgraded to cubase 13. I have no virtual desktops, and alt+tab stopped working.
So to replicate:

  • Just have cubase open
  • alt+ tab (this switches to another program)
  • alt+tab (this should switch back to cubase but it does not!)
    I have to manually click on taskbar to get back to cubase. It’s really annoying.
2 Likes

Yes. This is an issue for sure. I started a thread a while ago that dives deeper into this issue, and am including it here for reference:

Hi @docencik

Thank you very much for your report. I am unfortunately no longer personally in charge of this area. Since it is a new bug to us I have informed the relevant people about it.

Cheers,
Armand

Hi,
there will be a fix for the window activation when switching back from another application (including alt+tab) in the next Cubase update.

Cheers,
Marc

1 Like

Hi @Timo00,
this behavior was already changed with the Cubase 13.0.30 update. Only the window you are activating (+ maybe popups and always on top windows) should come into foreground.

Cheers,
Marc

Hi, unfortunately, this is not fixed in 13.0.30. You can find an example of this, reported by somebody else, here:

My original thread, with all the gory details, including a new finding in 13.0.30, is here:

Hi Marc, great to hear, thanks for working on these issues!
I assume that is also the issue that I described here (dont be able to switch back to cubase from another application when the cubase video window is on fullscreen mode)?
Cubase 13.0.30 bug when switiching between windows

I have also found a problem with window-handling when I drag&drop an audiofile from the explorer into my timeline:
Windows Explorer is in foreground and focussed → I drag&drop the audiofile into the timeline → Cubase does not come into focus when it shows the “import options” window. Also I can’t just ALT+TAB and switch to Cubase (nothing happens when I do that), I have to ALT+TAB to the “import-options” window (which in addition is always at the very end of the row of opened windows in the “ALT+TAB” menu).

this behavior was already changed with the Cubase 13.0.30 update. Only the window you are activating (+ maybe popups and always on top windows) should come into foreground.

→ yes, switching back from another application to the project window, the mixer or another cubase window works on my system as long as I don’t have the cubase video window in fullscreen mode (on a second screen) :smiley:

My system: Win 11 and Cubase 13.0.30

1 Like

Hi,

That’s exactly the issue we’ve fixed for the next update. The issue is not only limeted to the video window but also happening when other popup windows are open.

I just checked and can confirm the issue. I will see what I can do.

cheers,
Marc

2 Likes

Hi, okay great to hear, thanks a lot! :slight_smile: