Audio recorded with dropouts SHOWSTOPPER issue [ROOT CAUSED]

EDIT: Rootcaused the issue. It is not Cubase’s fault. It’s an RME ADAT issue - ADAT (unit to which mics were connected) went out of sync periodically leading to gaps in the input audio. Waiting for RME’s response to the problem.

I record a stereo audio track in cubase with audio inputs. The track has a track preset like “rock vocals”.

It’s recorded with gaps in between every few seconds. This is a pretty serious issue and highly annoying.

Attaching pic:



When I’m playing back the track I look at VST Performance and its hovering around 25% and the disk is around 0% BUT every now and then the disk spikes to 100% (correlated with a dropout in audio).

Win 7 x64, RME 9652, C7.5.4, buffers 256.

The project consists of ~100 tracks but this audio track was recorded in isolation with no other tracks playing at the same time. PLEASE HELP!

You might have too many audio tracks, even though they were not playing.

Try and recording another track like it, and see if something similar happens.

Hit F12 (the meter) and see how hot the meters are.

Are you at a low buffer size? … See if things are better if you make it bigger.

I have exactly 3 audio tracks in total with one of them muted.

The buffer is 256 which plays back fine at CPU ~25%.

Let me note this rig works perfectly fine in Reaper with hundreds of tracks, audio or otherwise. This is the first time I"m experiencing this kind of an issue.

You’re welcome!

How many VSTi’s do you have running? Might try temporarily cutting back on the #s if you do and see if that makes a difference.

Also, would see what happens if you push out the buffer.

Also turn off wifi/internet, security programs, other unnecessary things in case they are interrupting the audio processing.

Have you run Latency Mon?

Hi Alexis - thanks so much for trying to help. The buffer was previous at 64 which I’ve bumped up to 256 and seeing these issues. Again from my performance meter it is not an issue - only the disk meter spikes up to 100% randomly.

Yes I’ve run latency mon for 20 mins and it comes back perfectly fine for audio. I’ve been using reaper for several years prior and have not run into any performance issues since my computer is pretty powerful.

All wifi/security is turned off. All VSTis are running in a slave computer so cubase has nothing to process except for midi and 3 audio tracks with some fx.

Wow, that is a head scratcher. Does it make any difference if you run different VSTI’s? Or to simplify even more, disconnect from your slave and just run a few Halion Sonic SE VSTi’s?

This does not sound like a performance problem.

Does this happen on other tracks?

Do you have a demo version of any VST plugins installed?

Any Inserts on the inputs?

Hi Steve - Yes I have an issue with audio playback alone (midi plays back fine). When I playback an audio track it produces a crackle every few seconds. If I change my disk preload cache setting to, say 3 seconds, the crackles reflect that setting. No other setting seems to make a difference.

No demo VSTs - the track has reaEq, reaComp, Nectar 2, and Cubase PitchCorrect.

Also, get this - whenever I locate the play head, there’s a spike in the disk activity to 100%, even though the song isn’t playing.

@Alexis - this is just purely an audio thing. Doubt if the VSTs has anything to do with it but I can try. The big red flag for me is the disk activity spiking during audio playback.

Can you try files on a different disk?

I was looking at the .pdf of known issues, and saw some that might be worth looking at in your case.

16138: ASIO dropouts
occur when working with tools
showing “Extra Info” as tooltips
ASI O
dropouts
may occur when working with tools showing
“Extra Info” as tooltips in the Project window or inside the
MIDI Editors on PC Windows systems.
Plea
se disable “Select Tool: Show Extra Info” under
Preferences > Editing Tools


12307
: Projects using a significant amount of audio
material in m
usical
mode with élastique tend to
consume more dis
k load and drop
outs
may occur
The
élastique v3
algorithm
consumes more computer
resources. In critical cases please
switch back to the
élastique efficient mode or s
tandard algorithms —
or
consider bouncing the audio files.



Version
History
/ Known Issues and S
olutions
Page
12
Steinberg Media Technologies GmbH

9921: Performance peaks with certain plug
-ins under
Windows
Using CPU intensive plug
-ins (for example, VST Connect
SE) may cause ASIO peaks if the Windows power scheme is
set to “balanced” and ASIO
-Guard is enabled. To avoid
these peaks, please make sure to enable the “Steinberg
Audio Power Scheme” under Devices > Devices setup >
VST. For more information, refer to:
https://www.steinberg.net/en/support/knowledgebase_ne
w/show_details/kb_show/optimizing

w
indows

for

daws.html



6594:
When using e.g. HALion Sonic SE connected
with several MIDI t
racks
to use it as one multi-
timbral
VST
instrument
instance, clicking “Rec
-Enable” on
one of the connected MIDI channels may increase the
ASIO load significantly
Multi
-timbral VST Instruments can be only processed as a
whole in conjunction with ASIO
-Guard. If one of the
connected MIDI channels is enabled for record, the whole
Instrument switches back to real
-time operation and thus
may increase the ASIO load. Please consider using
dedicated Instrument instances for each sound instead of
using just one instance with several sounds loaded.



2926:
Opening then closing a project and opening the
same project directly afterwards again consu
mes
large amount of memory and may render the
application unreliable
There is currently no workaround except loading another
(smaller)
project in-
between.

Don’t know why they formatted that way with a copy/paste, but it’s just for quick review, in case it’s part of what’s going on with you by any small chance.

Hope that’s helpful!

Have you confirmed that the hard drive streaming the audio is 100% solid?

Try setting CPU Core Affinity to Core 0 (instead of All Processors) in the Task manager/Details /Cubase 7.5.exe (right click)
I have to do this to get dropout-free playback from my ASIO system. This is only on a 64-bit OS. The same computer on a 32 bit boot partition does not have this problem. I’m told this is likely a hardware conflict interrupting CPU access, maybe my graphics card. Haven’t had a chance to test this yet but the affinity setting lets me work around for now. maybe it will for you.

/Dave

Examine your system if it has running processes which do virus scanning, updating libraries etc, also check if you have running indexing software.

I also saw the suggestion to checkup your hard drives, this seems to me the first thing which you want to rule out, best is to run test software with burn-in test facilities (these test are supposed to run for at least 24 hours and do tests multiple times).

First of all - thanks for trying to help! Really appreciate it as this is driving me nuts.

I’ve tried all the below with NO difference whatsoever:

1). Tried a different disk (an SSD drive)
2). Set Core affinity to Core 0
3). Changed buffer size from 128 to 1024 samples
4). Disabled all inserts & sends on the audio channel

Its none of the known issues posted by alexis. There is no virus scanning/updating libraries and there’s no gate anywhere - as I mentioned earlier this all works perfectly fine in Reaper with hundreds of tracks.

What’s most puzzling is the audio waveform itself has the gap instead of it just being an audible gap (which would point to a perf issue).

I would suggest opening a support ticket.

UPDATE:

Okay I’ve figured out the issue. I tried recording with another MIC input and it works fine, no issues. The issue seems to be with my soundcard - RME 9652 (GASP!!) whose ADAT 2 input (i.e. my mics) keeps going in and out of sync periodically. The working MIC is from ADAT 1 which stays stable and in sync.

This is the issue I"m seeing:
https://www.steinberg.net/forums/viewtopic.php?f=209&t=60470

This one truly was a head scratcher and I’m really shocked that RME is the fault here. Usually its anything BUT RME. Anyways, sincere thanks for all those that tried to help! :slight_smile:

Wow. Glad you found it!

have you tried replacing your adat cable’s?

No but highly doubt if that’s the issue as the same batch of adat cables are being used from my 9652 to BF which works fine.

The issue is solved by making the ADA8k the master and the 9652 the slave though I’m still waiting on RME’s word on this workaround’s implications.

No but highly doubt if that’s the issue as the same batch of adat cables are being used from my 9652 to BF which works fine.

I wouldn’t trust a batch for that matter persé, just switch the 2 adat cables (if using in/out) and see what happens, adat capable devices sync through the adat cable (some can do world clock) and the dropouts are typically what happens when a adat cable misbehaves.

I guess I advise this to you as it is a simple and not costly troubleshoot step, if it ain’t this then it’s ruled out and you just head to your next step.